summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel2020-06-26 10:45:55 +0200
committerDaniel2020-06-26 10:45:55 +0200
commit1555f23eafe83cbd2d76fa6d023fb65550c02d82 (patch)
tree5df094204d83ad3088f1b903198ac30a5800c76c
parent6051176fb732268e89eeac07f94ea098f8dd6269 (diff)
downloadaur-1555f23eafe83cbd2d76fa6d023fb65550c02d82.tar.gz
Accomplish the rules and fix the sources line
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d28db35060ab..496919c6a579 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,8 +20,8 @@ optdepends=('kde-cli-tools: for editing file type options' 'ffmpegthumbs: video
'konsole: terminal panel' 'purpose: share context menu')
conflicts=($_pkgname)
provides=($_pkgname)
-source=("https://invent.kde.org/system/dolphin/-/archive/$pkgver/dolphin-$pkgver.tar" '0001-Revert-Disallow-executing-Dolphin-as-root-on-Linux.patch' 'Dolphin-Root-Git.desktop')
-sha256sums=('034f60c5e859209805762f149b90a893cf2eca2dda71daa14bceed6070784ed3'
+source=("git+https://invent.kde.org/system/dolphin.git" '0001-Revert-Disallow-executing-Dolphin-as-root-on-Linux.patch' 'Dolphin-Root-Git.desktop')
+sha256sums=('SKIP'
'bb043810c2777be4657a8c4f386a6497ed6169b0857f214c35aac435da040401'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <aacid@kde.org>
@@ -33,13 +33,14 @@ pkgver() {
prepare() {
mkdir -p build
- cd dolphin-$pkgver
+ cd dolphin
+ git reset --hard $pkgver
patch -p1 -i ../0001-Revert-Disallow-executing-Dolphin-as-root-on-Linux.patch
}
build() {
cd build
- cmake ../dolphin-$pkgver \
+ cmake ../dolphin \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=OFF