summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel2020-06-25 21:35:03 +0200
committerDaniel2020-06-25 21:35:03 +0200
commit6051176fb732268e89eeac07f94ea098f8dd6269 (patch)
tree196e5474a1b2c4462ab38ea5abcc443f1e62f867
parent9a6532a87a6cc1f3afd75e8dd417b4ae5ac1f393 (diff)
downloadaur-6051176fb732268e89eeac07f94ea098f8dd6269.tar.gz
Update Sources URL and add SHA256 sums for sources
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f693de52c1aa..4249cb71fa34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -25,14 +25,14 @@ pkgbase = dolphin-root-git
optdepends = purpose: share context menu
provides = dolphin
conflicts = dolphin
- source = https://invent.kde.org/system/dolphin.git
+ source = https://invent.kde.org/system/dolphin/-/archive/d1baf3398e53931735b724672d5ae48649b44a18/dolphin-d1baf3398e53931735b724672d5ae48649b44a18.tar
source = 0001-Revert-Disallow-executing-Dolphin-as-root-on-Linux.patch
source = Dolphin-Root-Git.desktop
validpgpkeys = CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7
validpgpkeys = F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87
- sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = SKIP
+ sha256sums = 034f60c5e859209805762f149b90a893cf2eca2dda71daa14bceed6070784ed3
+ sha256sums = bb043810c2777be4657a8c4f386a6497ed6169b0857f214c35aac435da040401
+ sha256sums = SKIP
pkgname = dolphin-root-git
diff --git a/PKGBUILD b/PKGBUILD
index ba0df82387b4..d28db35060ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,10 +20,9 @@ optdepends=('kde-cli-tools: for editing file type options' 'ffmpegthumbs: video
'konsole: terminal panel' 'purpose: share context menu')
conflicts=($_pkgname)
provides=($_pkgname)
-source=("https://invent.kde.org/system/dolphin.git"
- '0001-Revert-Disallow-executing-Dolphin-as-root-on-Linux.patch' 'Dolphin-Root-Git.desktop')
-sha512sums=('SKIP'
- 'SKIP'
+source=("https://invent.kde.org/system/dolphin/-/archive/$pkgver/dolphin-$pkgver.tar" '0001-Revert-Disallow-executing-Dolphin-as-root-on-Linux.patch' 'Dolphin-Root-Git.desktop')
+sha256sums=('034f60c5e859209805762f149b90a893cf2eca2dda71daa14bceed6070784ed3'
+ 'bb043810c2777be4657a8c4f386a6497ed6169b0857f214c35aac435da040401'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <aacid@kde.org>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <cfeck@kde.org>
@@ -34,14 +33,13 @@ pkgver() {
prepare() {
mkdir -p build
- cd dolphin
- git reset --hard $pkgver
- patch -p1 -i $srcdir/0001-Revert-Disallow-executing-Dolphin-as-root-on-Linux.patch
+ cd dolphin-$pkgver
+ patch -p1 -i ../0001-Revert-Disallow-executing-Dolphin-as-root-on-Linux.patch
}
build() {
cd build
- cmake ../dolphin \
+ cmake ../dolphin-$pkgver \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=OFF