summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordus20022020-02-21 19:18:39 +0100
committerdus20022020-02-21 19:18:39 +0100
commit892031125bff1d9f3564c61bb6043508b0f14f50 (patch)
tree8273bad1e1f5b1ad7c02136923ed244bc7143990
downloadaur-892031125bff1d9f3564c61bb6043508b0f14f50.tar.gz
First commit
-rw-r--r--.SRCINFO36
-rw-r--r--0001-Revert-Disallow-executing-Dolphin-as-root-on-Linux.patch42
-rw-r--r--PKGBUILD48
3 files changed, 126 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eec5644a036d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = dolphin-root-git
+ pkgdesc = KDE File Manager, patched to be able to run as root, based on dolphin-git sources
+ pkgver = r4888.8b12612
+ pkgrel = 1
+ url = https://kde.org/applications/system/dolphin/
+ arch = armv7h
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = extra-cmake-modules
+ makedepends = kdoctools
+ depends = baloo-widgets
+ depends = knewstuff
+ depends = kio-extras
+ depends = kcmutils
+ depends = kparts
+ depends = kinit
+ depends = phonon-qt5
+ optdepends = kde-cli-tools: for editing file type options
+ optdepends = ffmpegthumbs: video thumbnails
+ optdepends = kde-thumbnailer-odf: ODF thumbnails
+ optdepends = ruby: installing new service menus from KDE Store
+ optdepends = kdegraphics-thumbnailers: PDF and PS thumbnails
+ optdepends = konsole: terminal panel
+ optdepends = purpose: share context menu
+ provides = dolphin
+ conflicts = dolphin
+ source = git://anongit.kde.org/dolphin.git
+ source = 0001-Revert-Disallow-executing-Dolphin-as-root-on-Linux.patch
+ validpgpkeys = CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7
+ validpgpkeys = F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87
+ sha512sums = SKIP
+ sha512sums = SKIP
+
+pkgname = dolphin-root-git
+
diff --git a/0001-Revert-Disallow-executing-Dolphin-as-root-on-Linux.patch b/0001-Revert-Disallow-executing-Dolphin-as-root-on-Linux.patch
new file mode 100644
index 000000000000..1bb9355d465e
--- /dev/null
+++ b/0001-Revert-Disallow-executing-Dolphin-as-root-on-Linux.patch
@@ -0,0 +1,42 @@
+From ba74d639178916221c748b0d5d89f7ac4f5ed669 Mon Sep 17 00:00:00 2001
+From: Fabian Vogt <fabian@ritter-vogt.de>
+Date: Sat, 22 Apr 2017 14:00:33 +0200
+Subject: [PATCH] Revert "Disallow executing Dolphin as root on Linux"
+
+This reverts commit 0bdd8e0b0516555c6233fdc7901e9b417cf89791.
+We ship a desktop file to open dolphin as root and we allow YaST on the
+desktop. So this patch is absolutely pointless for us.
+---
+ src/main.cpp | 13 -------------
+ 1 file changed, 13 deletions(-)
+
+Index: dolphin-18.07.70git.20180603T132131~3c6ecfa24/src/main.cpp
+===================================================================
+--- dolphin-18.07.70git.20180603T132131~3c6ecfa24.orig/src/main.cpp
++++ dolphin-18.07.70git.20180603T132131~3c6ecfa24/src/main.cpp
+@@ -35,25 +35,8 @@
+ #include <QApplication>
+ #include <QCommandLineParser>
+
+-#ifndef Q_OS_WIN
+-#include <unistd.h>
+-#endif
+-#include <iostream>
+-
+ extern "C" Q_DECL_EXPORT int kdemain(int argc, char **argv)
+ {
+-#ifndef Q_OS_WIN
+- // Prohibit using sudo or kdesu (but allow using the root user directly)
+- if (getuid() == 0) {
+- if (!qEnvironmentVariableIsEmpty("SUDO_USER")) {
+- std::cout << "Executing Dolphin with sudo is not possible due to unfixable security vulnerabilities." << std::endl;
+- return EXIT_FAILURE;
+- } else if (!qEnvironmentVariableIsEmpty("KDESU_USER")) {
+- std::cout << "Executing Dolphin with kdesu is not possible due to unfixable security vulnerabilities." << std::endl;
+- return EXIT_FAILURE;
+- }
+- }
+-#endif
+
+ QApplication app(argc, argv);
+ app.setAttribute(Qt::AA_UseHighDpiPixmaps, true);
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca8020f27e2c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Mantainer: Daniel Urdiales <daniurdi46@gmail.com>
+# Contributor: David P. <megver83@parabola.nu>
+# Contributor: Antonio Rojas <arojas@archlinux,org>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Pierre Schmitz <pierre@archlinux.de>
+
+pkgname=dolphin-root-git
+_pkgname=${pkgname%-root-git}
+pkgver=r4888.8b12612
+pkgrel=1
+pkgdesc="KDE File Manager, patched to be able to run as root, based on dolphin-git sources"
+arch=(armv7h i686 x86_64)
+url="https://kde.org/applications/system/dolphin/"
+license=(LGPL)
+depends=(baloo-widgets knewstuff kio-extras kcmutils kparts kinit phonon-qt5)
+makedepends=(extra-cmake-modules kdoctools)
+optdepends=('kde-cli-tools: for editing file type options' 'ffmpegthumbs: video thumbnails' 'kde-thumbnailer-odf: ODF thumbnails'
+ 'ruby: installing new service menus from KDE Store' 'kdegraphics-thumbnailers: PDF and PS thumbnails'
+ 'konsole: terminal panel' 'purpose: share context menu')
+conflicts=($_pkgname)
+provides=($_pkgname)
+source=("git://anongit.kde.org/dolphin.git"
+ 0001-Revert-Disallow-executing-Dolphin-as-root-on-Linux.patch)
+sha512sums=('SKIP'
+ 'SKIP')
+validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <aacid@kde.org>
+ F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <cfeck@kde.org>
+
+prepare() {
+ mkdir -p build
+ cd dolphin
+ patch -p1 -i $srcdir/0001-Revert-Disallow-executing-Dolphin-as-root-on-Linux.patch
+}
+
+build() {
+ cd build
+ cmake ../dolphin \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_TESTING=OFF
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}