summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuentin Bouvet2020-11-04 18:43:01 +0100
committerQuentin Bouvet2020-11-04 18:43:01 +0100
commit14d9934863a2c6bd052725abdb540bbfbc28d8f5 (patch)
tree00fbadb0fa4709f90716f53ee10df28d1c5ebd0d
downloadaur-dolphin-squashfs-mount.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f62bf39a0493
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = dolphin-squashfs-mount
+ pkgdesc = Mount squashfs archives in dolphin right-click menu
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/shvchk/dolphin-squashfs-mount
+ arch = any
+ license = GPLv3
+ depends = dolphin
+ depends = squashfuse
+ source = dolphin-squashfs-mount-1.0.tar.gz::https://github.com/shvchk/dolphin-squashfs-mount/archive/v1.0.tar.gz
+ sha256sums = d0699590502350a70c0cb2d88cf4e872e85117f6b5c37cc05b14a0e48ebee1e7
+
+pkgname = dolphin-squashfs-mount
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..281390b1f263
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+
+# Maintainer: Quentin Bouvet <qbouvet at outlook dot com>
+pkgname=dolphin-squashfs-mount
+pkgver=1.0
+pkgrel=1
+pkgdesc="Mount squashfs archives in dolphin right-click menu"
+arch=('any')
+url="https://github.com/shvchk/dolphin-squashfs-mount"
+license=('GPLv3')
+depends=('dolphin' 'squashfuse')
+
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/shvchk/dolphin-squashfs-mount/archive/v1.0.tar.gz")
+sha256sums=('d0699590502350a70c0cb2d88cf4e872e85117f6b5c37cc05b14a0e48ebee1e7')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -D -m0755 -t "${pkgdir}/usr/share/kservices5/ServiceMenus/" \
+ "squashfs-mount.desktop"
+}
+
+#
+# makepkg --printsrcinfo > .SRCINFO
+#