aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDian Fay2016-09-24 02:48:20 -0400
committerDian Fay2016-09-24 02:48:20 -0400
commit80061b1659a701899b9f404cde44f624624d5765 (patch)
tree6e4a5ac34c66b17ff39a6d4bd56038cf1de46028
parent82dd96d0f933c0ac3844c5091cf5cd5aa29969f2 (diff)
downloadaur-80061b1659a701899b9f404cde44f624624d5765.tar.gz
more doco
-rw-r--r--PKGBUILD4
-rw-r--r--README.md14
-rwxr-xr-xdom44
3 files changed, 15 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 73277ed1e02f..3e6894b0dcde 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Dominions 4 Server Configuration
# Maintainer: Dian Fay <dian.m.fay@gmail.com>
pkgname=dom4-server
-pkgver=1.0.2
+pkgver=1.0.3
pkgrel=1
pkgdesc="Configure and run Dominions 4 as a headless server"
arch=('x86_64')
@@ -32,5 +32,5 @@ md5sums=('d8e3011dfa108d3f1574c57aefcecb32'
'7e51badb10054709bbec60bfcbf424ee'
'e9772a237cc540558e74235b98df8a7f'
'338b8462868ecf6cc56c4a520cea6bac'
- 'a6f06f3a3c5d4c12717b37db2c6f4dc7'
+ '99cdd4c32d1737b03cf8f55758d918ec'
'22bdb16a296d12c51988c43c3218201b')
diff --git a/README.md b/README.md
index 1c60dd3880e1..f88bc11aab64 100644
--- a/README.md
+++ b/README.md
@@ -34,16 +34,20 @@ If your computer is behind a router you will need to make sure the port is forwa
Your game configuration is stored in key=value format in a properties file. Copy `default.properties` to a safe location and edit as needed. `mapfile` should reference the filename of a map in *your* `~/dominions4/maps` directory. Once ready:
-1. `dom4 config mygame.properties` loads your config into the server and sets the current game name.
-1. `systemctl start dom4-server` starts the server in pretender upload mode.
+1. `sudo dom4 config mygame.properties` loads your config into the server and sets the current game name.
+1. `sudo systemctl start dom4-server` starts the server in pretender upload mode.
1. If `uploadmaxp` or `uploadtime` are set in your configuration, you're done: the game will start automatically when the appropriate limit is reached. If not, wait for everyone to upload their pretenders and then bring the server down with `systemctl stop dom4-server`.
-1. `dom4 ready` sets the game's start flag.
-1. Restart the server using `systemctl start dom4-server` again to begin the game.
+1. `sudo dom4 ready` sets the server up to host the last configured game, or you can pass in the name of another properties file (without the extension) after all pretenders have been uploaded.
+1. Restart the server using `sudo systemctl start dom4-server` again to begin the game.
-You may also want to `systemctl enable dom4-server` in order to start the server automatically after reboots.
+You may also want to `sudo systemctl enable dom4-server` in order to start the server automatically after reboots.
Note that only one game may be served at a time. If you run `dom4 config` with a config file when a game has already been set up, it will ask if you want to overwrite the existing game.
+### Deleting Games
+
+`sudo dom4 delete mygame` removes the properties file and save directory. Maps are not removed.
+
## SteamCMD
Here's how to download and install Dominions 4 from Steam without needing to let X or a monitor anywhere near your computer:
diff --git a/dom4 b/dom4
index 40647d8108c3..8f04edc96d28 100755
--- a/dom4
+++ b/dom4
@@ -45,6 +45,10 @@ EOF
}
function ready {
+ if [[ ! -z $1 ]]; then
+ echo $1 > /usr/share/dom4/current
+ fi
+
if [[ ! -s /usr/share/dom4/current ]]; then
echo "No current game found. Use dom4 config to load game configuration."
exit 1