summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralbakham2019-04-24 22:26:28 +0200
committeralbakham2019-04-24 22:26:28 +0200
commit935dd37b2354b25130a6cc9babf3be77dcf54a98 (patch)
tree95e72484b31990f54d7b857982c106b52f1f4266
downloadaur-935dd37b2354b25130a6cc9babf3be77dcf54a98.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD35
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..539b61f60bb2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = domain-expiration-git
+ pkgdesc = Checks the expiration dates of domains.
+ pkgver = r4.75c369c
+ pkgrel = 1
+ url = https://gitnet.fr/deblan/domain-expiration
+ arch = any
+ license = GPL
+ makedepends = composer
+ depends = php>=7.3
+ depends = whois
+ source = domain-expiration-git::git+https://gitnet.fr/deblan/domain-expiration
+ md5sums = SKIP
+
+pkgname = domain-expiration-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11b35cdec404
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Albakham <contact@geber.ga>
+
+pkgname=domain-expiration-git
+pkgver=r4.75c369c
+pkgrel=1
+pkgdesc="Checks the expiration dates of domains."
+arch=('any')
+url="https://gitnet.fr/deblan/domain-expiration"
+license=('GPL')
+depends=('php>=7.3' 'whois')
+makedepends=('composer')
+source=("$pkgname::git+https://gitnet.fr/deblan/domain-expiration")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ sed -i "1c\#!/usr/bin/env php" domain-expiration
+ echo "Version ${pkgver} installation"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ composer install
+}
+
+package() {
+ install -d "$pkgdir/"{usr/bin,opt}
+ cp -R $srcdir/$pkgname $pkgdir/opt/$pkgname
+ ln -s /opt/$pkgname/domain-expiration $pkgdir/usr/bin/$pkgname
+}