summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgoreleaserbot2023-08-29 02:19:11 +0000
committergoreleaserbot2023-08-29 02:19:11 +0000
commit30487bad2d07367b6b83ab956c68caf347e2d0ab (patch)
tree2fa74a299eb2c0c604c49181bbda3b85e2559193
downloadaur-30487bad2d07367b6b83ab956c68caf347e2d0ab.tar.gz
Update to v0.1.0
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD39
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a48cb6a877ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = domain-watch-bin
+ pkgdesc = Get notified about domain changes as they happen
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/gabe565/domain-watch
+ license = GPL-3.0
+ conflicts = domain-watch
+ provides = domain-watch
+ arch = aarch64
+ source_aarch64 = https://github.com/gabe565/domain-watch/releases/download/v0.1.0/domain-watch_0.1.0_linux_arm64.tar.gz
+ sha256sums_aarch64 = f6cde40795eed75c1f41dff0a4b7df366e659bcde61732336994a19a5fce0c71
+ arch = armv6h
+ source_armv6h = https://github.com/gabe565/domain-watch/releases/download/v0.1.0/domain-watch_0.1.0_linux_armv6.tar.gz
+ sha256sums_armv6h = 83972ff4b532143f370e9952c9139690455cfaa297d400cda1c13fbb2d40f16a
+ arch = armv7h
+ source_armv7h = https://github.com/gabe565/domain-watch/releases/download/v0.1.0/domain-watch_0.1.0_linux_armv7.tar.gz
+ sha256sums_armv7h = c7185680d97cc069a805a587f6061c4639ebff8f824212ed1eb6323e41f0df83
+ arch = x86_64
+ source_x86_64 = https://github.com/gabe565/domain-watch/releases/download/v0.1.0/domain-watch_0.1.0_linux_amd64.tar.gz
+ sha256sums_x86_64 = d99ebe44ea344883a6c3aa94b2aa85f19dea1d91bb3580e75794e91dbaa2ebe2
+
+pkgname = domain-watch-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e5e4e9d296a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# This file was generated by GoReleaser. DO NOT EDIT.
+# Maintainer: Gabe Cook <gabe565@gmail.com>
+
+pkgname='domain-watch-bin'
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='Get notified about domain changes as they happen'
+url='https://github.com/gabe565/domain-watch'
+arch=('aarch64' 'armv6h' 'armv7h' 'x86_64')
+license=('GPL-3.0')
+provides=('domain-watch')
+conflicts=('domain-watch')
+
+source_aarch64=("${pkgname}_${pkgver}_aarch64.tar.gz::https://github.com/gabe565/domain-watch/releases/download/v0.1.0/domain-watch_0.1.0_linux_arm64.tar.gz")
+sha256sums_aarch64=('f6cde40795eed75c1f41dff0a4b7df366e659bcde61732336994a19a5fce0c71')
+
+source_armv6h=("${pkgname}_${pkgver}_armv6h.tar.gz::https://github.com/gabe565/domain-watch/releases/download/v0.1.0/domain-watch_0.1.0_linux_armv6.tar.gz")
+sha256sums_armv6h=('83972ff4b532143f370e9952c9139690455cfaa297d400cda1c13fbb2d40f16a')
+
+source_armv7h=("${pkgname}_${pkgver}_armv7h.tar.gz::https://github.com/gabe565/domain-watch/releases/download/v0.1.0/domain-watch_0.1.0_linux_armv7.tar.gz")
+sha256sums_armv7h=('c7185680d97cc069a805a587f6061c4639ebff8f824212ed1eb6323e41f0df83')
+
+source_x86_64=("${pkgname}_${pkgver}_x86_64.tar.gz::https://github.com/gabe565/domain-watch/releases/download/v0.1.0/domain-watch_0.1.0_linux_amd64.tar.gz")
+sha256sums_x86_64=('d99ebe44ea344883a6c3aa94b2aa85f19dea1d91bb3580e75794e91dbaa2ebe2')
+
+package() {
+ # bin
+ install -Dm755 "./domain-watch" "${pkgdir}/usr/bin/domain-watch"
+ # license
+ install -Dm644 "./LICENSE" "${pkgdir}/usr/share/licenses/domain-watch/LICENSE"
+ # man page
+ install -Dm644 "./manpages/domain-watch.1.gz" "${pkgdir}/usr/share/man/man1/domain-watch.1.gz"
+ # completion
+ install -Dm644 "./completions/domain-watch.bash" "${pkgdir}/usr/share/bash-completion/completions/domain-watch"
+ install -Dm644 "./completions/domain-watch.zsh" "${pkgdir}/usr/share/zsh/site-functions/_domain-watch"
+ install -Dm644 "./completions/domain-watch.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/domain-watch.fish"
+ # systemd unit
+ install -Dm644 "./systemd/domain-watch.service" "${pkgdir}/usr/lib/systemd/system/domain-watch.service"
+}