summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThulinma2019-11-28 22:05:21 +0100
committerThulinma2019-11-28 22:10:43 +0100
commit29fc3eaef4041bfe20ed1c6136bc5b56b6dc77cc (patch)
tree7ef2eb480186ec54ecb321c5953453eebf0f4514
parente3e0f869f6a359794a2fff4359e1e3b3236459b9 (diff)
downloadaur-29fc3eaef4041bfe20ed1c6136bc5b56b6dc77cc.tar.gz
Updated to 4.10717. Removed support for openzwave and python since both will not compile on current release with the latest versions arch ships.
-rw-r--r--PKGBUILD19
-rw-r--r--boostver.patch12
2 files changed, 24 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0532ae146bad..f5281ebe0b43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,25 @@
-# Maintainer: Jameson Pugh <imntreal@gmail.com>
+# Maintainer: Jaron Viƫtor <thulinma@thulinma.com>
+# Previous maintainer: Jameson Pugh <imntreal@gmail.com>
pkgname=domoticz
-pkgver=4.9700
+pkgver=4.10717
pkgrel=1
pkgdesc="Web based home automation"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
url="http://www.domoticz.com"
license=('GPL')
-depends=('openzwave' 'libusb-compat' 'curl' 'sqlite' 'boost-libs' 'lua' 'mosquitto')
-makedepends=('git' 'cmake' 'boost')
+depends=('libusb-compat' 'curl' 'sqlite' 'boost-libs' 'lua' 'mosquitto')
+makedepends=('git' 'cmake' 'boost' 'python')
install='domoticz.install'
source=("https://github.com/domoticz/domoticz/archive/${pkgver}.tar.gz"
- 'domoticz.service')
-sha256sums=('c31f185a1ffac01b86a77bf33e059a4403d814e826c9d6639c63c2e9afa55a46'
- '52ea28893fc70a278a728f975c249ace48e48f595c9da01895bde115e8e6b255')
+ 'domoticz.service' 'boostver.patch')
+sha256sums=('c053a2161942529f56b748945ec297dcd67f449e68029fc886893a528891ad86'
+ '52ea28893fc70a278a728f975c249ace48e48f595c9da01895bde115e8e6b255'
+ 'b8c136ec718696a1d70d18245c0a3bad490d6f23b0000a53369ab5eb84ca5128')
prepare() {
+ cd $pkgname-$pkgver
+ patch --forward --strip=1 --input="${srcdir}/boostver.patch"
mkdir -p "${srcdir}/${pkgname}-${pkgver}/build"
}
@@ -31,6 +35,7 @@ build() {
-DUSE_STATIC_BOOST=NO \
-DUSE_STATIC_LIBSTDCXX=NO \
-DUSE_OPENSSL_STATIC=NO \
+ -DUSE_PYTHON=NO \
..
}
diff --git a/boostver.patch b/boostver.patch
new file mode 100644
index 000000000000..e9ce603dd01b
--- /dev/null
+++ b/boostver.patch
@@ -0,0 +1,12 @@
+diff --unified --recursive --text package.orig/CMakeLists.txt package.new/CMakeLists.txt
+--- package.orig/CMakeLists.txt 2019-05-10 11:37:55.000000000 +0200
++++ package.new/CMakeLists.txt 2019-11-28 21:24:16.426643205 +0100
+@@ -4,7 +4,7 @@
+ project(domoticz)
+
+ ## required min. libBoost version
+-SET(DOMO_MIN_LIBBOOST_VERSION 106000)
++SET(DOMO_MIN_LIBBOOST_VERSION 1.71)
+ ##
+
+ MACRO(Gitversion_GET_REVISION dir variable)