summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-04-10 16:59:47 +0300
committerDimitris Kiziridis2020-04-10 16:59:47 +0300
commitfab79c60b8ba18a6230769a4d15f5e116c6ab820 (patch)
tree4d7875f6e044eb181ec71dc0ca51ff336ac76f4b
parent2478dcaff0def1624da344e5171f9da1112a9154 (diff)
downloadaur-fab79c60b8ba18a6230769a4d15f5e116c6ab820.tar.gz
Update to 2020.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD52
-rw-r--r--boostver.patch12
3 files changed, 36 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9cc4a61eebbc..74ace692edd7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = domoticz
pkgdesc = Web based home automation
- pkgver = 4.10717
+ pkgver = 2020.1
pkgrel = 1
- url = http://www.domoticz.com
+ url = https://www.domoticz.com
install = domoticz.install
arch = i686
arch = x86_64
arch = arm
arch = armv6h
arch = armv7h
- license = GPL
+ license = GPL-3.0
makedepends = git
makedepends = cmake
makedepends = boost
@@ -20,12 +20,10 @@ pkgbase = domoticz
depends = boost-libs
depends = lua
depends = mosquitto
- source = https://github.com/domoticz/domoticz/archive/4.10717.tar.gz
+ source = https://github.com/domoticz/domoticz/archive/2020.1.tar.gz
source = domoticz.service
- source = boostver.patch
- sha256sums = c053a2161942529f56b748945ec297dcd67f449e68029fc886893a528891ad86
- sha256sums = 52ea28893fc70a278a728f975c249ace48e48f595c9da01895bde115e8e6b255
- sha256sums = b8c136ec718696a1d70d18245c0a3bad490d6f23b0000a53369ab5eb84ca5128
+ md5sums = 00ea7ab5c3f6de94fe590b8cf99a7e1f
+ md5sums = c13a3f5d04142587d159820156a6223f
pkgname = domoticz
diff --git a/PKGBUILD b/PKGBUILD
index f5281ebe0b43..3eb6c03af87c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,37 @@
-# Maintainer: Jaron Viëtor <thulinma@thulinma.com>
-# Previous maintainer: Jameson Pugh <imntreal@gmail.com>
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+# Contributor: Jaron Viëtor <thulinma@thulinma.com>
+# Contributor: Jameson Pugh <imntreal@gmail.com>
pkgname=domoticz
-pkgver=4.10717
+pkgver=2020.1
pkgrel=1
pkgdesc="Web based home automation"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
-url="http://www.domoticz.com"
-license=('GPL')
-depends=('libusb-compat' 'curl' 'sqlite' 'boost-libs' 'lua' 'mosquitto')
-makedepends=('git' 'cmake' 'boost' 'python')
+url='https://www.domoticz.com'
+license=('GPL-3.0')
+depends=('libusb-compat'
+ 'curl'
+ 'sqlite'
+ 'boost-libs'
+ 'lua'
+ 'mosquitto')
+makedepends=('git'
+ 'cmake'
+ 'boost'
+ 'python')
install='domoticz.install'
source=("https://github.com/domoticz/domoticz/archive/${pkgver}.tar.gz"
- 'domoticz.service' 'boostver.patch')
-sha256sums=('c053a2161942529f56b748945ec297dcd67f449e68029fc886893a528891ad86'
- '52ea28893fc70a278a728f975c249ace48e48f595c9da01895bde115e8e6b255'
- 'b8c136ec718696a1d70d18245c0a3bad490d6f23b0000a53369ab5eb84ca5128')
+ 'domoticz.service')
+md5sums=('00ea7ab5c3f6de94fe590b8cf99a7e1f'
+ 'c13a3f5d04142587d159820156a6223f')
prepare() {
- cd $pkgname-$pkgver
- patch --forward --strip=1 --input="${srcdir}/boostver.patch"
mkdir -p "${srcdir}/${pkgname}-${pkgver}/build"
-}
-
-build() {
cd "${srcdir}/${pkgname}-${pkgver}/build"
cmake -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/opt/domoticz \
- -DUSE_STATIC_OPENZWAVE=NO \
- -DUSE_BUILTIN_LUA=NO \
+ -DCMAKE_INSTALL_PREFIX=/opt/domoticz \
+ -DUSE_STATIC_OPENZWAVE=NO \
+ -DUSE_BUILTIN_LUA=NO \
-DUSE_BUILTIN_MQTT=NO \
-DUSE_BUILTIN_SQLITE=NO \
-DUSE_BUILTIN_ZLIB=NO \
@@ -39,14 +42,19 @@ build() {
..
}
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
+ make
+}
+
package() {
cd ${srcdir}/${pkgname}-${pkgver}/build
-
make DESTDIR=${pkgdir} install
chmod o+r "${pkgdir}/opt/domoticz/updatedomo"
mkdir -p "${pkgdir}/usr/lib/systemd/system"
cp ${srcdir}/domoticz.service "${pkgdir}/usr/lib/systemd/system/"
chown -R http:http "${pkgdir}/opt/domoticz"
+ install -Dm644 ${srcdir}/${pkgname}-${pkgver}/License.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm "${pkgdir}/opt/domoticz/License.txt"
}
-
-# vim:set ts=2 sw=2 et:
+# vim:set ts=2 sw=2 et: \ No newline at end of file
diff --git a/boostver.patch b/boostver.patch
deleted file mode 100644
index e9ce603dd01b..000000000000
--- a/boostver.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --unified --recursive --text package.orig/CMakeLists.txt package.new/CMakeLists.txt
---- package.orig/CMakeLists.txt 2019-05-10 11:37:55.000000000 +0200
-+++ package.new/CMakeLists.txt 2019-11-28 21:24:16.426643205 +0100
-@@ -4,7 +4,7 @@
- project(domoticz)
-
- ## required min. libBoost version
--SET(DOMO_MIN_LIBBOOST_VERSION 106000)
-+SET(DOMO_MIN_LIBBOOST_VERSION 1.71)
- ##
-
- MACRO(Gitversion_GET_REVISION dir variable)