summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2022-02-28 11:44:24 -0500
committerSolomon Choina2022-02-28 11:44:24 -0500
commit877fba437b36c561772df5ea528f49bf45f172fe (patch)
tree5e83eb8bb9897525a24101e6a1531ec3a3d0ffaf
parentde32c4782077b4ce1fad1c49749b679d6d262fa7 (diff)
downloadaur-877fba437b36c561772df5ea528f49bf45f172fe.tar.gz
fixing build for the new rust stuff
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2677b9c391bd..aa2c36ba967b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = domterm-git
pkgdesc = Terminal emulator capable of display html and images from command output
- pkgver = 2.1.r94.g40e9b1b
+ pkgver = 2.9.4.r95.g29efa6e
pkgrel = 1
url = https://github.com/PerBothner/DomTerm
arch = x86_64
@@ -10,16 +10,20 @@ pkgbase = domterm-git
makedepends = asciidoctor
makedepends = zip
makedepends = json-c
- depends = file
+ makedepends = rust
+ makedepends = jq
+ makedepends = libsoup
+ makedepends = atk
+ makedepends = gtk3
+ makedepends = webkit2gtk
+ makedepends = libappindicator-gtk3
+ makedepends = java-openjfx
depends = qt5-webengine
- depends = qt5-webchannel
depends = libwebsockets
depends = java-runtime
+ depends = webkit2gtk
conflicts = qtdomterm
source = git+https://github.com/PerBothner/DomTerm.git
- source = git+https://github.com/warmcat/libwebsockets
- md5sums = SKIP
md5sums = SKIP
pkgname = domterm-git
-
diff --git a/PKGBUILD b/PKGBUILD
index c2237464e88a..d1d364ff1a86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: solaraquarion <shlomochoina@gmail.com>
pkgname=domterm-git
-pkgver=2.1.r94.g40e9b1b
+pkgver=2.9.4.r95.g29efa6e
pkgrel=1
pkgdesc="Terminal emulator capable of display html and images from command output"
arch=('x86_64')
@@ -9,27 +9,19 @@ url=https://github.com/PerBothner/DomTerm
license=('BSD')
groups=()
conflicts=(qtdomterm)
-makedepends=('git' 'vim' 'asciidoctor' 'zip' 'json-c')
-depends=(file qt5-webengine qt5-webchannel libwebsockets java-runtime)
-source=('git+https://github.com/PerBothner/DomTerm.git'
- 'git+https://github.com/warmcat/libwebsockets')
-md5sums=('SKIP'
- 'SKIP')
+makedepends=('git' 'vim' 'asciidoctor' 'zip' 'json-c' 'rust' 'jq' 'libsoup' 'atk' 'gtk3' 'webkit2gtk' 'libappindicator-gtk3' 'java-openjfx')
+depends=(qt5-webengine libwebsockets java-runtime webkit2gtk)
+source=('git+https://github.com/PerBothner/DomTerm.git')
+md5sums=('SKIP')
pkgver(){
cd "$srcdir"/DomTerm
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
-
- cd "$srcdir"/libwebsockets
- mkdir build
- cd build
- cmake -DLWS_WITH_SSL=0 -DLWS_WITH_ZIP_FOPS=1 ..
- make
cd "$srcdir"/DomTerm
autoreconf -vfi
- ./configure --with-qtwebengine --with-libwebsockets="$srcdir"/libwebsockets/build --with-javafx --prefix=/usr
+ ./configure --with-qt --with-libwebsockets --with-javafx --with-wry --prefix=/usr
make V=1
}