summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2017-12-24 07:32:37 -0500
committerSolomon Choina2017-12-24 07:32:37 -0500
commit9d5375dff718f581c15ab86e2831cc93d9b7cd71 (patch)
tree5e85a9bb73bd5d026f3ed58c08b4a57581548792
downloadaur-9d5375dff718f581c15ab86e2831cc93d9b7cd71.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb71e46427ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Dec 24 12:32:27 UTC 2017
+pkgbase = domterm-git
+ pkgdesc = Terminal emulator capable of display html and images from command output
+ pkgver = 0.72.r273.g8c0bbce
+ pkgrel = 1
+ url = ttps://github.com/PerBothner/DomTerm
+ arch = any
+ license = BSD
+ depends = json-c
+ depends = qt5-webengine
+ depends = qt5-webchannel
+ depends = libwebsockets
+ conflicts = qtdomterm
+ source = git+https://github.com/PerBothner/DomTerm.git
+ md5sums = SKIP
+
+pkgname = domterm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65334e1dba4e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Oliver Mangold <o dot mangold at gmail dot com>
+
+pkgname=domterm-git
+pkgver=0.72.r273.g8c0bbce
+pkgrel=1
+pkgdesc="Terminal emulator capable of display html and images from command output"
+arch=('any')
+url=ttps://github.com/PerBothner/DomTerm
+license=('BSD')
+groups=()
+conflicts=(qtdomterm)
+depends=(json-c qt5-webengine qt5-webchannel libwebsockets)
+source=('git+https://github.com/PerBothner/DomTerm.git')
+md5sums=('SKIP')
+
+pkgver(){
+ cd "$srcdir"/DomTerm
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+build() {
+ cd "$srcdir"/DomTerm
+ autoreconf
+ ./configure --enable-pty --with-qtwebengine --with-libwebsockets --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir"/DomTerm
+ make install DESTDIR="$pkgdir"
+ install -m 755 "$srcdir"/DomTerm/bin/{h,img,svg}cat "$pkgdir"/usr/bin
+}