summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2020-04-12 17:14:44 -0400
committerSolomon Choina2020-04-12 17:14:44 -0400
commitde32c4782077b4ce1fad1c49749b679d6d262fa7 (patch)
tree3da4624fcef30467d31317cf44a54a15e8429059
parentb9a5074e5f3bdff01160a310b2204f6e376fa525 (diff)
downloadaur-de32c4782077b4ce1fad1c49749b679d6d262fa7.tar.gz
adding a locally built libwebsockets
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
2 files changed, 21 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 58f2aa7c7998..2677b9c391bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = domterm-git
pkgdesc = Terminal emulator capable of display html and images from command output
- pkgver = 2.1.r78.gbaa2623
+ pkgver = 2.1.r94.g40e9b1b
pkgrel = 1
url = https://github.com/PerBothner/DomTerm
arch = x86_64
@@ -8,13 +8,17 @@ pkgbase = domterm-git
makedepends = git
makedepends = vim
makedepends = asciidoctor
- depends = json-c
+ makedepends = zip
+ makedepends = json-c
depends = file
depends = qt5-webengine
depends = qt5-webchannel
depends = libwebsockets
+ depends = java-runtime
conflicts = qtdomterm
source = git+https://github.com/PerBothner/DomTerm.git
+ source = git+https://github.com/warmcat/libwebsockets
+ md5sums = SKIP
md5sums = SKIP
pkgname = domterm-git
diff --git a/PKGBUILD b/PKGBUILD
index c811e8ec9105..c2237464e88a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: solaraquarion <shlomochoina@gmail.com>
pkgname=domterm-git
-pkgver=2.1.r78.gbaa2623
+pkgver=2.1.r94.g40e9b1b
pkgrel=1
pkgdesc="Terminal emulator capable of display html and images from command output"
arch=('x86_64')
@@ -9,20 +9,28 @@ url=https://github.com/PerBothner/DomTerm
license=('BSD')
groups=()
conflicts=(qtdomterm)
-makedepends=('git' 'vim' 'asciidoctor')
-depends=(json-c file qt5-webengine qt5-webchannel libwebsockets)
-source=('git+https://github.com/PerBothner/DomTerm.git')
-md5sums=('SKIP')
+makedepends=('git' 'vim' 'asciidoctor' 'zip' 'json-c')
+depends=(file qt5-webengine qt5-webchannel libwebsockets java-runtime)
+source=('git+https://github.com/PerBothner/DomTerm.git'
+ 'git+https://github.com/warmcat/libwebsockets')
+md5sums=('SKIP'
+ 'SKIP')
pkgver(){
cd "$srcdir"/DomTerm
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
+
+ cd "$srcdir"/libwebsockets
+ mkdir build
+ cd build
+ cmake -DLWS_WITH_SSL=0 -DLWS_WITH_ZIP_FOPS=1 ..
+ make
cd "$srcdir"/DomTerm
autoreconf -vfi
- ./configure --with-qtwebengine --with-libwebsockets --with-javafx --prefix=/usr
- make
+ ./configure --with-qtwebengine --with-libwebsockets="$srcdir"/libwebsockets/build --with-javafx --prefix=/usr
+ make V=1
}
package() {