summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlucafulgenzi2023-07-01 14:56:08 +0200
committerlucafulgenzi2023-07-01 14:56:08 +0200
commit4f68d674e65eefcf925d814edaff2f34315583dd (patch)
tree6bca6bcda121c5112c8008a8a1a358281b455e1d
downloadaur-4f68d674e65eefcf925d814edaff2f34315583dd.tar.gz
version 0.1.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..535304d35a08
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = domust-bin
+ pkgdesc = Domust is a home automation system that allows you to control your home form your computer.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/lucafulgenzi/domust
+ arch = x86_64
+ license = AGPL-3.0
+ provides = domust
+ conflicts = domust
+ source = https://github.com/lucafulgenzi/domust/releases/download/0.1.0/domust-0.1.0-x86_64.tar.gz
+ sha256sums = SKIP
+
+pkgname = domust-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98a355a80fa2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Luca Fulgenzi <luca.fugenzi@justanother.cloud>
+#
+# This PKGBUILD was generated by `cargo aur`: https://crates.io/crates/cargo-aur
+
+pkgname=domust-bin
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Domust is a home automation system that allows you to control your home form your computer."
+url="https://github.com/lucafulgenzi/domust"
+license=("AGPL-3.0")
+arch=("x86_64")
+provides=("domust")
+conflicts=("domust")
+source=("https://github.com/lucafulgenzi/domust/releases/download/${pkgver}/domust-${pkgver}-x86_64.tar.gz")
+sha256sums=("SKIP")
+
+package() {
+ install -Dm755 domust -t "$pkgdir/usr/bin"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ mkdir -p $pkgdir/$HOME/.config/domust
+ [[ -f $HOME/.config/domust/config.yaml ]] || touch $HOME/.config/domust/config.yaml
+}