summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorayham-12024-01-07 10:44:33 +0300
committerayham-12024-01-07 10:44:33 +0300
commitfebce5c24b10c85c949acd7e7118401b6a763d36 (patch)
tree780c113961eff20753aee28d7b0ea8e61c7f4553
downloadaur-febce5c24b10c85c949acd7e7118401b6a763d36.tar.gz
donglify-20240107b: release first beta
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD23
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..707fe7e4cf33
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = donglify
+ pkgdesc = The ultimate Archlinux encryption USB dongiled setup.
+ pkgver = 20240107b
+ pkgrel = 1
+ url = https://github.com/ayham-1/donglify
+ arch = any
+ license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-hatchling
+ depends = python-termcolor
+ depends = python-prompt_toolkit
+ source = https://github.com/ayham-1/donglify/archive/refs/tags/20240107b.tar.gz
+ validpgpkeys = 8C38DD3A3030F8AEB8A9A2BC783F6DE277DA7BFF
+ sha256sums = 904e5bee08c5de59c29c9537fe8b77c83b95aa450a588c28d0bdc3eaf61ec2c9
+
+pkgname = donglify
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e859cd42c0c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: ayham-1 <me@ayham.xyz>
+pkgname='donglify'
+pkgver='20240107b'
+pkgrel=1
+arch=('any')
+pkgdesc='The ultimate Archlinux encryption USB dongiled setup.'
+url='https://github.com/ayham-1/donglify'
+license=('MIT')
+depends=('python-termcolor' 'python-prompt_toolkit')
+makedepends=(python-build python-installer python-wheel python-hatchling)
+source=("https://github.com/ayham-1/$pkgname/archive/refs/tags/$pkgver.tar.gz")
+validpgpkeys=('8C38DD3A3030F8AEB8A9A2BC783F6DE277DA7BFF')
+sha256sums=('904e5bee08c5de59c29c9537fe8b77c83b95aa450a588c28d0bdc3eaf61ec2c9')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}