summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Teles2018-09-21 11:40:43 -0300
committerAlexandre Teles2018-09-21 11:40:43 -0300
commit7f4aba36681e5cec666e2fac57e0aad3cb485e6c (patch)
tree9c0a192df4184bdb3dc240a7b8de8044259fe618
parent88b358b166499faa09977cea385c230144ee0ed6 (diff)
downloadaur-7f4aba36681e5cec666e2fac57e0aad3cb485e6c.tar.gz
Update to latest version
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD32
2 files changed, 24 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96ed1cd21387..9ce6df10fd79 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,23 @@
pkgbase = dontpanic-latest
- pkgdesc = Dontpanic is a python app to look for any movie or serie and watch them in 'streaming'. It looks like popcorntime, but doesn't depend of a centralized api.
+ pkgdesc = Dontpanic is a free (as in freedom) python application to look for any movie or serie and watch them in streaming. It looks like popcorntime or torrent time, but doesn't depend of a centralized api.
pkgver = 2.0
pkgrel = 2
- url = https://3hg.fr/dontpanic/index.html
+ url = https://3hg.fr/Bonus/dontpanic/index.html
arch = any
- license = GPL3
+ license = MIT
makedepends = git
depends = python-bottle
depends = python-requests
depends = python-beautifulsoup4
depends = sqlite
depends = libtorrent-rasterbar
+ depends = xdg-utils
optdepends = python-cherrypy: for server mode
provides = dontpanic
conflicts = dontpanic
- source = dontpanic::https://3hg.fr/dontpanic/downloads/dontpanic-latest.tgz
- sha256sums = a79fc5d008cfc1f46da430ea56c19c39ab4128a8c93d95554b77b395dede54c3
+ noextract = archive.tar.gz
+ source = https://framagit.org/Thuban/dontpanic/repository/master/archive.tar.gz
+ sha256sums = 7eee2a596f75d69f5be09870722fe0f2ee7a0270ab39dfa943426a6f964ed493
pkgname = dontpanic-latest
diff --git a/PKGBUILD b/PKGBUILD
index 57d712e7b8d4..2cf9f40a248f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,38 @@
+# Maintainer: Fanch
+# Maintainer: Alexandre Teles (afterSt0rm) <ateles.1@gmail.com>
_pkgname=dontpanic
pkgname=${_pkgname}-latest
pkgver=2.0
pkgrel=2
-#epoch=1
-pkgdesc="Dontpanic is a python app to look for any movie or serie and watch them in 'streaming'. It looks like popcorntime, but doesn't depend of a centralized api."
+
+pkgdesc="Dontpanic is a free (as in "freedom") python application to look for any movie or serie and watch them in "streaming". It looks like popcorntime or torrent time, but doesn't depend of a centralized api."
+
arch=(any)
-#url=http://3hg.toile-libre.org/dontpanic/index.html
-url=https://3hg.fr/dontpanic/index.html
-license=(GPL3)
+url=https://3hg.fr/Bonus/dontpanic/index.html
+license=(MIT)
-depends=('python-bottle' 'python-requests' 'python-beautifulsoup4' 'sqlite' 'libtorrent-rasterbar')
+depends=('python-bottle' 'python-requests' 'python-beautifulsoup4' 'sqlite' 'libtorrent-rasterbar' 'xdg-utils')
optdepends=('python-cherrypy: for server mode')
makedepends=('git')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-#source=("${_pkgname}::http://3hg.toile-libre.org/dontpanic/downloads/dontpanic-latest.tgz")
-source=("${_pkgname}::https://3hg.fr/dontpanic/downloads/dontpanic-latest.tgz")
+source=("https://framagit.org/Thuban/dontpanic/repository/master/archive.tar.gz")
+noextract=("archive.tar.gz")
-sha256sums=('a79fc5d008cfc1f46da430ea56c19c39ab4128a8c93d95554b77b395dede54c3')
+sha256sums=('7eee2a596f75d69f5be09870722fe0f2ee7a0270ab39dfa943426a6f964ed493')
pkgver() {
- #wget -qO- http://3hg.toile-libre.org/dontpanic/version
- #curl -s http://3hg.toile-libre.org/dontpanic/version
- curl -s https://3hg.fr/dontpanic/version
+ curl -s https://3hg.fr/Bonus/dontpanic/version
+}
+
+prepare() {
+ mkdir dontpanic && tar zxvf archive.tar.gz -C dontpanic --strip-components 1
}
package() {
-
install -dm755 "${pkgdir}/usr/bin"
install -dm755 "${pkgdir}/usr/share"
install -dm755 "${pkgdir}/usr/share/${_pkgname}/"
@@ -68,8 +71,7 @@ package() {
install -Dm644 "${srcdir}/${_pkgname}/dontpanic.desktop" "${pkgdir}/usr/share/applications/dontpanic.desktop"
- install -Dm644 "${srcdir}/${_pkgname}/dontpanic.1.gz" "${pkgdir}/usr/share/man/man1/"
-
+ install -Dm644 "${srcdir}/${_pkgname}/dontpanic.1.gz" "${pkgdir}/usr/share/man/man1/"
}