summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-03-24 12:19:02 +0800
committerzxp198210052023-03-24 12:19:02 +0800
commit0530591dacf2fbed8a0bef8f61a949664201b386 (patch)
treea1a425683cbe1e36ffdf2a0d9cd08cdd444d2ed2
parentb20ddc5c7b43730e86e3bd3c4fb0c5fed11585d6 (diff)
downloadaur-0530591dacf2fbed8a0bef8f61a949664201b386.tar.gz
fix errors
-rw-r--r--.SRCINFO45
-rw-r--r--PKGBUILD26
2 files changed, 58 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1690a1a05cc..c7c210029147 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dooble-bin
pkgdesc = Web browser based on QtWebEngine
pkgver = 2023.02.25
- pkgrel = 1
+ pkgrel = 2
url = https://textbrowser.github.io/dooble/
arch = x86_64
license = BSD
@@ -10,12 +10,53 @@ pkgbase = dooble-bin
depends = gtk3
depends = qt6-webengine
depends = qt6-svg
+ depends = expat
+ depends = xcb-util-renderutil
+ depends = hicolor-icon-theme
+ depends = libxshmfence
+ depends = libxrandr
+ depends = pango
+ depends = glibc
+ depends = xcb-util-image
+ depends = cairo
+ depends = gdk-pixbuf2
+ depends = qt6-declarative
+ depends = freetype2
+ depends = libdrm
+ depends = xcb-util-keysyms
+ depends = libglvnd
+ depends = dbus
+ depends = alsa-lib
+ depends = libxkbcommon
+ depends = libxext
+ depends = libxdamage
+ depends = libxfixes
+ depends = qt6-positioning
+ depends = libxrender
+ depends = zlib
+ depends = glib2
+ depends = libxcomposite
+ depends = qt6-webchannel
+ depends = qt6-base
+ depends = libxcb
+ depends = libxkbfile
+ depends = libcups
+ depends = libxkbcommon-x11
+ depends = gcc-libs
+ depends = nss
+ depends = krb5
+ depends = fontconfig
+ depends = wayland
+ depends = nspr
+ depends = libxtst
+ depends = libx11
+ depends = xcb-util-wm
conflicts = dooble
source = dooble-2023.02.25.tar.gz::https://github.com/textbrowser/dooble/releases/download/2023.02.25/Dooble-2023.02.25.tar.gz
source = dooble.desktop
source = LICENSE::https://github.com/textbrowser/dooble/raw/master/LICENSE
sha256sums = e15e464f2cd86b9c75e6ac3fd57910dd315350b4f5817a9839d7736ebcd37785
sha256sums = 0451898ad6b3864601d4406956558153b9518b1695545440e91bf26465c1dbe4
- sha256sums = cbf629abfdc78b888d87ceae0847a9129e5b0e1baa8da4a1cec53324f38defb7
+ sha256sums = c60bf2d6a8bfdf7c7418bba91c6767cbb4b48dccae36dd5d9ffdb48f756815dd
pkgname = dooble-bin
diff --git a/PKGBUILD b/PKGBUILD
index 7127d9b9c6f1..1737fbaa7c96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,36 @@
# Contributor: Balló György <ballogyor+arch at gmail dot com>
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
-pkgname=dooble-bin
_pkgname=dooble
+pkgname="${_pkgname}-bin"
pkgver=2023.02.25
-pkgrel=1
+pkgrel=2
pkgdesc="Web browser based on QtWebEngine"
arch=(x86_64)
url="https://textbrowser.github.io/dooble/"
+_githuburl="https://github.com/textbrowser/${_pkgname}"
license=('BSD')
-depends=('unixodbc' 'at-spi2-core' 'gtk3' 'qt6-webengine' 'qt6-svg')
+depends=(unixodbc at-spi2-core gtk3 qt6-webengine qt6-svg expat xcb-util-renderutil hicolor-icon-theme libxshmfence libxrandr pango glibc xcb-util-image cairo\
+ gdk-pixbuf2 qt6-declarative freetype2 libdrm xcb-util-keysyms libglvnd dbus alsa-lib libxkbcommon libxext libxdamage libxfixes qt6-positioning libxrender zlib \
+ glib2 libxcomposite qt6-webchannel qt6-base libxcb libxkbfile libcups libxkbcommon-x11 gcc-libs nss krb5 fontconfig wayland nspr libxtst libx11 xcb-util-wm)
optdepends=()
-conflicts=('dooble')
+providers=("${_pkgname}")
+conflicts=("${_pkgname}")
source=(
- "${_pkgname}-${pkgver}.tar.gz::https://github.com/textbrowser/${_pkgname}/releases/download/${pkgver}/Dooble-${pkgver}.tar.gz"
+ "${_pkgname}-${pkgver}.tar.gz::${_githuburl}/releases/download/${pkgver}/Dooble-${pkgver}.tar.gz"
"${_pkgname}.desktop"
- "LICENSE::https://github.com/textbrowser/dooble/raw/master/LICENSE"
+ "LICENSE::${_githuburl}/raw/master/LICENSE"
)
sha256sums=('e15e464f2cd86b9c75e6ac3fd57910dd315350b4f5817a9839d7736ebcd37785'
'0451898ad6b3864601d4406956558153b9518b1695545440e91bf26465c1dbe4'
- 'cbf629abfdc78b888d87ceae0847a9129e5b0e1baa8da4a1cec53324f38defb7')
+ 'c60bf2d6a8bfdf7c7418bba91c6767cbb4b48dccae36dd5d9ffdb48f756815dd')
package() {
- mkdir -p "${pkgdir}/opt"
- bsdtar -xvf ${_pkgname}-${pkgver}.tar.gz -C "${pkgdir}/opt"
+ install -Dm755 -d "${pkgdir}/opt"
+ bsdtar -xf "${_pkgname}-${pkgver}.tar.gz" -C "${pkgdir}/opt"
find "${pkgdir}/opt" -type d -exec chmod 755 {} \;
- chown -R root:root "${pkgdir}/opt"
+ chown -R root:root "${pkgdir}"
chmod -x "${pkgdir}/opt/dooble/Lib/libQt6WebEngineCore.so.6"
#Use system libc.so.6
- rm -r "${pkgdir}/opt/${_pkgname}/Lib/libc.so.6"
+ mv "${pkgdir}/opt/${_pkgname}/Lib/libc.so.6" "${pkgdir}/opt/${_pkgname}/Lib/libc.so.6.bak"
install -Dm644 "${pkgdir}/opt/${_pkgname}/${_pkgname}.png" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${_pkgname}.png"
install -Dm644 "${srcdir}/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"