summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Wanders2018-07-08 10:35:23 +0200
committerTim Wanders2018-07-08 10:35:23 +0200
commitf253012eef37485f55ececddee3813f70e49c042 (patch)
tree997564ef9cfb78ccb2a641a3fd420681559a7e86
downloadaur-f253012eef37485f55ececddee3813f70e49c042.tar.gz
sync with upstream
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d381bbe245d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = doom-launcher-git
+ pkgdesc = doom-launcher: A doom mod manager and launcher
+ pkgver = 1
+ pkgrel = 1
+ url = https://gitlab.com/tim241/doom-launcher
+ arch = any
+ license = GPL3
+ depends = bash
+ depends = dialog
+ depends = gzdoom
+ provides = doom-launcher
+ conflicts = doom-launcher
+ source = git+https://gitlab.com/tim241/doom-launcher.git
+ sha256sums = SKIP
+
+pkgname = doom-launcher-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad93769cc2f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Tim Wanders <timwanders241@gmail.com>
+_pkgname="doom-launcher"
+pkgname="${_pkgname}-git"
+pkgver=1
+pkgrel=1
+pkgdesc="doom-launcher: A doom mod manager and launcher"
+arch=('any')
+url="https://gitlab.com/tim241/${_pkgname}"
+license=('GPL3')
+
+provides=('doom-launcher')
+conflicts=('doom-launcher')
+depends=('bash' 'dialog' 'gzdoom')
+
+source=("git+https://gitlab.com/tim241/${_pkgname}.git")
+
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --always | sed -e 's|-|.|g'
+}
+
+package() {
+ cd "$_pkgname"
+ install -D -m=0755 doom-launcher "$pkgdir/usr/bin/doom-launcher"
+}