summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYardanico2019-12-20 23:48:35 +0300
committerYardanico2019-12-20 23:48:35 +0300
commitcae6977cd48651e9c6670daaae01e81face69832 (patch)
tree9b0753f0df1934b49bd2b0181e92b47946397082
parenteb64176e0d0adf88ab1a5c160eead11fabcde304 (diff)
downloadaur-cae6977cd48651e9c6670daaae01e81face69832.tar.gz
Add miniupnpc
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c82ad8d8e00c..71a8f9da564b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,6 +11,8 @@ pkgbase = doom2df-git
depends = sdl2_mixer
depends = sdl2
depends = enet
+ depends = libgl
+ depends = miniupnpc
options = !strip
source = git://repo.or.cz/d2df-sdl.git
source = http://doom2d.org/doom2d_forever/latest/win32-d2df-latest.zip
diff --git a/PKGBUILD b/PKGBUILD
index db0db65d3860..ac9c12b4575e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgdesc="Doom2D Forever: A Doom2D remake with multiplayer"
arch=(x86_64 i386)
url="http://doom2d.org/"
license=('GPL3')
-depends=(sdl2_mixer sdl2 enet)
+depends=(sdl2_mixer sdl2 enet libgl miniupnpc)
makedepends=(git fpc)
source=(
'git://repo.or.cz/d2df-sdl.git'
@@ -28,7 +28,7 @@ pkgver() {
build() {
cd "${srcdir}/d2df-sdl/src/game"
- fpc -g -gl -dUSE_SDL2 -dUSE_OPENGL -dUSE_SDLMIXER -FE../../../ Doom2DF.lpr
+ fpc -g -gl -dUSE_SDL2 -dUSE_OPENGL -dUSE_SDLMIXER -dUSE_MINIUPNPC -FE../../../ Doom2DF.lpr
}