summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera2020-09-14 10:17:55 +0200
committerJoan Bruguera2020-09-14 10:17:55 +0200
commit1366891ff68e568a9329dce72341a0d08f7a4089 (patch)
tree9d4b692c57f6cb3ef45bbfe2077f3ab2655c1a62
parent2c35b7e26f79d5ffdc5fc9cf78df181184cf7aa5 (diff)
downloadaur-1366891ff68e568a9329dce72341a0d08f7a4089.tar.gz
Fix build again due to Qt changes.
-rw-r--r--PKGBUILD4
-rw-r--r--qt5_support.patch22
2 files changed, 18 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d1b149e2174a..6ecd5739a44b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Joan Bruguera Micó <joanbrugueram@gmail.com>
pkgname=doom2masterlevelspatch
pkgver=1.2
-pkgrel=2
+pkgrel=3
pkgdesc="Unofficial Master Levels For Doom 2 Patcher For ZDoom (Join all Master Levels WADs)"
url=http://maniacsvault.net/projects
arch=('x86_64')
@@ -12,7 +12,7 @@ source=("http://maniacsvault.net/files/masterlevelspatch.7z"
qt5_support.patch)
sha256sums=(bd2e1a432084af72db2c860959392132db45ddc43abec61c101249c613b672c2
- b1ef893f549bd742333ae906eb71d630260b7b7e5317043d34cf6276641db83a)
+ 27c20d56de60005385cca12862c905be810a602a09e7ea6b8fc9269d19172b34)
prepare() {
# Extract relevant license excerpt from readme.txt
diff --git a/qt5_support.patch b/qt5_support.patch
index ff9e1555e843..55ae8595d8a1 100644
--- a/qt5_support.patch
+++ b/qt5_support.patch
@@ -1,8 +1,8 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 7f4730e..ea0f03c 100755
+index 7f4730e..7e77fc6 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -1,12 +1,10 @@
+@@ -1,24 +1,17 @@
cmake_minimum_required(VERSION 2.4)
project(MasterPatch)
@@ -13,11 +13,21 @@ index 7f4730e..ea0f03c 100755
include_directories(${CMAKE_CURRENT_BINARY_DIR})
-qt4_wrap_ui(UI_FILES
-+qt5_wrap_ui(UI_FILES
- main.ui
- )
+- main.ui
+-)
+-
+-qt_wrap_cpp(WRAPS QT_FILES
+- main.h
+-)
++set(CMAKE_AUTOUIC ON)
++set(CMAKE_AUTOMOC ON)
-@@ -21,4 +19,4 @@ add_executable(patch WIN32
+ add_executable(patch WIN32
+- ${UI_FILES}
+- ${QT_FILES}
++ main.ui
++ main.h
+ main.cpp
patcher.cpp
)