summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2012-12-03 08:41:29 -0800
committerMike Swanson2012-12-03 08:41:29 -0800
commit2f6ed198fe7714e9cfffcdb577a263ea2511c6c8 (patch)
treea20f750c35b9185763135ad3cf442fc0e0c22764
downloadaur-2f6ed198fe7714e9cfffcdb577a263ea2511c6c8.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD37
-rw-r--r--doom3-data.install22
4 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a7aed3930f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = doom3-data
+ pkgdesc = Doom 3 patch data files; not the full game!
+ pkgver = 1.3.1.1304
+ pkgrel = 2
+ url = http://www.idsoftware.com/
+ install = doom3-data.install
+ arch = any
+ license = custom
+ source = http://youfailit.net/pub/idgames/idstuff/doom3/linux/doom3-linux-1.3.1.1304.x86.run
+ sha256sums = 2f90dff20f2d3c0c47f17b3d6d45c4f0e7d27b986bf6084f21b85180cd1e03b4
+
+pkgname = doom3-data
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7c60004d16f2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.pkg.tar*
+*.src.tar*
+*.run
+src
+pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b517f4fe5bd7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
+
+# This is intended as a generic data package for open source Doom 3
+# engines. The omission of game*.pk4 files is intentional, as they
+# are the game code built for the proprietary Linux (32-bit), Windows,
+# Mac versions.
+
+pkgname=doom3-data
+pkgver=1.3.1.1304
+pkgrel=2
+pkgdesc="Doom 3 patch data files; not the full game!"
+url="http://www.idsoftware.com/"
+arch=('any')
+license=('custom')
+install=doom3-data.install
+source=("http://youfailit.net/pub/idgames/idstuff/doom3/linux/doom3-linux-$pkgver.x86.run")
+sha256sums=('2f90dff20f2d3c0c47f17b3d6d45c4f0e7d27b986bf6084f21b85180cd1e03b4')
+
+build() {
+ cd "$srcdir"
+
+ /bin/sh doom3-linux-$pkgver.x86.run --noexec --target doom3-data
+
+ echo -n Resurrection\ of\ Evil > roe_desc.txt
+}
+
+package() {
+ cd "$srcdir/doom3-data"
+
+ install -d "$pkgdir"/usr/share/doom3/{base,d3xp}
+ install -Dm 644 doom3.png "$pkgdir"/usr/share/icons/doom3.png
+ install -m 644 base/pak00{5,6,7,8}.pk4 "$pkgdir"/usr/share/doom3/base
+ install -m 644 d3xp/pak001.pk4 "$pkgdir"/usr/share/doom3/d3xp
+ install -m 644 ../roe_desc.txt "$pkgdir"/usr/share/doom3/d3xp/description.txt
+
+ install -Dm 644 License.txt "$pkgdir"/usr/share/licenses/doom3-data/license.txt
+}
diff --git a/doom3-data.install b/doom3-data.install
new file mode 100644
index 000000000000..61b913f3bf29
--- /dev/null
+++ b/doom3-data.install
@@ -0,0 +1,22 @@
+post_install() {
+ cat <<MSG
+The Doom 3 patch *.pk4 files have been installed to /usr/share/doom3.
+You must still copy the game *.pk4 files from the Doom 3 CDs or an
+installed copy (eg, from Steam, a Windows install, or otherwise) in
+order to complete the game.
+
+The files for the base directory are: pak000.pk4, pak001.pk4,
+pak002.pk4, pak003.pk4, and pak004.pk4.
+
+If you have Doom 3: Resurrection of Evil, you may also copy its
+pak000.pk4 file into the d3xp directory.
+
+STEAM USERS:
+Doom 3 requires a CD-key to run; Steam provides CD-keys but does not
+normally expose them to owners of the game. If you can run Steam, you
+may be able to right click the game(s) and view the CD key from the
+Steam client. Otherwise, run the game(s) at least once via Steam and
+then copy the doomkey and xpkey files from
+"Steam/steamapps/common/doom 3/base" into ~/.doom3/base
+MSG
+}