summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2015-02-07 17:48:17 -0500
committerSlashbunny2015-02-07 17:48:17 -0500
commit03fe0591f70772d60dbb73d8605fbb69d91439e1 (patch)
tree15c92846b673c824eae933f54cf271e950c2c220
downloadaur-03fe0591f70772d60dbb73d8605fbb69d91439e1.tar.gz
Initial commit of doom3-inhell package
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD33
-rw-r--r--doom3-inhell.desktop7
-rw-r--r--doom3-inhell.pngbin0 -> 11167 bytes
-rw-r--r--doom3-inhell.sh3
6 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..68adf39b8112
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = doom3-inhell
+ pkgdesc = Doom3 mod inspired by the classic "Ultimate Doom"
+ pkgver = 1.1dc
+ pkgrel = 1
+ url = http://doom3.filefront.com/file/;83607
+ arch = any
+ license = unknown
+ makedepends = tar
+ makedepends = lzma
+ depends = bash
+ depends = doom3
+ source = http://oxygen4.free.fr/dl/in_hell-1.1dc.tar.lzma
+ source = doom3-inhell.sh
+ source = doom3-inhell.png
+ source = doom3-inhell.desktop
+ md5sums = 90d09a5128a11769b78b9e292fe997b8
+ md5sums = 0082fef66d0c35bdf4e1cfa01d65513f
+ md5sums = a2025a0b6f52850fb8403ebe2d953c41
+ md5sums = 1b0b14d74f185a2060de4b7e9cdc43d0
+
+pkgname = doom3-inhell
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e4f398dc5b3a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+*.pkg.tar.xz
+*.pkg.tar
+*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c60438c13d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Contributor: Christoph Zeiler <archNOSPAM_at_moonblade.dot.org>
+# Contributor: Travis Nickles <ryoohki7@yahoo.com>
+
+pkgname=doom3-inhell
+pkgver=1.1dc
+pkgrel=1
+pkgdesc='Doom3 mod inspired by the classic "Ultimate Doom"'
+arch=('any')
+url="http://doom3.filefront.com/file/;83607"
+license=('unknown')
+depends=('bash' 'doom3')
+makedepends=('tar' 'lzma')
+source=(http://oxygen4.free.fr/dl/in_hell-$pkgver.tar.lzma \
+ $pkgname.sh \
+ $pkgname.png \
+ $pkgname.desktop)
+md5sums=('90d09a5128a11769b78b9e292fe997b8'
+ '0082fef66d0c35bdf4e1cfa01d65513f'
+ 'a2025a0b6f52850fb8403ebe2d953c41'
+ '1b0b14d74f185a2060de4b7e9cdc43d0')
+
+build() {
+ msg "Extracting in_hell-$pkgver.tar.lzma..."
+ tar --lzma -xf in_hell-$pkgver.tar.lzma || return 1
+
+ mkdir -p "$pkgdir"/opt/doom3
+ cp -rf in_hell-$pkgver/ "$pkgdir"/opt/doom3/in_hell/
+
+ install -Dm644 $pkgname.png "$pkgdir"/usr/share/pixmaps/$pkgname.png
+ install -Dm644 $pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+
+ install -Dm755 $pkgname.sh "$pkgdir"/usr/bin/$pkgname
+}
diff --git a/doom3-inhell.desktop b/doom3-inhell.desktop
new file mode 100644
index 000000000000..11e5c1ee81e1
--- /dev/null
+++ b/doom3-inhell.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=In Hell
+Comment=Doom3 mod inspired by Ultimate Doom
+Icon=doom3-inhell
+Exec=doom3-inhell
+Type=Application
+Categories=Application;Game;ActionGame;
diff --git a/doom3-inhell.png b/doom3-inhell.png
new file mode 100644
index 000000000000..8e1effbaf39b
--- /dev/null
+++ b/doom3-inhell.png
Binary files differ
diff --git a/doom3-inhell.sh b/doom3-inhell.sh
new file mode 100644
index 000000000000..f984dc3dac33
--- /dev/null
+++ b/doom3-inhell.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec /usr/bin/doom3 +set fs_game in_hell "$@"