summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Schwörer2022-11-11 11:15:20 +0100
committerMike Schwörer2022-11-11 11:15:20 +0100
commit1215660c246051e3f921e257d644ba19abeb3c7a (patch)
tree7caf5aaac5a12f46d7169016ae16295222b4a578
downloadaur-1215660c246051e3f921e257d644ba19abeb3c7a.tar.gz
v1.5
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa8cc10ca4f7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = dops-git
+ pkgdesc = A replacement for the default docker-ps that tries really hard to fit into the width of your terminal.
+ pkgver = 1.5
+ pkgrel = 1
+ url = https://github.com/Mikescher/better-docker-ps
+ arch = any
+ license = Apache
+ makedepends = go
+ makedepends = git
+ source = dops-git::git+https://github.com/Mikescher/better-docker-ps
+ sha256sums = SKIP
+
+pkgname = dops-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b1338b0514f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Mikescher <aur@mikescher.com>
+# Repo: https://github.com/Mikescher/better-docker-ps
+
+pkgname=dops-git
+pkgver=1.5
+pkgrel=1
+
+pkgdesc="A replacement for the default docker-ps that tries really hard to fit into the width of your terminal."
+
+url="https://github.com/Mikescher/better-docker-ps"
+license=('Apache')
+
+makedepends=('go' 'git')
+
+arch=('any')
+
+source=("$pkgname::git+https://github.com/Mikescher/better-docker-ps")
+
+sha256sums=('SKIP')
+
+build() {
+ cd "$pkgname"
+ go build -o dops cmd/dops/main.go
+}
+
+package()
+{
+ install -D -m755 "$pkgname/dops" "${pkgdir}/usr/bin/dops"
+}
+