summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJanez Žemva2023-05-04 06:03:22 +0200
committerJanez Žemva2023-05-04 06:03:22 +0200
commitf7589ba93020b6dea066d7d12d8f5884e0581c33 (patch)
tree858bcbb4a4de2050484d81cbdc6b0b2bcd366df2
parent027749065c2ba071a6682a2f3ff57c57266da66e (diff)
downloadaur-f7589ba93020b6dea066d7d12d8f5884e0581c33.tar.gz
some fixes
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--gcc-djgpp.diff19
3 files changed, 21 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb20657cde25..560eae860cb5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dosbox-gcc
pkgdesc = djgpp cross-compiler for the dosbox environment
pkgver = 13.1.0
- pkgrel = 1
+ pkgrel = 2
url = http://gcc.gnu.org
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 10bf6257183e..aa2b6df38397 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgname=dosbox-gcc
pkgver=13.1.0
_target="i586-pc-msdosdjgpp"
_djver=2.05
-pkgrel=1
+pkgrel=2
pkgdesc="djgpp cross-compiler for the dosbox environment"
arch=('i686' 'x86_64')
url="http://gcc.gnu.org"
diff --git a/gcc-djgpp.diff b/gcc-djgpp.diff
index 0176b7b9f27b..5c6f186136c5 100644
--- a/gcc-djgpp.diff
+++ b/gcc-djgpp.diff
@@ -926,3 +926,22 @@ index 19d246100cb..1463a59b45a 100644
return has_root_name() && has_root_directory();
#else
return has_root_directory();
+--- a/libstdc++-v3/src/c++11/shared_ptr.cc
++++ b/libstdc++-v3/src/c++11/shared_ptr.cc
+@@ -22,6 +22,7 @@
+ // see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
+ // <http://www.gnu.org/licenses/>.
+
++#include <cstddef>
+ #include <memory>
+
+ #include "mutex_pool.h"
+@@ -35,7 +36,7 @@
+ get_mutex(unsigned char i)
+ {
+ // increase alignment to put each lock on a separate cache line
+- struct alignas(64) M : __gnu_cxx::__mutex { };
++ struct alignas(std::max_align_t) M : __gnu_cxx::__mutex { };
+ // Use a static buffer, so that the mutexes are not destructed
+ // before potential users (or at all)
+ static __attribute__ ((aligned(__alignof__(M))))