summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-10-02 23:21:41 +0000
committerDaniel Bermond2020-10-02 23:27:49 +0000
commitfb1cd080761cd94a673f053773f260794321bb4b (patch)
tree100d38b3f47ba471b290549a002913f7585d712b
parente5336353154f02369fcb83634d07f9e3bc27c1bb (diff)
downloadaur-fb1cd080761cd94a673f053773f260794321bb4b.tar.gz
Refresh patch. Cosmetic changes.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
-rw-r--r--dosbox-openglide-svn.patch57
3 files changed, 30 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 250bf24b26aa..c818dff05257 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dosbox-openglide-svn
pkgdesc = DOS emulator for running DOS games (with openglide 3D, svn version)
- pkgver = 0.74.2.r4329
+ pkgver = 0.74.2.r4369
pkgrel = 1
url = https://www.dosbox.com/
arch = x86_64
@@ -29,7 +29,7 @@ pkgbase = dosbox-openglide-svn
sha256sums = ed391bb9fb0e7b5d33b92882356f02b05913361675712d93b4ef303d5b9f2ac9
sha256sums = 680c8543cb0329000a36c188bb95999c6fae159d3704a4496b54cfada360c7e5
sha256sums = 491c42d16fc5ef7ee2eca1b736f7801249d4ca8c0b236a001aec0d3e24504f3b
- sha256sums = 252c9590b10bb336c2541fe9d88b80a708553a525f141fce5e02fa80754959b0
+ sha256sums = 0fdefd8522a42d5106c4be87016113af3dd63265f5c936696cd1099e07bff56e
pkgname = dosbox-openglide-svn
diff --git a/PKGBUILD b/PKGBUILD
index f9bf5b682ab6..4884587f0951 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=dosbox-openglide-svn
-pkgver=0.74.2.r4329
+pkgver=0.74.2.r4369
pkgrel=1
pkgdesc='DOS emulator for running DOS games (with openglide 3D, svn version)'
arch=('x86_64')
@@ -25,7 +25,7 @@ sha256sums=('SKIP'
'ed391bb9fb0e7b5d33b92882356f02b05913361675712d93b4ef303d5b9f2ac9'
'680c8543cb0329000a36c188bb95999c6fae159d3704a4496b54cfada360c7e5'
'491c42d16fc5ef7ee2eca1b736f7801249d4ca8c0b236a001aec0d3e24504f3b'
- '252c9590b10bb336c2541fe9d88b80a708553a525f141fce5e02fa80754959b0')
+ '0fdefd8522a42d5106c4be87016113af3dd63265f5c936696cd1099e07bff56e')
prepare() {
cd dosbox
@@ -39,15 +39,8 @@ prepare() {
}
pkgver() {
- cd dosbox
-
- local _version
- local _revision
-
- _version="$(head -n1 VERSION | sed 's/-/./g')"
- _revision="$(svnversion | tr -d 'A-z')"
-
- printf '%s.r%s' "$_version" "$_revision"
+ printf '%s.r%s' "$(head -n1 dosbox/VERSION | sed 's/-/./g')" \
+ "$(svnversion dosbox | tr -d 'A-z')"
}
build() {
diff --git a/dosbox-openglide-svn.patch b/dosbox-openglide-svn.patch
index b49ab94b7d54..65b0fe3caf11 100644
--- a/dosbox-openglide-svn.patch
+++ b/dosbox-openglide-svn.patch
@@ -1,6 +1,5 @@
-diff -Naurp a/configure.ac b/configure.ac
---- a/configure.ac 2020-02-18 16:16:51.000000000 +0000
-+++ b/configure.ac 2020-02-18 16:29:49.000000000 +0000
+--- a/configure.ac
++++ b/configure.ac
@@ -598,7 +598,7 @@ int main(int argc,char * argv[]) {
dnl Some target detection and actions for them
case "$host" in
@@ -10,9 +9,8 @@ diff -Naurp a/configure.ac b/configure.ac
AC_DEFINE(C_DIRECTSERIAL, 1, [ Define to 1 if you want serial passthrough support (Win32, Posix and OS/2 only).])
if test x$have_sdl_net_lib = xyes -a x$have_sdl_net_h = xyes ; then
LIBS="$LIBS -lws2_32"
-diff -Naurp a/include/glidedef.h b/include/glidedef.h
---- a/include/glidedef.h 1970-01-01 00:00:00.000000000 +0000
-+++ b/include/glidedef.h 2020-02-18 16:20:33.000000000 +0000
+--- a/include/glidedef.h
++++ b/include/glidedef.h
@@ -0,0 +1,179 @@
+/*
+ * Copyright (C) 2002-2007 The DOSBox Team
@@ -193,9 +191,8 @@ diff -Naurp a/include/glidedef.h b/include/glidedef.h
+#endif // __3DFX_H__
+
+#endif // GLIDEDEF_H
-diff -Naurp a/include/glide.h b/include/glide.h
---- a/include/glide.h 1970-01-01 00:00:00.000000000 +0000
-+++ b/include/glide.h 2020-02-18 16:20:33.000000000 +0000
+--- a/include/glide.h
++++ b/include/glide.h
@@ -0,0 +1,331 @@
+/*
+ * Copyright (C) 2002-2007 The DOSBox Team
@@ -528,10 +525,9 @@ diff -Naurp a/include/glide.h b/include/glide.h
+};
+
+#endif // DOSBOX_GLIDE_H
-diff -Naurp a/include/mem.h b/include/mem.h
---- a/include/mem.h 2019-06-15 00:25:57.000000000 +0000
-+++ b/include/mem.h 2020-02-18 16:20:33.000000000 +0000
-@@ -152,6 +152,8 @@ static INLINE Bit32u phys_readd(PhysPt a
+--- a/include/mem.h
++++ b/include/mem.h
+@@ -173,6 +173,8 @@ static INLINE Bit32u phys_readd(PhysPt a
void MEM_BlockWrite(PhysPt pt,void const * const data,Bitu size);
void MEM_BlockRead(PhysPt pt,void * data,Bitu size);
@@ -540,9 +536,8 @@ diff -Naurp a/include/mem.h b/include/mem.h
void MEM_BlockCopy(PhysPt dest,PhysPt src,Bitu size);
void MEM_StrCopy(PhysPt pt,char * data,Bitu size);
-diff -Naurp a/src/dosbox.cpp b/src/dosbox.cpp
---- a/src/dosbox.cpp 2020-02-18 16:16:50.000000000 +0000
-+++ b/src/dosbox.cpp 2020-02-18 16:20:33.000000000 +0000
+--- a/src/dosbox.cpp
++++ b/src/dosbox.cpp
@@ -81,6 +81,7 @@ void PCI_Init(Section*);
void KEYBOARD_Init(Section*); //TODO This should setup INT 16 too but ok ;)
@@ -551,7 +546,7 @@ diff -Naurp a/src/dosbox.cpp b/src/dosbox.cpp
void MOUSE_Init(Section*);
void SBLASTER_Init(Section*);
void GUS_Init(Section*);
-@@ -752,6 +753,17 @@ void DOSBOX_Init(void) {
+@@ -753,6 +754,17 @@ void DOSBOX_Init(void) {
Pmulti_remain->Set_help("see serial1");
@@ -569,9 +564,8 @@ diff -Naurp a/src/dosbox.cpp b/src/dosbox.cpp
/* All the DOS Related stuff, which will eventually start up in the shell */
secprop=control->AddSection_prop("dos",&DOS_Init,false);//done
secprop->AddInitFunction(&XMS_Init,true);//done
-diff -Naurp a/src/gui/sdlmain.cpp b/src/gui/sdlmain.cpp
---- a/src/gui/sdlmain.cpp 2020-02-18 16:16:51.000000000 +0000
-+++ b/src/gui/sdlmain.cpp 2020-02-18 16:20:33.000000000 +0000
+--- a/src/gui/sdlmain.cpp
++++ b/src/gui/sdlmain.cpp
@@ -50,6 +50,7 @@
#include "cross.h"
#include "control.h"
@@ -580,7 +574,7 @@ diff -Naurp a/src/gui/sdlmain.cpp b/src/gui/sdlmain.cpp
#define MAPPERFILE "mapper-" VERSION ".map"
//#define DISABLE_JOYSTICK
-@@ -604,6 +605,10 @@ check_gotbpp:
+@@ -612,6 +613,10 @@ check_gotbpp:
void GFX_ResetScreen(void) {
@@ -591,7 +585,7 @@ diff -Naurp a/src/gui/sdlmain.cpp b/src/gui/sdlmain.cpp
GFX_Stop();
if (sdl.draw.callback)
(sdl.draw.callback)( GFX_CallBackReset );
-@@ -1214,6 +1219,9 @@ void GFX_SwitchFullScreen(void) {
+@@ -1227,6 +1232,9 @@ void GFX_SwitchFullScreen(void) {
sticky_keys(true); //restore sticky keys to default state in windowed mode.
#endif
}
@@ -601,7 +595,7 @@ diff -Naurp a/src/gui/sdlmain.cpp b/src/gui/sdlmain.cpp
GFX_ResetScreen();
}
-@@ -2104,7 +2112,7 @@ void GFX_Events() {
+@@ -2117,7 +2125,7 @@ void GFX_Events() {
throw(0);
break;
case SDL_VIDEOEXPOSE:
@@ -610,7 +604,7 @@ diff -Naurp a/src/gui/sdlmain.cpp b/src/gui/sdlmain.cpp
break;
#ifdef WIN32
case SDL_KEYDOWN:
-@@ -2558,6 +2566,7 @@ int main(int argc, char* argv[]) {
+@@ -2577,6 +2585,7 @@ int main(int argc, char* argv[]) {
if (strcmp(sdl_drv_name,"windib")==0) LOG_MSG("SDL_Init: Starting up with SDL windib video driver.\n Try to update your video card and directx drivers!");
}
#endif
@@ -618,9 +612,8 @@ diff -Naurp a/src/gui/sdlmain.cpp b/src/gui/sdlmain.cpp
sdl.num_joysticks=SDL_NumJoysticks();
/* Parse configuration files */
-diff -Naurp a/src/hardware/glide.cpp b/src/hardware/glide.cpp
---- a/src/hardware/glide.cpp 1970-01-01 00:00:00.000000000 +0000
-+++ b/src/hardware/glide.cpp 2020-02-18 16:20:33.000000000 +0000
+--- a/src/hardware/glide.cpp
++++ b/src/hardware/glide.cpp
@@ -0,0 +1,1962 @@
+/*
+ * Copyright (C) 2002-2013 The DOSBox Team
@@ -2584,9 +2577,8 @@ diff -Naurp a/src/hardware/glide.cpp b/src/hardware/glide.cpp
+
+ } /* switch */
+} /* process_msg() */
-diff -Naurp a/src/hardware/Makefile.am b/src/hardware/Makefile.am
---- a/src/hardware/Makefile.am 2019-06-15 00:25:57.000000000 +0000
-+++ b/src/hardware/Makefile.am 2020-02-18 16:20:33.000000000 +0000
+--- a/src/hardware/Makefile.am
++++ b/src/hardware/Makefile.am
@@ -10,6 +10,6 @@ libhardware_a_SOURCES = adlib.cpp dma.cp
memory.cpp mixer.cpp pcspeaker.cpp pci_bus.cpp pic.cpp sblaster.cpp tandy_sound.cpp timer.cpp \
vga.cpp vga_attr.cpp vga_crtc.cpp vga_dac.cpp vga_draw.cpp vga_gfx.cpp vga_other.cpp \
@@ -2595,9 +2587,8 @@ diff -Naurp a/src/hardware/Makefile.am b/src/hardware/Makefile.am
+ cmos.cpp disney.cpp gus.cpp mpu401.cpp ipx.cpp ipxserver.cpp dbopl.cpp glide.cpp
-diff -Naurp a/src/hardware/memory.cpp b/src/hardware/memory.cpp
---- a/src/hardware/memory.cpp 2019-06-15 00:25:55.000000000 +0000
-+++ b/src/hardware/memory.cpp 2020-02-18 16:20:33.000000000 +0000
+--- a/src/hardware/memory.cpp
++++ b/src/hardware/memory.cpp
@@ -23,6 +23,7 @@
#include "setup.h"
#include "paging.h"