summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Cuche2022-12-27 08:52:45 +0100
committerMike Cuche2022-12-27 08:52:45 +0100
commit915c22a3f798fae64bda562db89af4731bc76a58 (patch)
tree7a4b8df90f4d311c6a177dc2b1b869211d28c932
parenteba5b688b85a53b7a692b1ffb8cb2384b31ac1c6 (diff)
downloadaur-915c22a3f798fae64bda562db89af4731bc76a58.tar.gz
v. 2022.12.26
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 77ab0b6e13fe..37176f6410cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dosbox-x
pkgdesc = x86 emulator with builtin DOS, with patches with more features
- pkgver = 2022.08.0
+ pkgver = 2022.12.26
pkgrel = 1
url = http://dosbox-x.com
arch = i686
@@ -19,7 +19,7 @@ pkgbase = dosbox-x
depends = libpcap
optdepends = openglide-git: Third-party 3dfx Glide API support
conflicts = dosbox-x-git
- source = https://github.com/joncampbell123/dosbox-x/archive/dosbox-x-windows-v2022.08.0.tar.gz
- sha256sums = bac936ee198b607fb0cc55dfc4575e44b700dbc9138904d2e264792a6e6a941c
+ source = https://github.com/joncampbell123/dosbox-x/archive/dosbox-x-v2022.12.26.tar.gz
+ sha256sums = 39fb1ed19ea31e11883aa57655493b3100ac6b328ef59c799b840b9bfdfacb7b
pkgname = dosbox-x
diff --git a/PKGBUILD b/PKGBUILD
index 8ad50b0d8634..20846e1a786c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mike Cuche <cuche AT mailbox.org>
pkgname=dosbox-x
-pkgver=2022.08.0
+pkgver=2022.12.26
pkgrel=1
pkgdesc="x86 emulator with builtin DOS, with patches with more features"
arch=(i686 x86_64 aarch64)
@@ -11,12 +11,12 @@ depends=(fluidsynth libxkbfile libpng libxrandr mesa ffmpeg4.4 physfs libslirp l
makedepends=(glu)
optdepends=('openglide-git: Third-party 3dfx Glide API support')
conflicts=(dosbox-x-git)
-source=(https://github.com/joncampbell123/dosbox-x/archive/dosbox-x-windows-v${pkgver}.tar.gz)
+source=(https://github.com/joncampbell123/dosbox-x/archive/dosbox-x-v${pkgver}.tar.gz)
-sha256sums=('bac936ee198b607fb0cc55dfc4575e44b700dbc9138904d2e264792a6e6a941c')
+sha256sums=('39fb1ed19ea31e11883aa57655493b3100ac6b328ef59c799b840b9bfdfacb7b')
build() {
- cd $srcdir/dosbox-x-dosbox-x-windows-v${pkgver}
+ cd $srcdir/dosbox-x-dosbox-x-v${pkgver}
sed -i -e 's/-j3/-j$(nproc)/g' build
sed -i 's|"$LIBS -lavcodec -lavformat -lavutil -lswscale "`pkg-config libavcodec --libs`|`pkg-config libavcodec libavformat libavutil libswscale libswresample --libs`"$LIBS"|' configure.ac #ffmpeg avcodec fix
sed -i 's|$LIBS $SDL_LIBS|$LIBS $SDL_LIBS -lm -lGL|' configure.ac #fluidsynth fix
@@ -24,6 +24,6 @@ build() {
}
package() {
- cd $srcdir/dosbox-x-dosbox-x-windows-v${pkgver}
+ cd $srcdir/dosbox-x-dosbox-x-v${pkgver}
make DESTDIR="${pkgdir}" install
}