summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Cuche2023-09-02 15:38:12 +0200
committerMike Cuche2023-09-02 15:38:12 +0200
commitc292d8de28694ada47f3e03c9ecd28f8ff30d64b (patch)
tree1dad121949263baa3a2a081392ae30215f841944
parent564266eef1c068a1b833a5a54e3ffc7f9b0c53dc (diff)
downloadaur-c292d8de28694ada47f3e03c9ecd28f8ff30d64b.tar.gz
v. 2023.09.01
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 547f9d45f628..bd56fbb11046 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dosbox-x
pkgdesc = x86 emulator with builtin DOS, with patches with more features
- pkgver = 2023.05.01
+ pkgver = 2023.09.01
pkgrel = 1
url = http://dosbox-x.com
arch = i686
@@ -19,7 +19,7 @@ pkgbase = dosbox-x
depends = libpcap
optdepends = openglide-git: Third-party 3dfx Glide API support
conflicts = dosbox-x-git
- source = https://github.com/joncampbell123/dosbox-x/archive/dosbox-x-v2023.05.01.tar.gz
- sha256sums = 0aa75b873978aec41ecfee62bb103d8a17fe3566a3ebf5415245cee0dd032ebb
+ source = https://github.com/joncampbell123/dosbox-x/archive/dosbox-x-v2023.09.01.tar.gz
+ sha256sums = 71bf4477ae1640406fa24023f51766ab158ebf26f0e2f317f6fd7bd84c15b4e6
pkgname = dosbox-x
diff --git a/PKGBUILD b/PKGBUILD
index fcdb61cdceb5..32689f75009d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mike Cuche <cuche AT mailbox.org>
pkgname=dosbox-x
-pkgver=2023.05.01
+pkgver=2023.09.01
pkgrel=1
pkgdesc="x86 emulator with builtin DOS, with patches with more features"
arch=(i686 x86_64 aarch64)
@@ -13,10 +13,17 @@ optdepends=('openglide-git: Third-party 3dfx Glide API support')
conflicts=(dosbox-x-git)
source=(https://github.com/joncampbell123/dosbox-x/archive/dosbox-x-v${pkgver}.tar.gz)
-sha256sums=('0aa75b873978aec41ecfee62bb103d8a17fe3566a3ebf5415245cee0dd032ebb')
+sha256sums=('71bf4477ae1640406fa24023f51766ab158ebf26f0e2f317f6fd7bd84c15b4e6')
build() {
cd $srcdir/dosbox-x-dosbox-x-v${pkgver}
+
+ #Workaround: https://github.com/joncampbell123/dosbox-x/issues/4436
+ export CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fno-plt -fexceptions \
+ -Wp,-D_FORTIFY_SOURCE=2 -Wformat \
+ -fstack-clash-protection -fcf-protection"
+ export CXXFLAGS="$CFLAGS -Wp,-D_GLIBCXX_ASSERTIONS"
+
sed -i -e 's/-j3/-j$(nproc)/g' build
./build
}