summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2022-02-18 14:42:22 +0100
committerFrederic Bezies2022-02-18 14:42:22 +0100
commit53aa28bfcb21423d4a73d64f7bb3c642a95a6392 (patch)
tree01befcd2366694fdeadb6780bd3eb6adbab6afc3
parente32aa0bb6507c6f06a015a91db871156296207f1 (diff)
downloadaur-53aa28bfcb21423d4a73d64f7bb3c642a95a6392.tar.gz
using ffmpeg 4.4, thanks to Grapelli for the needed lines
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 9 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8bf150a0a0a..596eac0e7dd4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dosbox-x-sdl2-git
pkgdesc = x86 emulator with builtin DOS, with patches with more features - sdl2 git version
- pkgver = 0.83.22.r22.g899f7e620
- pkgrel = 2
+ pkgver = 0.83.22.r29.g504b33a49
+ pkgrel = 1
epoch = 1
url = https://dosbox-x.com/
install = dosbox-x.install
@@ -13,7 +13,7 @@ pkgbase = dosbox-x-sdl2-git
depends = fluidsynth
depends = libxkbfile
depends = libxrandr
- depends = ffmpeg
+ depends = ffmpeg4.4
depends = sdl2_net
depends = libslirp
conflicts = dosbox-x-sdl2
diff --git a/PKGBUILD b/PKGBUILD
index 20423a1c4b14..89da33d3689b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Mantainer: Franco Tortoriello
pkgname=dosbox-x-sdl2-git
-pkgver=0.83.22.r22.g899f7e620
-pkgrel=2
+pkgver=0.83.22.r29.g504b33a49
+pkgrel=1
epoch=1
pkgdesc="x86 emulator with builtin DOS, with patches with more features - sdl2 git version"
arch=(i686 x86_64)
url="https://dosbox-x.com/"
license=(GPL)
-depends=(fluidsynth libxkbfile libxrandr ffmpeg sdl2_net libslirp)
+depends=(fluidsynth libxkbfile libxrandr ffmpeg4.4 sdl2_net libslirp)
makedepends=(git glu)
conflicts=(dosbox-x-sdl2 dosbox-x-git dosbox-x)
install='dosbox-x.install'
@@ -22,14 +22,10 @@ pkgver() {
build() {
cd "$srcdir/dosbox-x"
- export LDFLAGS="${LDFLAGS//,--as-needed}"
- # Workaround bug https://github.com/joncampbell123/dosbox-x/issues/3039
- export CFLAGS=${CFLAGS/-Werror=format-security/}
- export CXXFLAGS=${CXXFLAGS/-Werror=format-security/}
+ # Working around bug : https://github.com/joncampbell123/dosbox-x/issues/3283
+ sed -i 's|"$LIBS -lavcodec -lavformat -lavutil -lswscale "`pkg-config libavcodec --libs`|`pkg-config libavcodec libavformat libavutil libswscale libswresample --libs`"$LIBS"|' configure.ac
./autogen.sh
- # until bug https://github.com/joncampbell123/dosbox-x/issues/3283
- # is fixed, disabling avcodec support
- ./configure --enable-core-inline --enable-debug --disable-avcodec --prefix=/usr --enable-sdl2
+ PKG_CONFIG_PATH="/usr/lib/ffmpeg4.4/pkgconfig" ./configure --enable-core-inline --enable-debug --enable-avcodec --prefix=/usr --enable-sdl2
make -j$(nproc)
}