summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2012-12-03 08:41:29 -0800
committerMike Swanson2012-12-03 08:41:29 -0800
commit0ec4e5d539be379b3e52fc7c1b0ac63dff4a62a6 (patch)
treea1f361d5046c94ac608304054db075fc1272e2fd
downloadaur-0ec4e5d539be379b3e52fc7c1b0ac63dff4a62a6.tar.gz
Initial commit
-rw-r--r--.SRCINFO33
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD62
-rw-r--r--debianize.patch71
-rw-r--r--xdosemu.desktop8
5 files changed, 179 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f69942c9110c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = dosemu-git
+ pkgdesc = DOS emulator
+ pkgver = 20121125
+ pkgrel = 1
+ url = http://www.dosemu.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = custom
+ makedepends = subversion
+ depends = gpm
+ depends = slang
+ depends = sdl
+ depends = libxxf86vm
+ depends = libsndfile
+ depends = sh
+ depends = xorg-mkfontdir
+ depends = xorg-bdftopcf
+ provides = dosemu
+ conflicts = dosemu
+ noextract = dosemu-freedos-1.1-bin.tgz
+ backup = etc/dosemu/dosemu.conf
+ backup = etc/dosemu/dosemu.users
+ backup = etc/dosemu/global.conf
+ source = https://dl.dropbox.com/u/13513277/dosemu/dosemu-freedos-1.1-bin.tgz
+ source = debianize.patch
+ source = xdosemu.desktop
+ sha256sums = 8f25916dc7f58e71398820b9bc83987cb39e3cd23a7d2d15a7294b2d42cfbed0
+ sha256sums = 9d07462543a6ce35eca7e647c17e1de7193de0a9067b83159aa1f6a18391a6ea
+ sha256sums = ae737e26165c016242d5a8603a5c887c313570e1525091b30f9e8d23d1a9faab
+
+pkgname = dosemu-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ac22e547c2bd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.pkg.tar*
+*.src.tar*
+*.tgz
+src
+pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db61d8787cab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
+
+# Based on the Arch Linux PKGBUILD by:
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Jaroslaw Swierczynski <swiergot@aur.archlinux.org>
+# Contributor: Eric Belanger <belanger@astro.umontreal.ca>
+# Contributor: Bob Finch <w9ya@arrl.net>
+
+pkgname=dosemu-git
+pkgver=20121125
+pkgrel=1
+pkgdesc="DOS emulator"
+arch=('i686' 'x86_64')
+url="http://www.dosemu.org/"
+license=('GPL' 'custom')
+depends=('gpm' 'slang' 'sdl' 'libxxf86vm' 'libsndfile' 'sh' 'xorg-mkfontdir' 'xorg-bdftopcf')
+makedepends=('subversion')
+conflicts=('dosemu')
+provides=('dosemu')
+backup=('etc/dosemu/dosemu.conf'
+ 'etc/dosemu/dosemu.users'
+ 'etc/dosemu/global.conf')
+source=(https://dl.dropbox.com/u/13513277/dosemu/dosemu-freedos-1.1-bin.tgz
+ debianize.patch
+ xdosemu.desktop)
+sha256sums=('8f25916dc7f58e71398820b9bc83987cb39e3cd23a7d2d15a7294b2d42cfbed0'
+ '9d07462543a6ce35eca7e647c17e1de7193de0a9067b83159aa1f6a18391a6ea'
+ 'ae737e26165c016242d5a8603a5c887c313570e1525091b30f9e8d23d1a9faab')
+noextract=('dosemu-freedos-1.1-bin.tgz')
+
+_gitroot=git://git.code.sf.net/p/dosemu/code
+_gitname=dosemu
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server..."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "SVN checkout done or server timeout"
+ msg "Starting build..."
+
+ cd "$srcdir/$_gitname"
+ patch -p1 < ../debianize.patch
+ sed -ie '/yyget_leng/ s/int/size_t/' src/base/init/lexer.h
+ ./configure --prefix=/usr --with-fdtarball="$srcdir/dosemu-freedos-1.1-bin.tgz" --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ make DESTDIR="$pkgdir" install
+ install -Dm 644 "$srcdir"/xdosemu.desktop "$pkgdir"/usr/share/applications/xdosemu.desktop
+ install -Dm 644 etc/dosemu.xpm "$pkgdir"/usr/share/icons/dosemu.xpm
+ install -Dm 644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+ install -Dm 644 COPYING.DOSEMU "$pkgdir"/usr/share/licenses/$pkgname/COPYING.DOSEMU
+}
diff --git a/debianize.patch b/debianize.patch
new file mode 100644
index 000000000000..51e73ff5cfb7
--- /dev/null
+++ b/debianize.patch
@@ -0,0 +1,71 @@
+Description: adjust where files are installed, which seems specific to Debian.
+ Additionally, adjust how the license files are handled, and how they're
+ mentioned in the copyright notice (i.e. point to the locally installed Debian
+ copies instead of duplicating them in the binary package).
+Author: Kees Cook <kees@debian.org>
+Forwarded: not-needed
+
+Index: dosemu-1.4.0+svn.2080/src/emu.c
+===================================================================
+--- dosemu-1.4.0+svn.2080.orig/src/emu.c 2012-06-16 11:51:59.000000000 -0700
++++ dosemu-1.4.0+svn.2080/src/emu.c 2012-06-16 11:54:53.960920640 -0700
+@@ -245,8 +245,8 @@
+ ".\nCopyright (C) 1992-2006 the 'DOSEMU-Development-Team'.\n"
+ "This program is distributed in the hope that it will be useful,\n"
+ "but WITHOUT ANY WARRANTY; without even the implied warranty of\n"
+- "MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the files\n"
+- "COPYING.DOSEMU and COPYING for more details.\n"
++ "MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the file\n"
++ "/usr/share/doc/dosemu/copyright for more details.\n"
+ "Use this program at your own risk!\n\n";
+
+ static char text2[] =
+Index: dosemu-1.4.0+svn.2080/src/arch/linux/Makefile.main
+===================================================================
+--- dosemu-1.4.0+svn.2080.orig/src/arch/linux/Makefile.main 2012-06-16 11:51:59.000000000 -0700
++++ dosemu-1.4.0+svn.2080/src/arch/linux/Makefile.main 2012-06-16 11:54:53.968920748 -0700
+@@ -9,7 +9,7 @@
+ # install DOSEMU.
+
+ SYS = ../commands
+-dosemudir = $(datadir)/dosemu
++dosemudir = $(libdir)/dosemu
+
+ NET=dosext/net/net
+
+@@ -196,7 +196,6 @@
+ $(INSTALL) -d $(DESTDIR)$(bindir)
+ $(INSTALL) -m 0755 ../bin/$(DOSBIN) $(DESTDIR)$(bindir)
+ $(INSTALL) -m 0755 ../bin/dosemu $(DESTDIR)$(bindir)
+- $(INSTALL) -m 0755 ../bin/mkfatimage $(DESTDIR)$(bindir)
+ $(INSTALL) -m 0755 ../bin/mkfatimage16 $(DESTDIR)$(bindir)
+ ifdef USE_SBEMU
+ $(INSTALL) -m 0755 ../bin/midid $(DESTDIR)$(bindir)
+@@ -211,7 +210,7 @@
+ fi; \
+ done
+ $(INSTALL) -d $(DESTDIR)$(docdir)
+- for i in README.bindist NEWS THANKS COPYING COPYING.DOSEMU; do \
++ for i in README.bindist NEWS THANKS; do \
+ $(INSTALL) -m 0644 $(REALTOPDIR)/$$i $(DESTDIR)$(docdir); \
+ done
+ for i in README README-tech dosemu-HOWTO sound-usage DANG EMUfailure \
+Index: dosemu-1.4.0+svn.2080/src/tools/periph/Makefile
+===================================================================
+--- dosemu-1.4.0+svn.2080.orig/src/tools/periph/Makefile 2012-06-16 11:51:55.000000000 -0700
++++ dosemu-1.4.0+svn.2080/src/tools/periph/Makefile 2012-06-16 11:54:53.968920748 -0700
+@@ -11,12 +11,12 @@
+ D=$(REALTOPDIR)/etc
+ IDEST=/var/lib
+
+-CFILES=hdinfo.c mkhdimage.c putrom.c mkfatimage.c mkfatimage16.c \
++CFILES=hdinfo.c mkhdimage.c putrom.c mkfatimage16.c \
+ dexeconfig.c scsicheck.c dosctrl.c vbioscheck.c
+ SFILES=bootsect.S
+ SRC=$(CFILES) $(SFILES)
+ OBJ1=hdinfo mkhdimage putrom dexeconfig scsicheck dosctrl vbioscheck
+-OBJ=$(OBJ1) $(BINPATH)/bin/mkfatimage $(BINPATH)/bin/mkfatimage16
++OBJ=$(OBJ1) $(BINPATH)/bin/mkfatimage16
+ SCRIPT=getrom
+
+ ALL_CPPFLAGS += -I.
diff --git a/xdosemu.desktop b/xdosemu.desktop
new file mode 100644
index 000000000000..c8bdcea7debf
--- /dev/null
+++ b/xdosemu.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=DOSEMU
+Exec=xdosemu
+Icon=dosemu
+Terminal=false
+Type=Application
+Categories=Emulator;System;
+GenericName=DOS Emulator