summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2021-03-30 04:00:58 -0400
committerChris Severance2021-03-30 04:00:58 -0400
commit4a1daec2f585aff87ac59f93484ecb92d7566857 (patch)
tree19619672b5d2c54943da2839a48ee8983dc9d509
parent2b7ec6454a6161e9a51dae37b72edf735be9d0ec (diff)
downloadaur-4a1daec2f585.tar.gz
autu: Update to 2.0pre8.r2855.gb12525bbd-1 Fix prefix for autoconf 2.71
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD39
2 files changed, 28 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61501123e350..6fb8f4ad480c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Fri May 29 19:59:09 UTC 2020
pkgbase = dosemu2-git
pkgdesc = Virtual machine that allows you to run DOS programs under Linux
- pkgver = 2.0pre8.r1875.gf8fb7ac43
+ pkgver = 2.0pre8.r2855.gb12525bbd
pkgrel = 1
url = https://github.com/dosemu2/dosemu2
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 50817d354d06..e9b002b38b96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,9 +29,11 @@ _opt_fdpp=0
# 0 = use freedos
# 1 = use fdpp and comcom32 (boot only, freedos is still used for utilities)
+#_commit='#commit=260ff21fea5de'; SOURCE_DATE_EPOCH="$(date +%s -d '2021-03-06 04:16')"
+
_pkgname='dosemu2'
pkgname="${_pkgname}-git"
-pkgver=2.0pre8.r1875.gf8fb7ac43
+pkgver=2.0pre8.r2855.gb12525bbd
pkgrel=1
_pkgver="${pkgver%%[a-z]*}"
pkgdesc='Virtual machine that allows you to run DOS programs under Linux'
@@ -78,7 +80,7 @@ _freedos='dosemu-freedos-1.1-bin.tgz'
#_freedos='dosemu-freedos-bin.tgz'
#_freedos='msdos70-bin.tgz' # install.c will need to be fixed before this is automatic
source=(
- "git+https://github.com/${_github}.git"
+ "git+https://github.com/${_github}.git${_commit:-}"
'http://downloads.sourceforge.net/sourceforge/dosemu/dosemu-freedos-1.0-bin.tgz' # for the GNU utils
)
if [ "${_freedos}" != 'none' ]; then
@@ -113,21 +115,30 @@ prepare() {
fi
done
+ shopt -s nullglob
+ for _pt in "${startdir}/"/*.localpatch; do
+ set +u; msg2 "Local Patch ${_pt}"; set -u
+ patch -Nup1 -i "${_pt}"
+ done
+ shopt -u nullglob
+
# Some makepkg options including -i erroneously run prepare() for vcs packages
if [ -f 'debian/rules' ]; then
if [ "${_freedos}" != 'none' ]; then
ln -sf "../${_freedos}"
fi
#ln -s '../.git' 'src/.git'
- sed -e '# Enable VDE' \
- -e 's:^\(\s*plugin_vde\)\s.*$:\1 on:g' \
- -e '# Update freedos' \
- -e 's:^\(\s*fdtarball\)\s.*$:'"\1 ${_freedos}:g" \
- -e '# This breaks PREFIX and we still need freedos' \
- -e '#s:^\(\s*fdtarball\)\s.*$:'"\1:g" \
- -e '# Prefix' \
- -e 's:^}$: prefix /usr\n&:g' \
- -i 'compiletime-settings'{,.devel}
+ local _onoff=(off on on)
+ cat > 'compiletime-settings' << EOF
+config {
+ sysconfdir /etc
+ fdtarball ${_freedos}
+ prefix /usr
+ plugin_vde on
+ fdpp ${_onoff[${_opt_fdpp}]}
+ debug ${_onoff[${_opt_Debug}]}
+}
+EOF
rm -f 'debian/rules' # We don't use this file so I'm using it as a flag.
fi
set +u
@@ -153,7 +164,7 @@ _configure() { # makepkg -e compatible
fi
echo "CFLAGS=${CFLAGS}"
CFLAGS="${CFLAGS} -Wno-unused-result" \
- ./default-configure "${_opts[@]:-}"
+ "${PWD}"/default-configure "${_opts[@]}" --prefix='/usr'
fi
set +u
cd "${srcdir}"
@@ -176,6 +187,7 @@ package() {
set -u
cd 'dosemu2'
make DESTDIR="${pkgdir}" install
+ test -d "${pkgdir}/usr/local" && echo "${}"
if [ "${_opt_Debug}" -eq 0 ] || [ "${_opt_keepdesktop}" -ne 0 ]; then # sudo in the launcher crashes cinnamon
install -Dm644 <(cat << EOF
[Desktop Entry]
@@ -206,6 +218,9 @@ fi
-e "s@^get_binary()@${_code//${_lf}/\\n}&@g" \
"${pkgdir}/usr/bin/dosemu"
fi
+ if [ "${_opt_fdpp}" -ne 0 ]; then
+ : find "${pkgdir}" -name 'command.com' -delete # remove files and symlinks
+ fi
set +u
}