summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaël PORTAY2019-08-13 16:08:41 -0400
committerGaël PORTAY2019-08-13 16:10:51 -0400
commitdc426f9c569c861d258c6231def63af5d78bea45 (patch)
tree04c00fbd19bd7597a66a894659a14da6c92a9032
downloadaur-dc426f9c569c861d258c6231def63af5d78bea45.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9808b3876740
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = dosh
+ pkgdesc = Docker shell
+ pkgver = 1.6
+ pkgrel = 1
+ url = https://github.com/gportay/dosh
+ arch = any
+ license = MIT
+ checkdepends = shellcheck
+ makedepends = asciidoctor
+ depends = docker
+ source = https://github.com/gportay/dosh/archive/1.6.tar.gz
+ md5sums = 33673c1fb370c691b75850cab671488e
+
+pkgname = dosh
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e95ff3687d71
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Gaël PORTAY <gael.portay@gmail.com>
+
+pkgname=dosh
+pkgver=1.6
+pkgrel=1
+pkgdesc='Docker shell'
+arch=('any')
+url="https://github.com/gportay/$pkgname"
+license=('MIT')
+depends=('docker')
+makedepends=('asciidoctor')
+checkdepends=('shellcheck')
+source=("https://github.com/gportay/$pkgname/archive/$pkgver.tar.gz")
+md5sums=('33673c1fb370c691b75850cab671488e')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make doc
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -D -m 755 dosh "$pkgdir/usr/bin/dosh"
+ install -D -m 644 dosh.1.gz "$pkgdir/usr/share/man/man1/dosh.1.gz"
+ install -D -m 644 bash-completion "$pkgdir/usr/share/bash-completion/completions/dosh"
+ install -D -m 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}