summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRains2015-08-21 18:27:38 +0800
committerRains2015-08-21 18:28:48 +0800
commit0b088c3c30b4127dea35577b2211ee6f0601fec2 (patch)
tree6f6a43fc97293d47682e8b6334d55395a4545122
downloadaur-0b088c3c30b4127dea35577b2211ee6f0601fec2.tar.gz
init
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD26
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3bd56d0d2c07
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = dot-editor
+ pkgdesc = The application, among other things, act as a graphical interface for the popular graphviz package. More generally, it is able to display the output of any text-based program that produces graphic files as output.
+ pkgver = 1.1.2
+ pkgrel = 1
+ url = https://sites.google.com/site/doteditorhome/
+ arch = i686
+ arch = x86_64
+ makedepends = bzip2
+ depends = qt5-base
+ depends = libx11
+ depends = libpng
+ depends = harfbuzz
+ depends = libgl
+ depends = icu
+ depends = libffi
+ depends = graphite
+ options = !emptydirs
+ source = http://tnick.github.com/dot-editor/distrib/1.1.1/source/dot-editor-1.1.1-Source.tar.bz2
+ md5sums = SKIP
+
+pkgname = dot-editor
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f381bd3b11c8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src
+pkg
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aecfb1dc2c63
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+
+pkgname=dot-editor
+pkgver=1.1.2
+pkgrel=1
+pkgdesc="The application, among other things, act as a graphical interface for the popular graphviz package. More generally, it is able to display the output of any text-based program that produces graphic files as output."
+arch=('i686' 'x86_64')
+url="https://sites.google.com/site/doteditorhome/"
+license=('')
+depends=('qt5-base' 'libx11' 'libpng' 'harfbuzz' 'libgl' 'icu' 'libffi' 'graphite')
+makedepends=('bzip2')
+options=('!emptydirs')
+source=("http://tnick.github.com/dot-editor/distrib/1.1.1/source/dot-editor-1.1.1-Source.tar.bz2")
+md5sums=('SKIP')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}-Source
+ cmake . -DCMAKE_INSTALL_PREFIX="$pkgdir/usr" -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}-Source
+ make install
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}