summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwallace2020-07-03 14:55:37 +0300
committerwallace2020-07-03 14:55:37 +0300
commitf81965335a2ec3a83c31aca3fdf4c40ce30d13b4 (patch)
treefedb0ce75f02684db0d3aa595dfc1a43c5262892
downloadaur-f81965335a2ec3a83c31aca3fdf4c40ce30d13b4.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
-rw-r--r--dotbare4
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..349f617f9099
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = dotbare
+ pkgdesc = Manage your dotfiles interactively with fzf
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/denisidoro/navi
+ arch = any
+ license = MIT
+ depends = fzf
+ source = https://github.com/kazhala/dotbare/archive/v1.2.0.tar.gz
+ source = dotbare
+ md5sums = 3cee4b754f2238c4799ca0c75edcc90e
+ md5sums = f6c62c573ace6e97e1948944cf6454cd
+
+pkgname = dotbare
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..748ac5ff2550
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: wallace < str(11) + my_id at gmail dot com>
+
+pkgname=dotbare
+pkgdesc="Manage your dotfiles interactively with fzf"
+pkgver=1.2.0
+pkgrel=1
+arch=("any")
+url="https://github.com/denisidoro/navi"
+license=("MIT")
+depends=('fzf')
+source=("https://github.com/kazhala/dotbare/archive/v${pkgver}.tar.gz" "${pkgname}")
+md5sums=('3cee4b754f2238c4799ca0c75edcc90e'
+ 'f6c62c573ace6e97e1948944cf6454cd')
+
+package() {
+ src="${srcdir}/${pkgname}-${pkgver}"
+ dest="${pkgdir}/opt/${pkgname}"
+
+ # create dirs
+ install -d ${dest}/{,helper,scripts}
+ # main script
+ install -Dm 755 ${src}/${pkgname} ${dest}
+ # additional dirs contents
+ for dir in helper scripts; do
+ install -Dm 755 ${src}/${dir}/* ${dest}/${dir}
+ done
+
+ # HACK: remove upgrade script since we're not on the git repo
+ rm ${dest}/scripts/fupgrade
+
+ # custom "launcher" script
+ install -Dm 755 ${srcdir}/${pkgname} ${pkgdir}/usr/bin/${pkgname}
+}
diff --git a/dotbare b/dotbare
new file mode 100644
index 000000000000..fe2a2f9c47b1
--- /dev/null
+++ b/dotbare
@@ -0,0 +1,4 @@
+#!/usr/bin/env bash
+
+SCRIPT_DIR=/opt/dotbare
+${SCRIPT_DIR}/dotbare "$@"