summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHusam Bilal2018-03-17 02:04:07 +0200
committerHusam Bilal2018-03-17 02:04:07 +0200
commit0df219d8e5b3c629e7b1a01f5856564942156f6c (patch)
treea995851480cae9e149adc000770a6c1d395fe1ac
downloadaur-0df219d8e5b3c629e7b1a01f5856564942156f6c.tar.gz
initial
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..50a87fae0fa6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = dotfiles-git
+ pkgdesc = A tool to make managing your dotfile symlinks in $HOME easy, allowing you to keep all of them in a single directory.
+ pkgver = r358.8998a93
+ pkgrel = 1
+ url = https://github.com/jbernard/dotfiles
+ arch = any
+ license = ISC
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python python-py
+ provides = dotfiles
+ conflicts = dotfiles
+ source = git+https://github.com/jbernard/dotfiles.git
+ md5sums = SKIP
+
+pkgname = dotfiles-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f108c93aa00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Husam Bilal <husam212@gmail.com>
+
+pkgname=dotfiles-git
+_pkgname=dotfiles
+pkgver=r358.8998a93
+pkgrel=1
+pkgdesc='A tool to make managing your dotfile symlinks in $HOME easy, allowing you to keep all of them in a single directory.'
+url='https://github.com/jbernard/dotfiles'
+license=('ISC')
+arch=('any')
+depends=('python python-py')
+makedepends=('git' 'python-setuptools')
+conflicts=('dotfiles')
+provides=('dotfiles')
+source=('git+https://github.com/jbernard/dotfiles.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ python setup.py install --root=$pkgdir
+}