summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKobus van Schoor2015-12-30 12:39:35 +0200
committerKobus van Schoor2015-12-30 12:39:35 +0200
commitf41bd19df91da690da8946790f34c5fbc89303c1 (patch)
tree5bcffd38e64a58239fcf67c7147a798009f366ab
parent79aa6e4d9f382afec401ce7ba6b96dd813bd8daa (diff)
downloadaur-f41bd19df91da690da8946790f34c5fbc89303c1.tar.gz
Updated PKGBUILD to use tags rather than snapshots
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 58995ceed4a7..bf9753987619 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Kobus van Schoor <pbscube at gmail dot com>
pkgname=dotgit
-pkgver=1.0.0
-pkgrel=1
+pkgver=1.0
+pkgrel=2
pkgdesc="A simple bash program to backup all your dotfiles (read multiple hosts) in a single git repo"
url="http://github.com/Cube777/dotgit"
arch=('any')
@@ -9,9 +9,9 @@ depends=('git' 'sed' 'grep' 'bash' )
source=('git+https://github.com/Cube777/dotgit.git')
md5sums=('SKIP')
-pkgver() {
- cd "$pkgname"
- git show -s --format="%ci" HEAD | sed -e 's/-//g' -e 's/ .*//'
+prepare() {
+ cd $pkgname
+ git --work-tree . checkout -q tags/$pkgver
}
package() {