summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGithub Actions2020-05-09 16:13:32 +0000
committerGithub Actions2020-05-09 16:13:32 +0000
commit8088f23184558ff4b1d35d75e3c96e01c990459d (patch)
tree82a2a7c5d63fedf52ea8a22d898699ef578106be
parentd5db77944da906eeea1d52e1e63f308e721db406 (diff)
downloadaur-8088f23184558ff4b1d35d75e3c96e01c990459d.tar.gz
version bump
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 23 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d84583f61c97..e5ab6de8fe55 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = dotgit-git
- pkgdesc = Development version of dotgit
- pkgver = 26.06.2017
- pkgrel = 6
- url = http://github.com/kobus-v-schoor/dotgit
+ pkgdesc = A comprehensive solution to managing your dotfiles
+ pkgver = 2.0.0a5
+ pkgrel = 0
+ url = https://github.com/kobus-v-schoor/dotgit
arch = any
+ makedepends = python-setuptools
depends = git
- depends = bash
- depends = gnupg
- conflicts = dotgit
- source = git+https://github.com/kobus-v-schoor/dotgit.git
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/d/dotgit/dotgit-2.0.0a5.tar.gz
md5sums = SKIP
pkgname = dotgit-git
diff --git a/PKGBUILD b/PKGBUILD
index 18cdbb204ff9..b1cb6cb9407d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,23 @@
-# Maintainer: Kobus van Schoor <pbscube at gmail dot com>
+# Maintainer: Kobus van Schoor <v dot schoor dot kobus at gmail dot com>
pkgname=dotgit-git
-pkgver=26.06.2017
-pkgrel=6
-pkgdesc="Development version of dotgit"
-url="http://github.com/kobus-v-schoor/dotgit"
+pkgver='2.0.0a5'
+pkgrel=0
+pkgdesc='A comprehensive solution to managing your dotfiles'
+url='https://github.com/kobus-v-schoor/dotgit'
arch=('any')
-depends=('git' 'bash' 'gnupg')
-conflicts=('dotgit')
-source=('git+https://github.com/kobus-v-schoor/dotgit.git')
+depends=('git' 'python')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/d/dotgit/dotgit-$pkgver.tar.gz")
md5sums=('SKIP')
+build()
+{
+ cd "dotgit-$pkgver"
+ python setup.py build
+}
+
package()
{
- install -Dm 755 "$srcdir/dotgit/bin/dotgit" "$pkgdir/usr/bin/dotgit"
- cp -r "$srcdir/dotgit/bin/dotgit_headers" "$pkgdir/usr/bin/dotgit_headers"
- chmod 555 "$pkgdir/usr/bin/dotgit_headers"
- install -Dm644 "$srcdir/dotgit/bin/bash_completion" \
- "$pkgdir/usr/share/bash-completion/completions/dotgit"
+ cd "dotgit-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}