summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Liebkies2017-06-30 15:22:38 +0200
committerMax Liebkies2017-06-30 15:22:38 +0200
commitcdbebdea78c86eadbc3a21b94e31c2aad9f93b46 (patch)
tree4bab00becd8135c39d8cdbbbf907fc57219dbc0d
parent6de0ad9ae24dbfac57c2a891985fd890d097cb46 (diff)
downloadaur-cdbebdea78c86eadbc3a21b94e31c2aad9f93b46.tar.gz
Make this package a noop meta package
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD89
-rw-r--r--clang-4-patchset.patch502
-rw-r--r--libcurl.patch23
-rw-r--r--llvm-39-github-pull-8311.patch180
-rw-r--r--llvm-39-move.patch28
-rw-r--r--lttng-uts-40.patch36
7 files changed, 4 insertions, 880 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2193f92043b3..2b571b328b10 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,39 +1,17 @@
pkgbase = dotnet
- pkgdesc = Provides the .NET core shared framework, i.e. coreclr and corefx.
+ pkgdesc = Meta package to pull in the latest stable dotnet package
pkgver = 1.1.2
pkgrel = 1
url = https://www.microsoft.com/net/core
arch = x86_64
license = MIT
- makedepends = cmake
- makedepends = make
- makedepends = clang
- makedepends = llvm
- makedepends = gettext
depends = lldb
depends = libunwind
depends = icu
depends = lttng-ust
depends = libcurl-openssl-1.0
- provides = dotnet=1.1.1
conflicts = dotnet-bin
- options = staticlibs
- source = coreclr-1.1.2.tar.gz::https://github.com/dotnet/coreclr/archive/v1.1.2.tar.gz
- source = corefx-1.1.2.tar.gz::https://github.com/dotnet/corefx/archive/v1.1.2.tar.gz
- source = dotnet-1.1.2.tar.gz::https://download.microsoft.com/download/D/7/A/D7A9E4E9-5D25-4F0C-B071-210CB8267943/dotnet-ubuntu.16.10-x64.1.1.2.tar.gz
- source = llvm-39-github-pull-8311.patch
- source = llvm-39-move.patch
- source = lttng-uts-40.patch
- source = clang-4-patchset.patch
- source = libcurl.patch
- sha256sums = 3dcc98d981b85008b44c994c2805bdbe30a650bfe7ef665a21ce6e36da807435
- sha256sums = 6d7c4598433843129a48ab106b029f5d9f9572c283cbc522114d8fbe3bff04ea
- sha256sums = 0a4d4061931e0154c9186446dbc8d4c3e69ba49537699be98185d55fc24a1b56
- sha256sums = 581d6484626bbae820feb19d0613955fea333c025fb06d43a731a3db776686f7
- sha256sums = 84a0e56d00fd2f3f9f82b7d017652f03d4e7f80c6968d7fa1274f6e46af0ff3d
- sha256sums = d7c6bbc24e8464dcfb4fd86cb76fa3a55f4822f5e8196e41a2c39650432aa401
- sha256sums = 2b884b4cd850027f95cba5deda32226e27ceaa962f0ab2879adc5180cf37c32a
- sha256sums = a32dea005f5379ae59d31e579f4ea13bad03228a8ca39b439b94767541c44450
+ replaces = dotnet-cli
pkgname = dotnet
diff --git a/PKGBUILD b/PKGBUILD
index e1005419f8f8..14a5b3a64402 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,98 +3,13 @@
pkgname=dotnet
pkgver=1.1.2
pkgrel=1
-pkgdesc="Provides the .NET core shared framework, i.e. coreclr and corefx."
+pkgdesc="Meta package to pull in the latest stable dotnet package"
arch=(x86_64)
url="https://www.microsoft.com/net/core"
license=('MIT')
groups=()
depends=('lldb' 'libunwind' 'icu' 'lttng-ust' 'libcurl-openssl-1.0')
-makedepends=('cmake' 'make' 'clang' 'llvm' 'gettext')
-provides=('dotnet=1.1.1')
conflicts=('dotnet-bin')
-replaces=()
-backup=()
-options=(staticlibs)
-install=
-
-source=(
- "coreclr-${pkgver}.tar.gz::https://github.com/dotnet/coreclr/archive/v${pkgver}.tar.gz"
- "corefx-${pkgver}.tar.gz::https://github.com/dotnet/corefx/archive/v${pkgver}.tar.gz"
- "${pkgname}-${pkgver}.tar.gz::https://download.microsoft.com/download/D/7/A/D7A9E4E9-5D25-4F0C-B071-210CB8267943/dotnet-ubuntu.16.10-x64.1.1.2.tar.gz"
- 'llvm-39-github-pull-8311.patch'
- 'llvm-39-move.patch'
- 'lttng-uts-40.patch'
- 'clang-4-patchset.patch'
- 'libcurl.patch')
-
-sha256sums=('3dcc98d981b85008b44c994c2805bdbe30a650bfe7ef665a21ce6e36da807435'
- '6d7c4598433843129a48ab106b029f5d9f9572c283cbc522114d8fbe3bff04ea'
- '0a4d4061931e0154c9186446dbc8d4c3e69ba49537699be98185d55fc24a1b56'
- '581d6484626bbae820feb19d0613955fea333c025fb06d43a731a3db776686f7'
- '84a0e56d00fd2f3f9f82b7d017652f03d4e7f80c6968d7fa1274f6e46af0ff3d'
- 'd7c6bbc24e8464dcfb4fd86cb76fa3a55f4822f5e8196e41a2c39650432aa401'
- '2b884b4cd850027f95cba5deda32226e27ceaa962f0ab2879adc5180cf37c32a'
- 'a32dea005f5379ae59d31e579f4ea13bad03228a8ca39b439b94767541c44450')
-
-prepare() {
- cd "${srcdir}/coreclr-${pkgver}"
- patch -p1 < "${srcdir}/llvm-39-github-pull-8311.patch"
- patch -p1 < "${srcdir}/llvm-39-move.patch"
- patch -p0 < "${srcdir}/lttng-uts-40.patch"
- patch -p1 < "${srcdir}/clang-4-patchset.patch"
-
- cd "${srcdir}/corefx-${pkgver}"
- patch -p0 < "${srcdir}/libcurl.patch"
-}
-
-build() {
- cd "${srcdir}/coreclr-${pkgver}"
- ./build.sh x64 release skiptests
-
- cd "${srcdir}/corefx-${pkgver}"
- CPLUS_INCLUDE_PATH=/usr/include/openssl-1.0 C_INCLUDE_PATH=/usr/include/openssl-1.0 ./src/Native/build-native.sh x64 release cmakeargs -DOPENSSL_INCLUDE_DIR=/usr/include/openssl-1.0 cmakeargs -DOPENSSL_SSL_LIBRARY=/usr/lib/openssl-1.0/libssl.so cmakeargs -DOPENSSL_CRYPTO_LIBRARY=/usr/lib/openssl-1.0/libcrypto.so cmakeargs -DCURL_LIBRARIES=/usr/lib/libcurl-openssl-1.0/libcurl.so
-}
-
-_coreclr_files=(
- 'libclrjit.so'
- 'libcoreclr.so'
- 'libcoreclrtraceptprovider.so'
- 'libdbgshim.so'
- 'libmscordaccore.so'
- 'libmscordbi.so'
- 'libsosplugin.so'
- 'libsos.so'
- 'System.Globalization.Native.so'
-)
-
-_corefx_files=(
- 'System.IO.Compression.Native.so'
- 'System.Native.so'
- 'System.Native.a'
- 'System.Net.Http.Native.so'
- 'System.Net.Security.Native.so'
- 'System.Security.Cryptography.Native.so'
- 'System.Security.Cryptography.Native.OpenSsl.so'
-)
-
-package() {
- mkdir -p "${pkgdir}/opt/dotnet/shared/Microsoft.NETCore.App/"
-
- # copy the original files from the binary archive
- cp --force --preserve=mode --recursive "${srcdir}/shared/Microsoft.NETCore.App/${pkgver}" "${pkgdir}/opt/dotnet/shared/Microsoft.NETCore.App/${pkgver}"
-
- for file in "${_coreclr_files[@]}"; do
- cp --force --preserve=mode "${srcdir}/coreclr-${pkgver}/bin/Product/Linux.x64.Release/${file}" "${pkgdir}/opt/dotnet/shared/Microsoft.NETCore.App/${pkgver}/"
- done
-
- for file in "${_corefx_files[@]}"; do
- cp --force --preserve=mode "${srcdir}/corefx-${pkgver}/bin/Linux.x64.Release/Native/${file}" "${pkgdir}/opt/dotnet/shared/Microsoft.NETCore.App/${pkgver}/"
- done
-
- chown -R root:root "${pkgdir}/opt/dotnet"
- find "${pkgdir}/opt/dotnet" -name *.dll -exec chmod 644 {} \;
- find "${pkgdir}/opt/dotnet" -name *.exe -exec chmod 755 {} \;
- find "${pkgdir}/opt/dotnet" -name *.so -exec chmod 755 {} \;
-}
+replaces=('dotnet-cli')
# vim:set ts=2 sw=2 et:
diff --git a/clang-4-patchset.patch b/clang-4-patchset.patch
deleted file mode 100644
index 9f6ad635cbda..000000000000
--- a/clang-4-patchset.patch
+++ /dev/null
@@ -1,502 +0,0 @@
-diff --git a/build.sh b/build.sh
-index f5cab1e..b0751c2 100755
---- a/build.sh
-+++ b/build.sh
-@@ -671,6 +671,11 @@ while :; do
- __ClangMinorVersion=9
- ;;
-
-+ clang4.0)
-+ __ClangMajorVersion=4
-+ __ClangMinorVersion=0
-+ ;;
-+
- ninja)
- __UseNinja=1
- ;;
-diff --git a/src/ToolBox/SOS/lldbplugin/CMakeLists.txt b/src/ToolBox/SOS/lldbplugin/CMakeLists.txt
-index 247c700..f0c2176 100644
---- a/src/ToolBox/SOS/lldbplugin/CMakeLists.txt
-+++ b/src/ToolBox/SOS/lldbplugin/CMakeLists.txt
-@@ -55,14 +55,15 @@ if(NOT ENABLE_LLDBPLUGIN)
- endif()
-
- # Check for LLDB library
--find_library(LLDB NAMES LLDB lldb lldb-3.8 lldb-3.6 lldb-3.5 PATHS "${WITH_LLDB_LIBS}" PATH_SUFFIXES llvm NO_DEFAULT_PATH)
--find_library(LLDB NAMES LLDB lldb lldb-3.8 lldb-3.6 lldb-3.5 PATH_SUFFIXES llvm)
-+find_library(LLDB NAMES LLDB lldb lldb-4.0 lldb-3.9 lldb-3.8 lldb-3.7 lldb-3.6 lldb-3.5 PATHS "${WITH_LLDB_LIBS}" PATH_SUFFIXES llvm NO_DEFAULT_PATH)
-+find_library(LLDB NAMES LLDB lldb lldb-4.0 lldb-3.8 lldb-3.7 lldb-3.6 lldb-3.5 PATH_SUFFIXES llvm)
- if(LLDB STREQUAL LLDB-NOTFOUND)
- if(REQUIRE_LLDBPLUGIN)
-- message(FATAL_ERROR "Cannot find lldb-3.5, lldb-3.6 or lldb-3.8. Try installing lldb-3.6-dev (or the appropriate package for your platform)")
-+ set(MESSAGE_MODE FATAL_ERROR)
- else()
-- message(WARNING "Cannot find lldb-3.5,lldb-3.6 or lldb-3.8. Try installing lldb-3.6-dev (or the appropriate package for your platform)")
-+ set(MESSAGE_MODE WARNING)
- endif()
-+ message(${MESSAGE_MODE} "Cannot find lldb-3.5, lldb-3.6, lldb-3.8, lldb-3.9 or lldb-4.0. Try installing lldb-3.6-dev (or the appropriate package for your platform)")
- return()
- endif()
-
-diff --git a/src/debug/di/dbgtransportmanager.cpp b/src/debug/di/dbgtransportmanager.cpp
-index 77a3548..8c1079d 100644
---- a/src/debug/di/dbgtransportmanager.cpp
-+++ b/src/debug/di/dbgtransportmanager.cpp
-@@ -102,7 +102,7 @@ HRESULT DbgTransportTarget::GetTransportForProcess(DWORD dwPID
- entry->m_cProcessRef++;
- _ASSERTE(entry->m_cProcessRef > 0);
- _ASSERTE(entry->m_transport != NULL);
-- _ASSERTE(entry->m_hProcess > 0);
-+ _ASSERTE((intptr_t)entry->m_hProcess > 0);
-
- *ppTransport = entry->m_transport;
- if (!DuplicateHandle(GetCurrentProcess(),
-@@ -139,7 +139,7 @@ void DbgTransportTarget::ReleaseTransport(DbgTransportSession *pTransport)
-
- _ASSERTE(entry->m_cProcessRef > 0);
- _ASSERTE(entry->m_transport != NULL);
-- _ASSERTE(entry->m_hProcess > 0);
-+ _ASSERTE((intptr_t)entry->m_hProcess > 0);
-
- if (entry->m_transport == pTransport)
- {
-diff --git a/src/gc/gc.cpp b/src/gc/gc.cpp
-index 745b24f..08de1fa 100644
---- a/src/gc/gc.cpp
-+++ b/src/gc/gc.cpp
-@@ -20356,7 +20356,7 @@ size_t gc_heap::update_brick_table (uint8_t* tree, size_t current_brick,
- dprintf (3, ("tree: %Ix, current b: %Ix, x: %Ix, plug_end: %Ix",
- tree, current_brick, x, plug_end));
-
-- if (tree > 0)
-+ if (tree != NULL)
- {
- dprintf (3, ("b- %Ix->%Ix pointing to tree %Ix",
- current_brick, (size_t)(tree - brick_address (current_brick)), tree));
-diff --git a/src/pal/inc/pal.h b/src/pal/inc/pal.h
-index 9e97edc..7d25940 100644
---- a/src/pal/inc/pal.h
-+++ b/src/pal/inc/pal.h
-@@ -5303,6 +5303,7 @@ inline WCHAR *PAL_wcsstr(WCHAR *_S, const WCHAR *_P)
- }
- #endif
-
-+#if !__has_builtin(_rotl)
- /*++
- Function:
- _rotl
-@@ -5320,12 +5321,15 @@ unsigned int __cdecl _rotl(unsigned int value, int shift)
- retval = (value << shift) | (value >> (sizeof(int) * CHAR_BIT - shift));
- return retval;
- }
-+#endif // !__has_builtin(_rotl)
-
- // On 64 bit unix, make the long an int.
- #ifdef BIT64
- #define _lrotl _rotl
- #endif // BIT64
-
-+#if !__has_builtin(_rotr)
-+
- /*++
- Function:
- _rotr
-@@ -5344,6 +5348,8 @@ unsigned int __cdecl _rotr(unsigned int value, int shift)
- return retval;
- }
-
-+#endif // !__has_builtin(_rotr)
-+
- PALIMPORT int __cdecl abs(int);
- #ifndef PAL_STDCPP_COMPAT
- PALIMPORT LONG __cdecl labs(LONG);
-diff --git a/src/pal/inc/pal_mstypes.h b/src/pal/inc/pal_mstypes.h
-index 0ca2871..0aa35ae 100644
---- a/src/pal/inc/pal_mstypes.h
-+++ b/src/pal/inc/pal_mstypes.h
-@@ -556,7 +556,7 @@ typedef LONG_PTR SSIZE_T, *PSSIZE_T;
- #endif
-
- #ifndef SSIZE_T_MIN
--#define SSIZE_T_MIN I64(-9223372036854775808)
-+#define SSIZE_T_MIN I64(0x8000000000000000)
- #endif
-
- #ifndef PAL_STDCPP_COMPAT
-diff --git a/src/vm/amd64/unixstubs.cpp b/src/vm/amd64/unixstubs.cpp
-index 2904149..76d3cf1 100644
---- a/src/vm/amd64/unixstubs.cpp
-+++ b/src/vm/amd64/unixstubs.cpp
-@@ -37,7 +37,7 @@ extern "C"
- " mov %%edx, 12(%[result])\n" \
- : "=a"(eax) /*output in eax*/\
- : "a"(arg), [result]"r"(result) /*inputs - arg in eax, result in any register*/\
-- : "eax", "rbx", "ecx", "edx", "memory" /* registers that are clobbered, *result is clobbered */
-+ : "rbx", "ecx", "edx", "memory" /* registers that are clobbered, *result is clobbered */
- );
- return eax;
- }
-@@ -52,7 +52,7 @@ extern "C"
- " mov %%edx, 12(%[result])\n" \
- : "=a"(eax) /*output in eax*/\
- : "c"(arg1), "a"(arg2), [result]"r"(result) /*inputs - arg1 in ecx, arg2 in eax, result in any register*/\
-- : "eax", "rbx", "ecx", "edx", "memory" /* registers that are clobbered, *result is clobbered */
-+ : "rbx", "edx", "memory" /* registers that are clobbered, *result is clobbered */
- );
- return eax;
- }
-@@ -63,7 +63,7 @@ extern "C"
- __asm(" xgetbv\n" \
- : "=a"(eax) /*output in eax*/\
- : "c"(0) /*inputs - 0 in ecx*/\
-- : "eax", "edx" /* registers that are clobbered*/
-+ : "edx" /* registers that are clobbered*/
- );
- // check OS has enabled both XMM and YMM state support
- return ((eax & 0x06) == 0x06) ? 1 : 0;
---- a/src/pal/inc/rt/intsafe.h
-+++ b/src/pal/inc/rt/intsafe.h
-@@ -18,26 +18,6 @@
-
- #include <specstrings.h> // for IN, etc.
-
--
--#if defined(_AMD64_)
--#ifdef __cplusplus
--extern "C" {
--#endif
--#define UnsignedMultiply128 _umul128
--ULONG64
--UnsignedMultiply128 (
-- IN ULONG64 Multiplier,
-- IN ULONG64 Multiplicand,
-- OUT ULONG64 *HighProduct
-- );
--#ifdef _MSC_VER
--#pragma intrinsic(_umul128)
--#endif // _MSC_VER
--#ifdef __cplusplus
--}
--#endif
--#endif // _AMD64_
--
- #ifndef FEATURE_PAL
-
- #ifdef _WIN64
-@@ -434,7 +414,7 @@
- OUT ULONG* pulResult)
- {
- *pulResult = (ULONG)uOperand;
--
-+
- return S_OK;
- }
-
-@@ -552,7 +532,7 @@
- OUT UINT* puResult)
- {
- *puResult = (UINT)ulOperand;
--
-+
- return S_OK;
- }
-
-@@ -673,13 +653,13 @@
- {
- HRESULT hr = INTSAFE_E_ARITHMETIC_OVERFLOW;
- *pulResult = ULONG_ERROR;
--
-+
- if (ullOperand <= ULONG_MAX)
- {
- *pulResult = (ULONG)ullOperand;
- hr = S_OK;
- }
--
-+
- return hr;
- }
-
-@@ -727,13 +707,13 @@
- {
- HRESULT hr = INTSAFE_E_ARITHMETIC_OVERFLOW;
- *puResult = UINT_ERROR;
--
-+
- if (ullOperand <= UINT_MAX)
- {
- *puResult = (UINT)ullOperand;
- hr = S_OK;
- }
--
-+
- return hr;
- }
-
-@@ -1120,7 +1100,7 @@
- *pusResult = (usAugend + usAddend);
- hr = S_OK;
- }
--
-+
- return hr;
- }
-
-@@ -1147,7 +1127,7 @@
- *puResult = (uAugend + uAddend);
- hr = S_OK;
- }
--
-+
- return hr;
- }
-
-@@ -1174,7 +1154,7 @@
- *pulResult = (ulAugend + ulAddend);
- hr = S_OK;
- }
--
-+
- return hr;
- }
-
-@@ -1223,7 +1203,7 @@
- *pResult = (Augend + Addend);
- hr = S_OK;
- }
--
-+
- return hr;
- }
-
-@@ -1250,7 +1230,7 @@
- *pullResult = (ullAugend + ullAddend);
- hr = S_OK;
- }
--
-+
- return hr;
- }
-
-@@ -1272,7 +1252,7 @@
- *pusResult = (usMinuend - usSubtrahend);
- hr = S_OK;
- }
--
-+
- return hr;
- }
-
-@@ -1300,7 +1280,7 @@
- *puResult = (uMinuend - uSubtrahend);
- hr = S_OK;
- }
--
-+
- return hr;
- }
-
-@@ -1327,7 +1307,7 @@
- *pulResult = (ulMinuend - ulSubtrahend);
- hr = S_OK;
- }
--
-+
- return hr;
- }
-
-@@ -1377,7 +1357,7 @@
- *pResult = (Minuend - Subtrahend);
- hr = S_OK;
- }
--
-+
- return hr;
- }
-
-@@ -1404,7 +1384,7 @@
- *pullResult = (ullMinuend - ullSubtrahend);
- hr = S_OK;
- }
--
-+
- return hr;
- }
-
-@@ -1419,7 +1399,7 @@
- OUT USHORT* pusResult)
- {
- ULONG ulResult = ((ULONG)usMultiplicand) * (ULONG)usMultiplier;
--
-+
- return ULongToUShort(ulResult, pusResult);
- }
-
-@@ -1444,23 +1424,6 @@
- }
-
- //
--// UINT_PTR multiplication
--//
--#ifdef _WIN64
--#define UIntPtrMult ULongLongMult
--#else
--__inline
--HRESULT
--UIntPtrMult(
-- IN UINT_PTR ulMultiplicand,
-- IN UINT_PTR ulMultiplier,
-- OUT UINT_PTR* pulResult)
--{
-- return UIntMult((UINT)ulMultiplicand, (UINT)ulMultiplier, (UINT*)pulResult);
--}
--#endif // _WIN64
--
--//
- // ULONG multiplication
- //
- __inline
-@@ -1471,27 +1434,9 @@
- OUT ULONG* pulResult)
- {
- ULONGLONG ull64Result = UInt32x32To64(ulMultiplicand, ulMultiplier);
--
-- return ULongLongToULong(ull64Result, pulResult);
--}
-
--//
--// ULONG_PTR multiplication
--//
--#ifdef _WIN64
--#define ULongPtrMult ULongLongMult
--#else
--__inline
--HRESULT
--ULongPtrMult(
-- IN ULONG_PTR ulMultiplicand,
-- IN ULONG_PTR ulMultiplier,
-- OUT ULONG_PTR* pulResult)
--{
-- return ULongMult((ULONG)ulMultiplicand, (ULONG)ulMultiplier, (ULONG*)pulResult);
-+ return ULongLongToULong(ull64Result, pulResult);
- }
--#endif // _WIN64
--
-
- //
- // DWORD multiplication
-@@ -1503,114 +1448,4 @@
- //
- #define DWordPtrMult ULongPtrMult
-
--//
--// size_t multiplication
--//
--#define SizeTMult UIntPtrMult
--
--//
--// SIZE_T multiplication
--//
--#define SIZETMult ULongPtrMult
--
--//
--// ULONGLONG multiplication
--//
--__inline
--HRESULT
--ULongLongMult(
-- IN ULONGLONG ullMultiplicand,
-- IN ULONGLONG ullMultiplier,
-- OUT ULONGLONG* pullResult)
--{
-- HRESULT hr = INTSAFE_E_ARITHMETIC_OVERFLOW;
--#ifdef _AMD64_
-- ULONGLONG u64ResultHigh;
-- ULONGLONG u64ResultLow;
--
-- *pullResult = ULONGLONG_ERROR;
--
-- u64ResultLow = UnsignedMultiply128(ullMultiplicand, ullMultiplier, &u64ResultHigh);
-- if (u64ResultHigh == 0)
-- {
-- *pullResult = u64ResultLow;
-- hr = S_OK;
-- }
--#else
-- // 64x64 into 128 is like 32.32 x 32.32.
-- //
-- // a.b * c.d = a*(c.d) + .b*(c.d) = a*c + a*.d + .b*c + .b*.d
-- // back in non-decimal notation where A=a*2^32 and C=c*2^32:
-- // A*C + A*d + b*C + b*d
-- // So there are four components to add together.
-- // result = (a*c*2^64) + (a*d*2^32) + (b*c*2^32) + (b*d)
-- //
-- // a * c must be 0 or there would be bits in the high 64-bits
-- // a * d must be less than 2^32 or there would be bits in the high 64-bits
-- // b * c must be less than 2^32 or there would be bits in the high 64-bits
-- // then there must be no overflow of the resulting values summed up.
--
-- ULONG dw_a;
-- ULONG dw_b;
-- ULONG dw_c;
-- ULONG dw_d;
-- ULONGLONG ad = 0;
-- ULONGLONG bc = 0;
-- ULONGLONG bd = 0;
-- ULONGLONG ullResult = 0;
--
-- *pullResult = ULONGLONG_ERROR;
--
-- dw_a = (ULONG)(ullMultiplicand >> 32);
-- dw_c = (ULONG)(ullMultiplier >> 32);
--
-- // common case -- if high dwords are both zero, no chance for overflow
-- if ((dw_a == 0) && (dw_c == 0))
-- {
-- dw_b = (DWORD)ullMultiplicand;
-- dw_d = (DWORD)ullMultiplier;
--
-- *pullResult = (((ULONGLONG)dw_b) * (ULONGLONG)dw_d);
-- hr = S_OK;
-- }
-- else
-- {
-- // a * c must be 0 or there would be bits set in the high 64-bits
-- if ((dw_a == 0) ||
-- (dw_c == 0))
-- {
-- dw_d = (DWORD)ullMultiplier;
--
-- // a * d must be less than 2^32 or there would be bits set in the high 64-bits
-- ad = (((ULONGLONG)dw_a) * (ULONGLONG)dw_d);
-- if ((ad & HIDWORD_MASK) == 0)
-- {
-- dw_b = (DWORD)ullMultiplicand;
--
-- // b * c must be less than 2^32 or there would be bits set in the high 64-bits
-- bc = (((ULONGLONG)dw_b) * (ULONGLONG)dw_c);
-- if ((bc & HIDWORD_MASK) == 0)
-- {
-- // now sum them all up checking for overflow.
-- // shifting is safe because we already checked for overflow above
-- if (SUCCEEDED(ULongLongAdd(bc << 32, ad << 32, &ullResult)))
-- {
-- // b * d
-- bd = (((ULONGLONG)dw_b) * (ULONGLONG)dw_d);
--
-- if (SUCCEEDED(ULongLongAdd(ullResult, bd, &ullResult)))
-- {
-- *pullResult = ullResult;
-- hr = S_OK;
-- }
-- }
-- }
-- }
-- }
-- }
--#endif // _AMD64_
--
-- return hr;
--}
--
- #endif // _INTSAFE_H_INCLUDED_
diff --git a/libcurl.patch b/libcurl.patch
deleted file mode 100644
index fec517978523..000000000000
--- a/libcurl.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-*** src/Native/Unix/System.Net.Http.Native/CMakeLists.txt.orig 2017-05-04 21:14:29.817439384 -0700
---- src/Native/Unix/System.Net.Http.Native/CMakeLists.txt 2017-05-04 21:14:43.417017513 -0700
-***************
-*** 1,9 ****
- project(System.Net.Http.Native)
-
-! find_package(CURL)
-! if(NOT CURL_FOUND)
-! message(FATAL_ERROR "!!! Cannot find libcurl and System.Net.Http.Native cannot build without it. Try installing libcurl4-openssl-dev (or the appropriate package for your platform) !!!")
-! endif(NOT CURL_FOUND)
-
- if(CMAKE_STATIC_LIB_LINK)
- find_library(CURL_STATIC_LIB NAMES libcurl.a)
---- 1,9 ----
- project(System.Net.Http.Native)
-
-! #find_package(CURL)
-! #if(NOT CURL_FOUND)
-! # message(FATAL_ERROR "!!! Cannot find libcurl and System.Net.Http.Native cannot build without it. Try installing libcurl4-openssl-dev (or the appropriate package for your platform) !!!")
-! #endif(NOT CURL_FOUND)
-
- if(CMAKE_STATIC_LIB_LINK)
- find_library(CURL_STATIC_LIB NAMES libcurl.a)
diff --git a/llvm-39-github-pull-8311.patch b/llvm-39-github-pull-8311.patch
deleted file mode 100644
index 21b8374050a3..000000000000
--- a/llvm-39-github-pull-8311.patch
+++ /dev/null
@@ -1,180 +0,0 @@
-From 9f4bf341ad236df7d16bbdba0c4111393ea141d2 Mon Sep 17 00:00:00 2001
-From: Jan Vorlicek <janvorli@microsoft.com>
-Date: Sun, 27 Nov 2016 05:34:03 +0100
-Subject: [PATCH] Fix building CoreCLR with Clang 3.9 (#8311)
-
-There were few constructs that Clang 3.9 didn't like due to its strict
-C++ standard conformance rules.
----
- src/debug/daccess/dacdbiimpl.cpp | 2 +-
- src/debug/di/rsmain.cpp | 2 ++
- src/debug/di/rspriv.h | 2 +-
- src/debug/ee/debugger.cpp | 3 +++
- src/debug/ee/debugger.h | 4 ++--
- src/debug/ildbsymlib/symwrite.h | 3 ++-
- src/debug/inc/dacdbiinterface.h | 2 +-
- src/pal/src/exception/seh.cpp | 2 +-
- tests/src/Common/Platform/platformdefines.cpp | 2 +-
- tests/src/Common/Platform/platformdefines.h | 2 +-
- tests/src/Interop/common/types.h | 4 ++--
- 11 files changed, 17 insertions(+), 11 deletions(-)
-
-diff --git a/src/debug/daccess/dacdbiimpl.cpp b/src/debug/daccess/dacdbiimpl.cpp
-index 26e3d6c..ae266e8 100644
---- a/src/debug/daccess/dacdbiimpl.cpp
-+++ b/src/debug/daccess/dacdbiimpl.cpp
-@@ -90,7 +90,7 @@ IDacDbiInterface::IAllocator * g_pAllocator = NULL;
- //
-
- // Need a class to serve as a tag that we can use to overload New/Delete.
--#define forDbi (*(forDbiWorker *)NULL)
-+forDbiWorker forDbi;
-
- void * operator new(size_t lenBytes, const forDbiWorker &)
- {
-diff --git a/src/debug/di/rsmain.cpp b/src/debug/di/rsmain.cpp
-index b568575..0f57787 100644
---- a/src/debug/di/rsmain.cpp
-+++ b/src/debug/di/rsmain.cpp
-@@ -40,6 +40,8 @@
- RSDebuggingInfo g_RSDebuggingInfo_OutOfProc = {0 }; // set to NULL
- RSDebuggingInfo * g_pRSDebuggingInfo = &g_RSDebuggingInfo_OutOfProc;
-
-+// The following instances are used for invoking overloaded new/delete
-+forDbiWorker forDbi;
-
- #ifdef _DEBUG
- // For logs, we can print the string name for the debug codes.
-diff --git a/src/debug/di/rspriv.h b/src/debug/di/rspriv.h
-index bc0ea59..18920ad 100644
---- a/src/debug/di/rspriv.h
-+++ b/src/debug/di/rspriv.h
-@@ -177,7 +177,7 @@ private:
- USHORT m_usPort;
- };
-
--#define forDbi (*(forDbiWorker *)NULL)
-+extern forDbiWorker forDbi;
-
- // for dbi we just default to new, but we need to have these defined for both dac and dbi
- inline void * operator new(size_t lenBytes, const forDbiWorker &)
-diff --git a/src/debug/ee/debugger.cpp b/src/debug/ee/debugger.cpp
-index a06811c..d67cb41 100644
---- a/src/debug/ee/debugger.cpp
-+++ b/src/debug/ee/debugger.cpp
-@@ -75,6 +75,9 @@ SVAL_IMPL_INIT(BOOL, Debugger, s_fCanChangeNgenFlags, TRUE);
-
- bool g_EnableSIS = false;
-
-+// The following instances are used for invoking overloaded new/delete
-+InteropSafe interopsafe;
-+InteropSafeExecutable interopsafeEXEC;
-
- #ifndef DACCESS_COMPILE
-
-diff --git a/src/debug/ee/debugger.h b/src/debug/ee/debugger.h
-index 6368647..9cdf546 100644
---- a/src/debug/ee/debugger.h
-+++ b/src/debug/ee/debugger.h
-@@ -3512,10 +3512,10 @@ public:
- * ------------------------------------------------------------------------ */
-
- class InteropSafe {};
--#define interopsafe (*(InteropSafe*)NULL)
-+extern InteropSafe interopsafe;
-
- class InteropSafeExecutable {};
--#define interopsafeEXEC (*(InteropSafeExecutable*)NULL)
-+extern InteropSafeExecutable interopsafeEXEC;
-
- #ifndef DACCESS_COMPILE
- inline void * __cdecl operator new(size_t n, const InteropSafe&)
-diff --git a/src/debug/ildbsymlib/symwrite.h b/src/debug/ildbsymlib/symwrite.h
-index 055b8ec..54ab11a 100644
---- a/src/debug/ildbsymlib/symwrite.h
-+++ b/src/debug/ildbsymlib/symwrite.h
-@@ -839,7 +839,8 @@ public:
- {
- // Help mitigate the impact of buffer overflow
- // Fail fast with a null-reference AV
-- return *(static_cast<T*>(0)) ;
-+ volatile char* nullPointer = nullptr;
-+ *nullPointer;
- }
- return m_array[ i ];
- }
-diff --git a/src/debug/inc/dacdbiinterface.h b/src/debug/inc/dacdbiinterface.h
-index e61e240..569ccba 100644
---- a/src/debug/inc/dacdbiinterface.h
-+++ b/src/debug/inc/dacdbiinterface.h
-@@ -32,7 +32,7 @@
- template<class T> void DeleteDbiMemory(T *p);
- // Need a class to serve as a tag that we can use to overload New/Delete.
- class forDbiWorker {};
--#define forDbi (*(forDbiWorker *)NULL)
-+extern forDbiWorker forDbi;
- extern void * operator new(size_t lenBytes, const forDbiWorker &);
- extern void * operator new[](size_t lenBytes, const forDbiWorker &);
- extern void operator delete(void *p, const forDbiWorker &);
-diff --git a/src/pal/src/exception/seh.cpp b/src/pal/src/exception/seh.cpp
-index 473c490..ad09e02 100644
---- a/src/pal/src/exception/seh.cpp
-+++ b/src/pal/src/exception/seh.cpp
-@@ -274,7 +274,7 @@ SEHProcessException(PAL_SEHException* exception)
- {
- // The exception happened in the page right below the stack limit,
- // so it is a stack overflow
-- write(STDERR_FILENO, StackOverflowMessage, sizeof(StackOverflowMessage) - 1);
-+ (void)write(STDERR_FILENO, StackOverflowMessage, sizeof(StackOverflowMessage) - 1);
- PROCAbort();
- }
- }
-diff --git a/tests/src/Common/Platform/platformdefines.cpp b/tests/src/Common/Platform/platformdefines.cpp
-index 4bef170..82061ac 100644
---- a/tests/src/Common/Platform/platformdefines.cpp
-+++ b/tests/src/Common/Platform/platformdefines.cpp
-@@ -277,7 +277,7 @@ DWORD TP_GetFullPathName(LPWSTR fileName, DWORD nBufferLength, LPWSTR lpBuffer)
- return GetFullPathNameW(fileName, nBufferLength, lpBuffer, NULL);
- #else
- char nativeFullPath[MAX_PATH];
-- realpath(HackyConvertToSTR(fileName), nativeFullPath);
-+ (void)realpath(HackyConvertToSTR(fileName), nativeFullPath);
- LPWSTR fullPathForCLR = HackyConvertToWSTR(nativeFullPath);
- wcscpy_s(lpBuffer, MAX_PATH, fullPathForCLR);
- return wcslen(lpBuffer);
-diff --git a/tests/src/Common/Platform/platformdefines.h b/tests/src/Common/Platform/platformdefines.h
-index 49e8f88..c196b0c 100644
---- a/tests/src/Common/Platform/platformdefines.h
-+++ b/tests/src/Common/Platform/platformdefines.h
-@@ -87,7 +87,7 @@ typedef void* HMODULE;
- typedef void* ULONG_PTR;
- typedef unsigned error_t;
- typedef void* LPVOID;
--typedef char BYTE;
-+typedef unsigned char BYTE;
- typedef WCHAR OLECHAR;
- #endif
-
-diff --git a/tests/src/Interop/common/types.h b/tests/src/Interop/common/types.h
-index 7d7f776..cb59c42 100755
---- a/tests/src/Interop/common/types.h
-+++ b/tests/src/Interop/common/types.h
-@@ -28,7 +28,7 @@ typedef void* HMODULE;
- typedef void* ULONG_PTR;
- typedef unsigned error_t;
- typedef void* LPVOID;
--typedef char BYTE;
-+typedef unsigned char BYTE;
- typedef WCHAR OLECHAR;
-
- typedef unsigned int UINT_PTR;
-@@ -54,4 +54,4 @@ typedef int* DWORD_PTR;
- #define FALSE 0
- #endif
-
--#endif //_INTEROP_TYPES__H
-\ No newline at end of file
-+#endif //_INTEROP_TYPES__H
---
-2.10.2
-
diff --git a/llvm-39-move.patch b/llvm-39-move.patch
deleted file mode 100644
index 2c02d41c3f28..000000000000
--- a/llvm-39-move.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 7dfb2ed8614dea8c2fe757592436a38694e91ebc Mon Sep 17 00:00:00 2001
-From: Jan Vorlicek <janvorli@microsoft.com>
-Date: Fri, 28 Oct 2016 04:34:42 +0200
-Subject: [PATCH] Add missing std::move to one exception throw (#7865)
-
-We had the std::move missing in one of the exception throws. For some reason,
-the current clang didn't complain about it even though the copy constructor was
-deleted.
----
- src/vm/exceptionhandling.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/vm/exceptionhandling.cpp b/src/vm/exceptionhandling.cpp
-index e59f10e..ed155eb 100644
---- a/src/vm/exceptionhandling.cpp
-+++ b/src/vm/exceptionhandling.cpp
-@@ -4730,7 +4730,7 @@ VOID DECLSPEC_NORETURN DispatchManagedException(PAL_SEHException& ex, bool isHar
- }
- }
-
-- throw ex;
-+ throw std::move(ex);
- }
-
- #ifdef _AMD64_
---
-2.10.2
-
diff --git a/lttng-uts-40.patch b/lttng-uts-40.patch
deleted file mode 100644
index 6534d0d5339e..000000000000
--- a/lttng-uts-40.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -Naur src/pal/src/configure.cmake-orig src/pal/src/configure.cmake
---- src/pal/src/configure.cmake-orig 2016-12-27 09:27:00.480715728 -0500
-+++ src/pal/src/configure.cmake 2016-12-27 09:26:28.707299084 -0500
-@@ -13,7 +13,7 @@
- set(CMAKE_REQUIRED_INCLUDES /opt/local/include)
- endif()
- if(NOT CMAKE_SYSTEM_NAME STREQUAL Darwin AND NOT CMAKE_SYSTEM_NAME STREQUAL FreeBSD AND NOT CMAKE_SYSTEM_NAME STREQUAL NetBSD)
-- set(CMAKE_REQUIRED_DEFINITIONS "-D_DEFAULT_SOURCE -D_POSIX_C_SOURCE=200809L")
-+ set(CMAKE_REQUIRED_DEFINITIONS "-D_BSD_SOURCE -D_SVID_SOURCE -D_DEFAULT_SOURCE -D_POSIX_C_SOURCE=200809L")
- endif()
-
- list(APPEND CMAKE_REQUIRED_DEFINITIONS -D_FILE_OFFSET_BITS=64)
-@@ -33,7 +33,15 @@
- check_include_files(lwp.h HAVE_LWP_H)
- check_include_files(libunwind.h HAVE_LIBUNWIND_H)
- check_include_files(runetype.h HAVE_RUNETYPE_H)
-+
-+if(NOT CMAKE_SYSTEM_NAME STREQUAL FreeBSD AND NOT CMAKE_SYSTEM_NAME STREQUAL NetBSD)
-+ set(CMAKE_REQUIRED_FLAGS "-ldl")
-+endif()
- check_include_files(lttng/tracepoint.h HAVE_LTTNG_TRACEPOINT_H)
-+if(NOT CMAKE_SYSTEM_NAME STREQUAL FreeBSD AND NOT CMAKE_SYSTEM_NAME STREQUAL NetBSD)
-+ unset(CMAKE_REQUIRED_FLAGS)
-+endif()
-+
- check_include_files(uuid/uuid.h HAVE_LIBUUID_H)
- check_include_files(sys/sysctl.h HAVE_SYS_SYSCTL_H)
- check_include_files(gnu/lib-names.h HAVE_GNU_LIBNAMES_H)
-@@ -62,7 +70,6 @@
- check_function_exists(localtime_r HAVE_LOCALTIME_R)
- check_function_exists(gmtime_r HAVE_GMTIME_R)
- check_function_exists(timegm HAVE_TIMEGM)
--check_function_exists(_snwprintf HAVE__SNWPRINTF)
- check_function_exists(poll HAVE_POLL)
- check_function_exists(statvfs HAVE_STATVFS)
- check_function_exists(thread_self HAVE_THREAD_SELF) \ No newline at end of file