summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYurii Kolesnykov2017-02-15 17:59:58 +0300
committerYurii Kolesnykov2017-02-15 17:59:58 +0300
commit16fb6a52a721b32706fdb9ed5bb76705f8220999 (patch)
tree4b3ba78f06a14dd57fb37fee595636c569a35e1d
parent690b8d46d68498ef125ef47417ea486692af75ed (diff)
downloadaur-16fb6a52a721b32706fdb9ed5bb76705f8220999.tar.gz
fix permissions
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5eb4c42b686d..9af156accbea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dotnet-cli
pkgdesc = A command line utility for building, testing, packaging and running .NET Core applications and libraries
pkgver = 1.0.0_rc4_004771
- pkgrel = 1
+ pkgrel = 2
url = https://www.microsoft.com/net/core
arch = x86_64
license = MIT
@@ -17,6 +17,7 @@ pkgbase = dotnet-cli
depends = openssl
depends = curl
provides = dotnet
+ conflicts = dotnet-bin
noextract = dotnet-cli-1.0.0_rc4_004771.tar.gz
options = staticlibs
source = coreclr-1.1.0.tar.gz::https://github.com/dotnet/coreclr/archive/v1.1.0.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 4e819c7253f1..fbf8c5714cf5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=dotnet-cli
pkgver="1.0.0_rc4_004771"
-pkgrel=1
+pkgrel=2
pkgdesc="A command line utility for building, testing, packaging and running .NET Core applications and libraries"
arch=(x86_64)
url="https://www.microsoft.com/net/core"
@@ -90,6 +90,10 @@ package() {
mkdir -p "${pkgdir}/usr/bin/"
ln -s "/opt/dotnet/dotnet" "${pkgdir}/usr/bin/dotnet"
chown -R 0:0 "${_outdir}"
+ find "${_outdir}" -name *.dll -exec chmod 644 {} \;
+ find "${_outdir}" -name *.exe -exec chmod 755 {} \;
+
+
}
# vim:set ts=2 sw=2 et: