summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Brodersen2016-07-13 12:56:04 -0500
committerAaron Brodersen2016-07-13 12:56:04 -0500
commit5898269e955afbd506c7c115931f4c55d83e4509 (patch)
treef82da46d8df8b1892d7a8a5c09e84301e4b007b8
parentcd9c391bb5992cdaeafdbebda9e58fc92fd1c471 (diff)
downloadaur-5898269e955afbd506c7c115931f4c55d83e4509.tar.gz
add patches to fix unused value warnings
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD23
-rw-r--r--unused-attr-coreclr.patch40
-rw-r--r--unused-attr-corefx.patch26
4 files changed, 86 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b08b13cca23e..953b3bd2f03b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dotnet-cli
pkgdesc = A command line utility for building, testing, packaging and running .NET Core applications and libraries
pkgver = 1.0.0_preview2_003121
- pkgrel = 1
+ pkgrel = 2
url = https://www.microsoft.com/net/core
arch = x86_64
license = MIT
@@ -24,11 +24,15 @@ pkgbase = dotnet-cli
source = dotnet-cli-1.0.0_preview2_003121.tar.gz::https://go.microsoft.com/fwlink/?LinkID=816869
source = gcc6-github-pull-5304.patch
source = segv-github-pull-6027.patch
+ source = unused-attr-coreclr.patch
+ source = unused-attr-corefx.patch
sha256sums = fad7bb05f78d90dfea6e8fec59f79ff12648fe95c0965cda5bc11beafabd0f27
sha256sums = 98f9475ea42e5d55ad9402424e342a6c0ea7351f3fb5805a602132969b44b774
sha256sums = dde9f8326583f351a89e57095dc523ba92560896cd1d4b8e0ca5ac7fd8499138
sha256sums = 0905f9f8e6e33a7a6e5f4acf9ec54ec3796400dce28f0d71c1d1d8bcd9b7e068
sha256sums = a039329f892c55a400537ea4da61de86af195d143d758b6019fbae76f17ef6f1
+ sha256sums = 8a33c449312f90660d431177f7ee0a36894b75749f79ecf8995c64d82197af90
+ sha256sums = 9ecdd0ca615b988b67cc4c6a9f5035fb3fb70b16d9281d07c17a28a784a6d4ab
pkgname = dotnet-cli
diff --git a/PKGBUILD b/PKGBUILD
index ddc1d9b35362..b771d1d18ef6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Aaron Brodersen <aaron at abrodersen dot com>
pkgname=dotnet-cli
pkgver="1.0.0_preview2_003121"
-pkgrel=1
+pkgrel=2
pkgdesc="A command line utility for building, testing, packaging and running .NET Core applications and libraries"
arch=(x86_64)
url="https://www.microsoft.com/net/core"
@@ -27,19 +27,26 @@ source=(
"${_corefx}.tar.gz::https://github.com/dotnet/corefx/archive/v${_corefxver}.tar.gz"
"${pkgname}-${pkgver}.tar.gz::https://go.microsoft.com/fwlink/?LinkID=816869"
'gcc6-github-pull-5304.patch'
- 'segv-github-pull-6027.patch')
+ 'segv-github-pull-6027.patch'
+ 'unused-attr-coreclr.patch'
+ 'unused-attr-corefx.patch')
noextract=("${pkgname}-${pkgver}.tar.gz")
-sha256sums=(
- 'fad7bb05f78d90dfea6e8fec59f79ff12648fe95c0965cda5bc11beafabd0f27'
- '98f9475ea42e5d55ad9402424e342a6c0ea7351f3fb5805a602132969b44b774'
- 'dde9f8326583f351a89e57095dc523ba92560896cd1d4b8e0ca5ac7fd8499138'
- '0905f9f8e6e33a7a6e5f4acf9ec54ec3796400dce28f0d71c1d1d8bcd9b7e068'
- 'a039329f892c55a400537ea4da61de86af195d143d758b6019fbae76f17ef6f1')
+sha256sums=('fad7bb05f78d90dfea6e8fec59f79ff12648fe95c0965cda5bc11beafabd0f27'
+ '98f9475ea42e5d55ad9402424e342a6c0ea7351f3fb5805a602132969b44b774'
+ 'dde9f8326583f351a89e57095dc523ba92560896cd1d4b8e0ca5ac7fd8499138'
+ '0905f9f8e6e33a7a6e5f4acf9ec54ec3796400dce28f0d71c1d1d8bcd9b7e068'
+ 'a039329f892c55a400537ea4da61de86af195d143d758b6019fbae76f17ef6f1'
+ '8a33c449312f90660d431177f7ee0a36894b75749f79ecf8995c64d82197af90'
+ '9ecdd0ca615b988b67cc4c6a9f5035fb3fb70b16d9281d07c17a28a784a6d4ab')
prepare() {
cd "${srcdir}/${_coreclr}"
patch -p1 < "${srcdir}/gcc6-github-pull-5304.patch"
patch -p1 < "${srcdir}/segv-github-pull-6027.patch"
+ patch -p1 < "${srcdir}/unused-attr-coreclr.patch"
+
+ cd "${srcdir}/${_corefx}"
+ patch -p1 < "${srcdir}/unused-attr-corefx.patch"
}
build() {
diff --git a/unused-attr-coreclr.patch b/unused-attr-coreclr.patch
new file mode 100644
index 000000000000..d8d23e247784
--- /dev/null
+++ b/unused-attr-coreclr.patch
@@ -0,0 +1,40 @@
+From e2590a57e8fd557aec5b8a64bcca9308a950414b Mon Sep 17 00:00:00 2001
+From: Aaron Brodersen <aaron@abrodersen.com>
+Date: Wed, 13 Jul 2016 12:12:50 -0500
+Subject: [PATCH] Ignore unused return values
+
+Credit to Hazerd and leafi for identifying the issue and resolution.
+---
+ src/pal/src/exception/seh.cpp | 2 +-
+ tests/src/Common/Platform/platformdefines.cpp | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/pal/src/exception/seh.cpp b/src/pal/src/exception/seh.cpp
+index 01de6e8..a89f800 100644
+--- a/src/pal/src/exception/seh.cpp
++++ b/src/pal/src/exception/seh.cpp
+@@ -233,7 +233,7 @@ SEHProcessException(PEXCEPTION_POINTERS pointers)
+ {
+ // The exception happened in the page right below the stack limit,
+ // so it is a stack overflow
+- write(STDERR_FILENO, StackOverflowMessage, sizeof(StackOverflowMessage) - 1);
++ (void)write(STDERR_FILENO, StackOverflowMessage, sizeof(StackOverflowMessage) - 1);
+ PROCAbort();
+ }
+ }
+diff --git a/tests/src/Common/Platform/platformdefines.cpp b/tests/src/Common/Platform/platformdefines.cpp
+index 4caead5..3a2cae2 100644
+--- a/tests/src/Common/Platform/platformdefines.cpp
++++ b/tests/src/Common/Platform/platformdefines.cpp
+@@ -277,7 +277,7 @@ DWORD TP_GetFullPathName(LPWSTR fileName, DWORD nBufferLength, LPWSTR lpBuffer)
+ return GetFullPathNameW(fileName, nBufferLength, lpBuffer, NULL);
+ #else
+ char nativeFullPath[MAX_PATH];
+- realpath(HackyConvertToSTR(fileName), nativeFullPath);
++ (void)realpath(HackyConvertToSTR(fileName), nativeFullPath);
+ LPWSTR fullPathForCLR = HackyConvertToWSTR(nativeFullPath);
+ wcscpy_s(lpBuffer, MAX_PATH, fullPathForCLR);
+ return wcslen(lpBuffer);
+--
+2.9.0
+
diff --git a/unused-attr-corefx.patch b/unused-attr-corefx.patch
new file mode 100644
index 000000000000..75ba7c70c2fd
--- /dev/null
+++ b/unused-attr-corefx.patch
@@ -0,0 +1,26 @@
+From 39334d46be9c3184fef8f762135e65216cc4ee84 Mon Sep 17 00:00:00 2001
+From: Aaron Brodersen <aaron@abrodersen.com>
+Date: Wed, 13 Jul 2016 11:23:10 -0500
+Subject: [PATCH] Ignore unused return values
+
+Credit to Hazerd and leafi for identifying the issue and resolution.
+---
+ src/Native/System.Native/pal_process.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Native/System.Native/pal_process.cpp b/src/Native/System.Native/pal_process.cpp
+index 74c4335..e64205d 100644
+--- a/src/Native/System.Native/pal_process.cpp
++++ b/src/Native/System.Native/pal_process.cpp
+@@ -142,7 +142,7 @@ extern "C" int32_t SystemNative_ForkAndExecProcess(const char* filename,
+ // where the parent process uses members of Process, like ProcessName, when the Process
+ // is still the clone of this one. This is a best-effort attempt, so ignore any errors.
+ #if HAVE_PIPE2
+- pipe2(waitForChildToExecPipe, O_CLOEXEC);
++ (void)pipe2(waitForChildToExecPipe, O_CLOEXEC);
+ #endif
+
+ // Fork the child process
+--
+2.9.0
+