summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Kalinin2017-05-25 15:50:42 +0000
committerDmitry Kalinin2017-05-25 15:50:42 +0000
commitfd5348ef5f2b5145b74f948e4e5f4058608e2315 (patch)
tree423b3dd3bac7b8b468f73a67d0c805e324e21cb4
parent45afc553e73df0a61ca1dd11f0225862f2b66993 (diff)
downloadaur-fd5348ef5f2b5145b74f948e4e5f4058608e2315.tar.gz
1) Package version updated.
2) Reference to OpenSSL 1.0.0 added.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD112
-rw-r--r--libcurl_openssl-1_0.patch18
-rw-r--r--llvm-39-github-pull-8311.patch180
-rw-r--r--llvm-39-move.patch28
5 files changed, 104 insertions, 252 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 347502930239..7c1a6191dc91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dotnet-cli-git
pkgdesc = The .NET Core command-line (CLI) tools, used for building .NET Core apps and libraries through your development flow (compiling, NuGet package management, running, testing, ...)
- pkgver = 2.0.0_alpha_005165
+ pkgver = 2.0.0_preview2_006127
pkgrel = 1
url = https://github.com/dotnet/cli
arch = x86_64
@@ -17,18 +17,14 @@ pkgbase = dotnet-cli-git
depends = openssl
depends = curl
provides = dotnet
- noextract = dotnet-cli-git-2.0.0_alpha_005165.tar.gz
+ noextract = dotnet-cli-git-2.0.0_preview2_006127.tar.gz
options = staticlibs
- source = coreclr-1.1.0.tar.gz::https://github.com/dotnet/coreclr/archive/v1.1.0.tar.gz
- source = corefx-1.1.0.tar.gz::https://github.com/dotnet/corefx/archive/v1.1.0.tar.gz
- source = dotnet-cli-git-2.0.0_alpha_005165.tar.gz::https://dotnetcli.blob.core.windows.net/dotnet/Sdk/master/dotnet-dev-debian-x64.latest.tar.gz
- source = llvm-39-github-pull-8311.patch
- source = llvm-39-move.patch
- sha256sums = edc1e416f07a71e2b3f70c1f1412e45a7396b3f0daac5bcb267d5f779b9d7444
- sha256sums = ca48ad090c72129ef145ef9b414767408a8fc1249e94a14dc6d4255b1e0b8648
+ source = corefx-latest.zip::https://github.com/dotnet/corefx/archive/master.zip
+ source = dotnet-cli-git-2.0.0_preview2_006127.tar.gz::https://dotnetcli.blob.core.windows.net/dotnet/Sdk/master/dotnet-dev-linux-x64.latest.tar.gz
+ source = libcurl_openssl-1_0.patch
sha256sums = SKIP
- sha256sums = 581d6484626bbae820feb19d0613955fea333c025fb06d43a731a3db776686f7
- sha256sums = 84a0e56d00fd2f3f9f82b7d017652f03d4e7f80c6968d7fa1274f6e46af0ff3d
+ sha256sums = SKIP
+ sha256sums = 90bc8e1cc9c89fc94ec6a0264200e297e00371136f3b574eccfc077d40d3746d
pkgname = dotnet-cli-git
diff --git a/PKGBUILD b/PKGBUILD
index 29815fb10216..80638f4d1971 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Dmitry Kalinin <lwinch2006.rss@protonmail.ch>
pkgname=dotnet-cli-git
-pkgver=2.0.0_alpha_005165
+pkgver=2.0.0_preview2_006127
pkgrel=1
pkgdesc="The .NET Core command-line (CLI) tools, used for building .NET Core apps and libraries through your development flow (compiling, NuGet package management, running, testing, ...)"
arch=(x86_64)
@@ -18,21 +18,26 @@ install=
_coreclrname="coreclr"
_corefxname="corefx"
-_coreclrver="1.1.0"
-_corefxver="1.1.0"
+_coreclrOriginalVersion="latest"
+_corefxOriginalVersion="latest"
+_coreclrChangedVersion="${_coreclrOriginalVersion//-/_}"
+_corefxChangedVersion="${_corefxOriginalVersion//-/_}"
source=(
- "${_coreclrname}-${_coreclrver}.tar.gz::https://github.com/dotnet/coreclr/archive/v1.1.0.tar.gz"
- "${_corefxname}-${_corefxver}.tar.gz::https://github.com/dotnet/corefx/archive/v1.1.0.tar.gz"
- "${pkgname}-${pkgver}.tar.gz::https://dotnetcli.blob.core.windows.net/dotnet/Sdk/master/dotnet-dev-debian-x64.latest.tar.gz"
- 'llvm-39-github-pull-8311.patch'
- 'llvm-39-move.patch')
+ #"${_coreclrname}-${_coreclrChangedVersion}.zip::https://github.com/dotnet/coreclr/archive/master.zip"
+ "${_corefxname}-${_corefxChangedVersion}.zip::https://github.com/dotnet/corefx/archive/master.zip"
+ "${pkgname}-${pkgver}.tar.gz::https://dotnetcli.blob.core.windows.net/dotnet/Sdk/master/dotnet-dev-linux-x64.latest.tar.gz"
+ "libcurl_openssl-1_0.patch"
+)
+
noextract=("${pkgname}-${pkgver}.tar.gz")
-sha256sums=('edc1e416f07a71e2b3f70c1f1412e45a7396b3f0daac5bcb267d5f779b9d7444'
- 'ca48ad090c72129ef145ef9b414767408a8fc1249e94a14dc6d4255b1e0b8648'
- 'SKIP'
- '581d6484626bbae820feb19d0613955fea333c025fb06d43a731a3db776686f7'
- '84a0e56d00fd2f3f9f82b7d017652f03d4e7f80c6968d7fa1274f6e46af0ff3d')
+
+sha256sums=(
+ #'SKIP'
+ 'SKIP'
+ 'SKIP'
+ '90bc8e1cc9c89fc94ec6a0264200e297e00371136f3b574eccfc077d40d3746d'
+)
pkgver() {
local _versionDetailsAsString=$(curl https://dotnetcli.blob.core.windows.net/dotnet/Sdk/master/latest.version);
@@ -41,8 +46,7 @@ pkgver() {
_version="${_version//[$'\t\r\n']}";
_version="${_version//-/_}";
- if [ "${_version}" != "${pkgver}" ]
- then
+ if [ "${_version}" != "${pkgver}" ]; then
mv "${srcdir}/${pkgname}-${pkgver}.tar.gz" "${srcdir}/${pkgname}-${_version}.tar.gz"
fi
@@ -50,17 +54,36 @@ pkgver() {
}
prepare() {
- cd "${srcdir}/${_coreclrname}-${_coreclrver}"
- patch -p1 < "${srcdir}/llvm-39-github-pull-8311.patch"
- patch -p1 < "${srcdir}/llvm-39-move.patch"
+ local _extractedCoreclrFolder="$(ls -d ${srcdir}/*/ | grep coreclr | head -n 1 | tail -n 1)"
+ local _extractedCorefxFolder="$(ls -d ${srcdir}/*/ | grep corefx | head -n 1 | tail -n 1)"
+
+ if [ -n "${_extractedCoreclrFolder}" ]; then
+ cd "${_extractedCoreclrFolder}"
+ #patch -p1 < "${srcdir}/enable-build-with-clang-4.patch"
+ fi
+
+ if [ -n "${_extractedCorefxFolder}" ]; then
+ cd "${_extractedCorefxFolder}"
+ patch -p1 < "${srcdir}/libcurl_openssl-1_0.patch"
+ fi
}
build() {
- cd "${srcdir}/${_coreclrname}-${_coreclrver}"
- ./build.sh x64 release
+ local _extractedCoreclrFolder="$(ls -d ${srcdir}/*/ | grep coreclr | head -n 1 | tail -n 1)"
+ local _extractedCorefxFolder="$(ls -d ${srcdir}/*/ | grep corefx | head -n 1 | tail -n 1)"
+
+ if [ -n "${_extractedCoreclrFolder}" ]; then
+ cd "${_extractedCoreclrFolder}"
+ ./build.sh x64 release
+ fi
+
+ if [ -n "${_extractedCorefxFolder}" ]; then
+ cd "${_extractedCorefxFolder}"
+ #./src/Native/build-native.sh x64 release
+ CPLUS_INCLUDE_PATH=/usr/include/openssl-1.0 C_INCLUDE_PATH=/usr/include/openssl-1.0 ./src/Native/build-native.sh x64 release cmakeargs -DOPENSSL_INCLUDE_DIR=/usr/include/openssl-1.0 cmakeargs -DOPENSSL_SSL_LIBRARY=/usr/lib/openssl-1.0/libssl.so cmakeargs -DOPENSSL_CRYPTO_LIBRARY=/usr/lib/openssl-1.0/libcrypto.so cmakeargs -DCURL_LIBRARIES=/usr/lib/openssl-1.0/libcurl.so
- cd "${srcdir}/${_corefxname}-${_corefxver}"
- ./src/Native/build-native.sh x64 release
+ #./src/Native/build-native.sh x64 release cmakeargs -DCURL_LIBRARIES=/usr/lib/openssl-1.0/libcurl.so
+ fi
}
_coreclr_files=(
@@ -68,16 +91,35 @@ _coreclr_files=(
)
_corefx_files=(
- 'System.Security.Cryptography.Native.OpenSsl.so'
+ 'System.IO.Compression.Native.so'
+ 'System.Native.a'
+ 'System.Native.so'
'System.Net.Http.Native.so'
+ 'System.Net.Security.Native.so'
+ 'System.Security.Cryptography.Native.OpenSsl.so'
)
_copy_file() {
local _netcoreappverdir1="$(ls -d $2/shared/Microsoft.NETCore.App/*/ | head -n 1 | tail -n 1)";
local _netcoreappverdir2="$(ls -d $2/shared/Microsoft.NETCore.App/*/ | head -n 2 | tail -n 1)";
+ local _netcoreappverdir3="$(ls -d $2/shared/Microsoft.NETCore.App/*/ | head -n 3 | tail -n 1)";
+ local _netcoreappverdir4="$(ls -d $2/shared/Microsoft.NETCore.App/*/ | head -n 4 | tail -n 1)";
+
+ if [ -n "${_netcoreappverdir1}" ]; then
+ cp --force --preserve=mode $1 "${_netcoreappverdir1}"
+ fi
+
+ if [ -n "${_netcoreappverdir2}" ]; then
+ cp --force --preserve=mode $1 "${_netcoreappverdir2}"
+ fi
- cp --force --preserve=mode $1 "${_netcoreappverdir1}"
- cp --force --preserve=mode $1 "${_netcoreappverdir2}"
+ if [ -n "${_netcoreappverdir3}" ]; then
+ cp --force --preserve=mode $1 "${_netcoreappverdir3}"
+ fi
+
+ if [ -n "${_netcoreappverdir4}" ]; then
+ cp --force --preserve=mode $1 "${_netcoreappverdir4}"
+ fi
}
package() {
@@ -86,17 +128,21 @@ package() {
tar -C "${_outdir}" -xzf "${srcdir}/${pkgname}-${pkgver}.tar.gz"
- local _clrdir="${srcdir}/${_coreclrname}-${_coreclrver}"
+ local _extractedCoreclrFolder="$(ls -d ${srcdir}/*/ | grep coreclr | head -n 1 | tail -n 1)"
- for file in "${_coreclr_files[@]}"; do
- _copy_file "${_clrdir}/bin/Product/Linux.x64.Release/${file}" "${_outdir}"
- done
+ if [ -n "${_extractedCoreclrFolder}" ]; then
+ for file in "${_coreclr_files[@]}"; do
+ _copy_file "${_extractedCoreclrFolder}bin/Product/Linux.x64.Release/${file}" "${_outdir}"
+ done
+ fi
- local _fxdir="${srcdir}/${_corefxname}-${_corefxver}"
+ local _extractedCorefxFolder="$(ls -d ${srcdir}/*/ | grep corefx | head -n 1 | tail -n 1)"
- for file in "${_corefx_files[@]}"; do
- _copy_file "${_fxdir}/bin/Linux.x64.Release/Native/${file}" "${_outdir}"
- done
+ if [ -n "${_extractedCorefxFolder}" ]; then
+ for file in "${_corefx_files[@]}"; do
+ _copy_file "${_extractedCorefxFolder}bin/Linux.x64.Release/native/${file}" "${_outdir}"
+ done
+ fi
mkdir -p "${pkgdir}/usr/bin/"
ln -s "/opt/dotnet/dotnet" "${pkgdir}/usr/bin/dotnet"
diff --git a/libcurl_openssl-1_0.patch b/libcurl_openssl-1_0.patch
new file mode 100644
index 000000000000..caa374d26308
--- /dev/null
+++ b/libcurl_openssl-1_0.patch
@@ -0,0 +1,18 @@
+diff --git a/src/Native/Unix/System.Net.Http.Native/CMakeLists.txt b/src/Native/Unix/System.Net.Http.Native/CMakeLists.txt
+index 515bdb6..c8d3426 100644
+--- a/src/Native/Unix/System.Net.Http.Native/CMakeLists.txt
++++ b/src/Native/Unix/System.Net.Http.Native/CMakeLists.txt
+@@ -1,9 +1,9 @@
+ project(System.Net.Http.Native)
+
+-find_package(CURL)
+-if(NOT CURL_FOUND)
+- message(FATAL_ERROR "!!! Cannot find libcurl and System.Net.Http.Native cannot build without it. Try installing libcurl4-openssl-dev (or the appropriate package for your platform) !!!")
+-endif(NOT CURL_FOUND)
++#find_package(CURL)
++#if(NOT CURL_FOUND)
++# message(FATAL_ERROR "!!! Cannot find libcurl and System.Net.Http.Native cannot build without it. Try installing libcurl4-openssl-dev (or the appropriate package for your platform) !!!")
++#endif(NOT CURL_FOUND)
+
+ if(CMAKE_STATIC_LIB_LINK)
+ find_library(CURL_STATIC_LIB NAMES libcurl.a) \ No newline at end of file
diff --git a/llvm-39-github-pull-8311.patch b/llvm-39-github-pull-8311.patch
deleted file mode 100644
index 21b8374050a3..000000000000
--- a/llvm-39-github-pull-8311.patch
+++ /dev/null
@@ -1,180 +0,0 @@
-From 9f4bf341ad236df7d16bbdba0c4111393ea141d2 Mon Sep 17 00:00:00 2001
-From: Jan Vorlicek <janvorli@microsoft.com>
-Date: Sun, 27 Nov 2016 05:34:03 +0100
-Subject: [PATCH] Fix building CoreCLR with Clang 3.9 (#8311)
-
-There were few constructs that Clang 3.9 didn't like due to its strict
-C++ standard conformance rules.
----
- src/debug/daccess/dacdbiimpl.cpp | 2 +-
- src/debug/di/rsmain.cpp | 2 ++
- src/debug/di/rspriv.h | 2 +-
- src/debug/ee/debugger.cpp | 3 +++
- src/debug/ee/debugger.h | 4 ++--
- src/debug/ildbsymlib/symwrite.h | 3 ++-
- src/debug/inc/dacdbiinterface.h | 2 +-
- src/pal/src/exception/seh.cpp | 2 +-
- tests/src/Common/Platform/platformdefines.cpp | 2 +-
- tests/src/Common/Platform/platformdefines.h | 2 +-
- tests/src/Interop/common/types.h | 4 ++--
- 11 files changed, 17 insertions(+), 11 deletions(-)
-
-diff --git a/src/debug/daccess/dacdbiimpl.cpp b/src/debug/daccess/dacdbiimpl.cpp
-index 26e3d6c..ae266e8 100644
---- a/src/debug/daccess/dacdbiimpl.cpp
-+++ b/src/debug/daccess/dacdbiimpl.cpp
-@@ -90,7 +90,7 @@ IDacDbiInterface::IAllocator * g_pAllocator = NULL;
- //
-
- // Need a class to serve as a tag that we can use to overload New/Delete.
--#define forDbi (*(forDbiWorker *)NULL)
-+forDbiWorker forDbi;
-
- void * operator new(size_t lenBytes, const forDbiWorker &)
- {
-diff --git a/src/debug/di/rsmain.cpp b/src/debug/di/rsmain.cpp
-index b568575..0f57787 100644
---- a/src/debug/di/rsmain.cpp
-+++ b/src/debug/di/rsmain.cpp
-@@ -40,6 +40,8 @@
- RSDebuggingInfo g_RSDebuggingInfo_OutOfProc = {0 }; // set to NULL
- RSDebuggingInfo * g_pRSDebuggingInfo = &g_RSDebuggingInfo_OutOfProc;
-
-+// The following instances are used for invoking overloaded new/delete
-+forDbiWorker forDbi;
-
- #ifdef _DEBUG
- // For logs, we can print the string name for the debug codes.
-diff --git a/src/debug/di/rspriv.h b/src/debug/di/rspriv.h
-index bc0ea59..18920ad 100644
---- a/src/debug/di/rspriv.h
-+++ b/src/debug/di/rspriv.h
-@@ -177,7 +177,7 @@ private:
- USHORT m_usPort;
- };
-
--#define forDbi (*(forDbiWorker *)NULL)
-+extern forDbiWorker forDbi;
-
- // for dbi we just default to new, but we need to have these defined for both dac and dbi
- inline void * operator new(size_t lenBytes, const forDbiWorker &)
-diff --git a/src/debug/ee/debugger.cpp b/src/debug/ee/debugger.cpp
-index a06811c..d67cb41 100644
---- a/src/debug/ee/debugger.cpp
-+++ b/src/debug/ee/debugger.cpp
-@@ -75,6 +75,9 @@ SVAL_IMPL_INIT(BOOL, Debugger, s_fCanChangeNgenFlags, TRUE);
-
- bool g_EnableSIS = false;
-
-+// The following instances are used for invoking overloaded new/delete
-+InteropSafe interopsafe;
-+InteropSafeExecutable interopsafeEXEC;
-
- #ifndef DACCESS_COMPILE
-
-diff --git a/src/debug/ee/debugger.h b/src/debug/ee/debugger.h
-index 6368647..9cdf546 100644
---- a/src/debug/ee/debugger.h
-+++ b/src/debug/ee/debugger.h
-@@ -3512,10 +3512,10 @@ public:
- * ------------------------------------------------------------------------ */
-
- class InteropSafe {};
--#define interopsafe (*(InteropSafe*)NULL)
-+extern InteropSafe interopsafe;
-
- class InteropSafeExecutable {};
--#define interopsafeEXEC (*(InteropSafeExecutable*)NULL)
-+extern InteropSafeExecutable interopsafeEXEC;
-
- #ifndef DACCESS_COMPILE
- inline void * __cdecl operator new(size_t n, const InteropSafe&)
-diff --git a/src/debug/ildbsymlib/symwrite.h b/src/debug/ildbsymlib/symwrite.h
-index 055b8ec..54ab11a 100644
---- a/src/debug/ildbsymlib/symwrite.h
-+++ b/src/debug/ildbsymlib/symwrite.h
-@@ -839,7 +839,8 @@ public:
- {
- // Help mitigate the impact of buffer overflow
- // Fail fast with a null-reference AV
-- return *(static_cast<T*>(0)) ;
-+ volatile char* nullPointer = nullptr;
-+ *nullPointer;
- }
- return m_array[ i ];
- }
-diff --git a/src/debug/inc/dacdbiinterface.h b/src/debug/inc/dacdbiinterface.h
-index e61e240..569ccba 100644
---- a/src/debug/inc/dacdbiinterface.h
-+++ b/src/debug/inc/dacdbiinterface.h
-@@ -32,7 +32,7 @@
- template<class T> void DeleteDbiMemory(T *p);
- // Need a class to serve as a tag that we can use to overload New/Delete.
- class forDbiWorker {};
--#define forDbi (*(forDbiWorker *)NULL)
-+extern forDbiWorker forDbi;
- extern void * operator new(size_t lenBytes, const forDbiWorker &);
- extern void * operator new[](size_t lenBytes, const forDbiWorker &);
- extern void operator delete(void *p, const forDbiWorker &);
-diff --git a/src/pal/src/exception/seh.cpp b/src/pal/src/exception/seh.cpp
-index 473c490..ad09e02 100644
---- a/src/pal/src/exception/seh.cpp
-+++ b/src/pal/src/exception/seh.cpp
-@@ -274,7 +274,7 @@ SEHProcessException(PAL_SEHException* exception)
- {
- // The exception happened in the page right below the stack limit,
- // so it is a stack overflow
-- write(STDERR_FILENO, StackOverflowMessage, sizeof(StackOverflowMessage) - 1);
-+ (void)write(STDERR_FILENO, StackOverflowMessage, sizeof(StackOverflowMessage) - 1);
- PROCAbort();
- }
- }
-diff --git a/tests/src/Common/Platform/platformdefines.cpp b/tests/src/Common/Platform/platformdefines.cpp
-index 4bef170..82061ac 100644
---- a/tests/src/Common/Platform/platformdefines.cpp
-+++ b/tests/src/Common/Platform/platformdefines.cpp
-@@ -277,7 +277,7 @@ DWORD TP_GetFullPathName(LPWSTR fileName, DWORD nBufferLength, LPWSTR lpBuffer)
- return GetFullPathNameW(fileName, nBufferLength, lpBuffer, NULL);
- #else
- char nativeFullPath[MAX_PATH];
-- realpath(HackyConvertToSTR(fileName), nativeFullPath);
-+ (void)realpath(HackyConvertToSTR(fileName), nativeFullPath);
- LPWSTR fullPathForCLR = HackyConvertToWSTR(nativeFullPath);
- wcscpy_s(lpBuffer, MAX_PATH, fullPathForCLR);
- return wcslen(lpBuffer);
-diff --git a/tests/src/Common/Platform/platformdefines.h b/tests/src/Common/Platform/platformdefines.h
-index 49e8f88..c196b0c 100644
---- a/tests/src/Common/Platform/platformdefines.h
-+++ b/tests/src/Common/Platform/platformdefines.h
-@@ -87,7 +87,7 @@ typedef void* HMODULE;
- typedef void* ULONG_PTR;
- typedef unsigned error_t;
- typedef void* LPVOID;
--typedef char BYTE;
-+typedef unsigned char BYTE;
- typedef WCHAR OLECHAR;
- #endif
-
-diff --git a/tests/src/Interop/common/types.h b/tests/src/Interop/common/types.h
-index 7d7f776..cb59c42 100755
---- a/tests/src/Interop/common/types.h
-+++ b/tests/src/Interop/common/types.h
-@@ -28,7 +28,7 @@ typedef void* HMODULE;
- typedef void* ULONG_PTR;
- typedef unsigned error_t;
- typedef void* LPVOID;
--typedef char BYTE;
-+typedef unsigned char BYTE;
- typedef WCHAR OLECHAR;
-
- typedef unsigned int UINT_PTR;
-@@ -54,4 +54,4 @@ typedef int* DWORD_PTR;
- #define FALSE 0
- #endif
-
--#endif //_INTEROP_TYPES__H
-\ No newline at end of file
-+#endif //_INTEROP_TYPES__H
---
-2.10.2
-
diff --git a/llvm-39-move.patch b/llvm-39-move.patch
deleted file mode 100644
index 2c02d41c3f28..000000000000
--- a/llvm-39-move.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 7dfb2ed8614dea8c2fe757592436a38694e91ebc Mon Sep 17 00:00:00 2001
-From: Jan Vorlicek <janvorli@microsoft.com>
-Date: Fri, 28 Oct 2016 04:34:42 +0200
-Subject: [PATCH] Add missing std::move to one exception throw (#7865)
-
-We had the std::move missing in one of the exception throws. For some reason,
-the current clang didn't complain about it even though the copy constructor was
-deleted.
----
- src/vm/exceptionhandling.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/vm/exceptionhandling.cpp b/src/vm/exceptionhandling.cpp
-index e59f10e..ed155eb 100644
---- a/src/vm/exceptionhandling.cpp
-+++ b/src/vm/exceptionhandling.cpp
-@@ -4730,7 +4730,7 @@ VOID DECLSPEC_NORETURN DispatchManagedException(PAL_SEHException& ex, bool isHar
- }
- }
-
-- throw ex;
-+ throw std::move(ex);
- }
-
- #ifdef _AMD64_
---
-2.10.2
-