summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGr3q2019-10-05 12:21:06 +0100
committerGr3q2019-10-05 12:21:06 +0100
commit34c0fa974bbaee0ce1615c86371fe7612692837c (patch)
treec8fd22fda3367529a5dca5f38faeba3419bbc1e6
parent2703f89a43d15f9cd6d936ed141a0e70afcc5325 (diff)
downloadaur-34c0fa974bbaee0ce1615c86371fe7612692837c.tar.gz
Disable Aspnet-Runtime because it prevents installing the other packages on aarch64
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD20
2 files changed, 10 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e74116d29640..60b5f3d06077 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -45,13 +45,6 @@ pkgname = dotnet-runtime-2.1
optdepends = lttng-ust: CoreCLR tracing
provides = dotnet-runtime=2.1.13
-pkgname = aspnet-runtime-2.1
- pkgdesc = The ASP.NET Core runtime version 2.1
- arch = x86_64
- arch = armv7h
- depends = dotnet-runtime=2.1.13
- provides = aspnet-runtime=2.1.13
-
pkgname = dotnet-sdk-2.1
pkgdesc = The .NET Core SDK version 2.1
depends = dotnet-runtime=2.1.13
diff --git a/PKGBUILD b/PKGBUILD
index 574c75e76e72..17e492fdb97e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Attila Greguss <floyd0122[at]gmail[dot]com>
pkgbase=dotnet-core-2.1
-pkgname=('dotnet-host-2.1' 'dotnet-runtime-2.1' 'aspnet-runtime-2.1' 'dotnet-sdk-2.1')
+pkgname=('dotnet-host-2.1' 'dotnet-runtime-2.1' 'dotnet-sdk-2.1')
pkgver=2.1.13
pkgrel=1
arch=('x86_64' 'armv7h' 'aarch64')
@@ -47,16 +47,16 @@ package_dotnet-runtime-2.1() {
ln -s dotnet-host-2.1 "${pkgdir}"/usr/share/licenses/dotnet-runtime-2.1
}
-package_aspnet-runtime-2.1() {
- arch=('x86_64' 'armv7h')
- pkgdesc='The ASP.NET Core runtime version 2.1'
- depends=('dotnet-runtime=2.1.13')
- provides=("aspnet-runtime=${pkgver%+*}")
+#package_aspnet-runtime-2.1() {
+# arch=('x86_64' 'armv7h')
+# pkgdesc='The ASP.NET Core runtime version 2.1'
+# depends=('dotnet-runtime=2.1.13')
+# provides=("aspnet-runtime=${pkgver%+*}")
- install -dm 755 "${pkgdir}"/{opt/dotnet/shared,usr/share/licenses}
- cp -dr --no-preserve='ownership' shared/Microsoft.AspNetCore.App "${pkgdir}"/opt/dotnet/shared/
- ln -s dotnet-host-2.1 "${pkgdir}"/usr/share/licenses/aspnet-runtime-2.1
-}
+# install -dm 755 "${pkgdir}"/{opt/dotnet/shared,usr/share/licenses}
+# cp -dr --no-preserve='ownership' shared/Microsoft.AspNetCore.App "${pkgdir}"/opt/dotnet/shared/
+# ln -s dotnet-host-2.1 "${pkgdir}"/usr/share/licenses/aspnet-runtime-2.1
+#}
package_dotnet-sdk-2.1() {
pkgdesc='The .NET Core SDK version 2.1'