summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGr3q2020-04-16 21:58:17 +0100
committerGr3q2020-04-16 21:58:17 +0100
commit68943510aedb798966c4dc26700d1ee952316651 (patch)
tree12bac0165bc2bfb89c76e7e7f59d603840dd64f2
parentb5d295bf78902e99edd1408041c4499adb7e24d3 (diff)
downloadaur-68943510aedb798966c4dc26700d1ee952316651.tar.gz
Remove makedepends, add itself as conflicts
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c238f315aebf..c1c00fd37f04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,18 +6,6 @@ pkgbase = dotnet-core-2.1
arch = armv7h
arch = aarch64
license = MIT
- makedepends = clang
- makedepends = cmake
- makedepends = curl
- makedepends = git
- makedepends = icu
- makedepends = krb5
- makedepends = libunwind
- makedepends = lldb
- makedepends = llvm
- makedepends = lttng-ust
- makedepends = openssl
- makedepends = zlib
options = staticlibs
source_x86_64 = https://download.visualstudio.microsoft.com/download/pr/e730fe40-e2ea-42e5-a5d0-f86830d75849/571e5a2f4ebf9f8117878eeaad5cb19b/dotnet-sdk-2.1.805-linux-x64.tar.gz
sha512sums_x86_64 = ceceaf569060c313e9e1b519ad2bfda37bb11c4549689d01080bed84b8a1b64f4c8a35fce4622b2f951a7ccf574e7ea4552c076fa2ba302846d4e1c5ae5b3a0c
@@ -39,11 +27,14 @@ pkgname = dotnet-runtime-2.1
provides = dotnet-runtime-2.1
provides = dotnet-runtime=2.1.17.sdk805
conflicts = dotnet-runtime-2.1
+ conflicts = dotnet-runtime=2.1.17.sdk805
pkgname = dotnet-sdk-2.1
pkgdesc = The .NET Core SDK version 2.1
depends = dotnet-runtime-2.1
+ depends = glibc
provides = dotnet-sdk-2.1
provides = dotnet-sdk=2.1.17.sdk805
conflicts = dotnet-sdk-2.1
+ conflicts = dotnet-sdk=2.1.17.sdk805
diff --git a/PKGBUILD b/PKGBUILD
index ccda1dab8fa1..cd0143de63b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,10 +9,6 @@ pkgrel=2
arch=('x86_64' 'armv7h' 'aarch64')
url='https://www.microsoft.com/net/core'
license=('MIT')
-makedepends=(
- 'clang' 'cmake' 'curl' 'git' 'icu' 'krb5' 'libunwind' 'lldb' 'llvm'
- 'lttng-ust' 'openssl' 'zlib'
-)
options=('staticlibs')
source_armv7h=('https://download.visualstudio.microsoft.com/download/pr/57666a6d-0c82-4431-b251-f70356a1b6f7/8190a9b4ff5e962eb4547955c88848c3/dotnet-sdk-2.1.805-linux-arm.tar.gz')
source_aarch64=('https://download.visualstudio.microsoft.com/download/pr/e9a7e3c5-2db0-4eb2-9dc4-cc7060d0ee81/1ed6a7621a066dd15a06d4bb4a894a29/dotnet-sdk-2.1.805-linux-arm64.tar.gz')
@@ -30,7 +26,7 @@ package_dotnet-runtime-2.1() {
'libcurl.so')
optdepends=('lttng-ust: CoreCLR tracing')
provides=("dotnet-runtime-2.1" "dotnet-runtime=${pkgver}")
- conflicts=("dotnet-runtime-2.1")
+ conflicts=("dotnet-runtime-2.1" "dotnet-runtime=${pkgver}")
install -dm 755 "${pkgdir}"/usr/share/{dotnet/shared,licenses}
cp -dr --no-preserve='ownership' shared/Microsoft.NETCore.App "${pkgdir}"/usr/share/dotnet/shared/
@@ -39,9 +35,9 @@ package_dotnet-runtime-2.1() {
package_dotnet-sdk-2.1() {
pkgdesc='The .NET Core SDK version 2.1'
- depends=('dotnet-runtime-2.1')
+ depends=('dotnet-runtime-2.1' 'glibc')
provides=("dotnet-sdk-2.1" "dotnet-sdk=${pkgver}")
- conflicts=("dotnet-sdk-2.1")
+ conflicts=("dotnet-sdk-2.1" "dotnet-sdk=${pkgver}")
install -dm 755 "${pkgdir}"/usr/share/{dotnet,licenses}
cp -dr --no-preserve='ownership' sdk "${pkgdir}"/usr/share/dotnet/