summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGr3q2020-04-16 21:54:36 +0100
committerGr3q2020-04-16 21:54:36 +0100
commit7cdda9cc0c074f102e8823b992328c2f90f1148e (patch)
tree648d4a248d431f41dfb8c0f30c1122baa701ead1
parent6f204dd917c96f863e51f69705457cf5da7373bf (diff)
downloadaur-7cdda9cc0c074f102e8823b992328c2f90f1148e.tar.gz
Remove makedepends, resolve conflict between 3.0 and 3.1 SDK
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD18
2 files changed, 14 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15cb70aebb5b..576cb29010f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,11 @@
pkgbase = dotnet-core-3.0
pkgver = 3.0.3.sdk103
- pkgrel = 1
+ pkgrel = 2
url = https://www.microsoft.com/net/core
arch = x86_64
arch = armv7h
arch = aarch64
license = MIT
- makedepends = clang
- makedepends = cmake
- makedepends = curl
- makedepends = git
- makedepends = icu
- makedepends = krb5
- makedepends = libunwind
- makedepends = lldb
- makedepends = llvm
- makedepends = lttng-ust
- makedepends = openssl
- makedepends = zlib
options = staticlibs
source_x86_64 = https://download.visualstudio.microsoft.com/download/pr/43f3a3bd-3df2-41e6-beca-3ec4952ca6c4/30fe7779249607d1bb3bb4b20d61a479/dotnet-sdk-3.0.103-linux-x64.tar.gz
sha512sums_x86_64 = 22acd337c1f837c586b9d0e3581feeba828c7d6dc64e4c6c9b24bdc6159c635eb7019c3fb0534edeb4f84971e9c3584c7e3a4d80854cf5664d2792ee8fde189b
@@ -32,6 +20,7 @@ pkgname = aspnet-runtime-3.0
provides = aspnet-runtime-3.0
provides = aspnet-runtime=3.0.3.sdk103
conflicts = aspnet-runtime-3.0
+ conflicts = aspnet-runtime=3.0.3.sdk103
pkgname = dotnet-runtime-3.0
pkgdesc = The .NET Core runtime (binary) - End-of-life
@@ -46,12 +35,15 @@ pkgname = dotnet-runtime-3.0
provides = dotnet-runtime-3.0
provides = dotnet-runtime=3.0.3.sdk103
conflicts = dotnet-runtime-3.0
+ conflicts = dotnet-runtime=3.0.3.sdk103
pkgname = dotnet-sdk-3.0
pkgdesc = The .NET Core SDK (binary) - End-of-life
depends = dotnet-runtime-3.0
+ depends = dotnet-sdk>=3.1
+ depends = glibc
provides = dotnet-sdk-3.0
provides = dotnet-sdk=3.0.3.sdk103
conflicts = dotnet-sdk-3.0
- conflicts = dotnet-sdk>=3
+ conflicts = dotnet-sdk=3.0.3.sdk103
diff --git a/PKGBUILD b/PKGBUILD
index e075d38d3210..359fa4a29ee5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,10 @@ pkgname=( 'aspnet-runtime-3.0' 'dotnet-runtime-3.0' 'dotnet-sdk-3.0')
pkgver=3.0.3.sdk103
_runtimever=3.0.3
_sdkver=3.0.103
-pkgrel=1
+pkgrel=2
arch=('x86_64' 'armv7h' 'aarch64')
url='https://www.microsoft.com/net/core'
license=('MIT')
-makedepends=(
- 'clang' 'cmake' 'curl' 'git' 'icu' 'krb5' 'libunwind' 'lldb' 'llvm'
- 'lttng-ust' 'openssl' 'zlib'
-)
options=('staticlibs')
source_armv7h=('https://download.visualstudio.microsoft.com/download/pr/4a44d4d2-19c1-485a-8b58-fa06805cddcf/cc805a1ebd9d72099309dcd46492d36f/dotnet-sdk-3.0.103-linux-arm.tar.gz')
source_aarch64=('https://download.visualstudio.microsoft.com/download/pr/eb4ffaf1-b0a9-466d-8440-0220dca8f806/48df585d8d978c5418fa514da6a2bd9b/dotnet-sdk-3.0.103-linux-arm64.tar.gz')
@@ -27,7 +23,7 @@ package_dotnet-runtime-3.0() {
'libcurl.so')
optdepends=('lttng-ust: CoreCLR tracing')
provides=("dotnet-runtime-3.0" "dotnet-runtime=${pkgver}")
- conflicts=("dotnet-runtime-3.0")
+ conflicts=("dotnet-runtime-3.0" "dotnet-runtime=${pkgver}")
install -dm 755 "${pkgdir}"/usr/share/{dotnet/shared,licenses}
cp -dr --no-preserve='ownership' shared/Microsoft.NETCore.App "${pkgdir}"/usr/share/dotnet/shared/
@@ -38,7 +34,7 @@ package_aspnet-runtime-3.0() {
pkgdesc='The ASP.NET Core runtime (binary) - End-of-life'
depends=('dotnet-runtime-3.0')
provides=("aspnet-runtime-3.0" "aspnet-runtime=${pkgver}")
- conflicts=("aspnet-runtime-3.0")
+ conflicts=("aspnet-runtime-3.0" "aspnet-runtime=${pkgver}")
install -dm 755 "${pkgdir}"/usr/share/{dotnet/shared,licenses}
cp -dr --no-preserve='ownership' shared/Microsoft.AspNetCore.App "${pkgdir}"/usr/share/dotnet/shared/
@@ -47,10 +43,12 @@ package_aspnet-runtime-3.0() {
package_dotnet-sdk-3.0() {
pkgdesc='The .NET Core SDK (binary) - End-of-life'
- depends=('dotnet-runtime-3.0')
+ depends=('dotnet-runtime-3.0' 'dotnet-sdk>=3.1' 'glibc')
provides=("dotnet-sdk-3.0" "dotnet-sdk=${pkgver}")
- conflicts=("dotnet-sdk-3.0" "dotnet-sdk>=3")
+ conflicts=("dotnet-sdk-3.0" "dotnet-sdk=${pkgver}")
install -dm 755 "${pkgdir}"/usr/share/{dotnet,licenses}
- cp -dr --no-preserve='ownership' packs sdk templates "${pkgdir}"/usr/share/dotnet/
+ # Not copying packs because /usr/share/dotnet/packs/NETStandard.Library.Ref/2.1.0/ contained in 3.1
+ # as well, depend on it instead
+ cp -dr --no-preserve='ownership' sdk templates "${pkgdir}"/usr/share/dotnet/
ln -s dotnet-host-bin "${pkgdir}"/usr/share/licenses/dotnet-sdk-3.0
} \ No newline at end of file