summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGr3q2020-01-16 09:46:27 +0000
committerGr3q2020-01-16 09:46:27 +0000
commit3962062664b776c88e6a71f0ab1dd3e754ca64c2 (patch)
tree46a4fda70cabf12c70e3fe814fb226459eeba8f9
parent3df402022857d16e0ff9e21df83b0b345f8d1f3e (diff)
downloadaur-3962062664b776c88e6a71f0ab1dd3e754ca64c2.tar.gz
Add additional provides strings so dependency handling is properly working
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93e23833238c..c863f15a8075 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dotnet-core-bin
pkgver = 3.1.1.sdk101
- pkgrel = 1
+ pkgrel = 2
url = https://www.microsoft.com/net/core
arch = x86_64
arch = armv7h
@@ -37,6 +37,7 @@ pkgname = aspnet-runtime-bin
pkgdesc = The ASP.NET Core runtime (binary)
depends = dotnet-runtime-3.1
provides = aspnet-runtime-3.1
+ provides = aspnet-runtime=3.1.1.sdk101
conflicts = aspnet-runtime-3.1
pkgname = dotnet-runtime-bin
@@ -50,11 +51,13 @@ pkgname = dotnet-runtime-bin
depends = libcurl.so
optdepends = lttng-ust: CoreCLR tracing
provides = dotnet-runtime-3.1
+ provides = dotnet-runtime=3.1.1.sdk101
conflicts = dotnet-runtime-3.1
pkgname = dotnet-sdk-bin
pkgdesc = The .NET Core SDK (binary)
depends = dotnet-runtime-3.1
provides = dotnet-sdk-3.1
+ provides = dotnet-sdk=3.1.1.sdk101
conflicts = dotnet-sdk-3.1
diff --git a/PKGBUILD b/PKGBUILD
index 9d9460546e22..8a0588a95fa7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=('dotnet-host-bin' 'aspnet-runtime-bin' 'dotnet-runtime-bin' 'dotnet-sdk
pkgver=3.1.1.sdk101
_runtimever=3.1.1
_sdkver=3.1.101
-pkgrel=1
+pkgrel=2
arch=('x86_64' 'armv7h' 'aarch64')
url='https://www.microsoft.com/net/core'
license=('MIT')
@@ -41,7 +41,7 @@ package_dotnet-runtime-bin() {
depends=('dotnet-host' 'icu' 'krb5' 'libunwind' 'openssl' 'zlib'
'libcurl.so')
optdepends=('lttng-ust: CoreCLR tracing')
- provides=("dotnet-runtime-3.1")
+ provides=("dotnet-runtime-3.1" "dotnet-runtime=${pkgver}")
conflicts=("dotnet-runtime-3.1")
install -dm 755 "${pkgdir}"/usr/share/{dotnet/shared,licenses}
@@ -52,7 +52,7 @@ package_dotnet-runtime-bin() {
package_aspnet-runtime-bin() {
pkgdesc='The ASP.NET Core runtime (binary)'
depends=('dotnet-runtime-3.1')
- provides=("aspnet-runtime-3.1")
+ provides=("aspnet-runtime-3.1" "aspnet-runtime=${pkgver}")
conflicts=("aspnet-runtime-3.1")
install -dm 755 "${pkgdir}"/usr/share/{dotnet/shared,licenses}
@@ -63,7 +63,7 @@ package_aspnet-runtime-bin() {
package_dotnet-sdk-bin() {
pkgdesc='The .NET Core SDK (binary)'
depends=('dotnet-runtime-3.1')
- provides=("dotnet-sdk-3.1")
+ provides=("dotnet-sdk-3.1" "dotnet-sdk=${pkgver}")
conflicts=("dotnet-sdk-3.1")
install -dm 755 "${pkgdir}"/usr/share/{dotnet,licenses}
cp -dr --no-preserve='ownership' packs sdk templates "${pkgdir}"/usr/share/dotnet/