summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAttila Greguss2019-10-07 10:46:49 +0100
committerAttila Greguss2019-10-07 10:46:49 +0100
commit5de219abb6629c3d437022fa0c424b27674d470e (patch)
tree5a18d01d419c2370f8cd183f1c397872875e7f0d
parent8358fbcbfd227f93409f70d6039331a62e79df0c (diff)
downloadaur-5de219abb6629c3d437022fa0c424b27674d470e.tar.gz
Split dotnet-sdk out to provide the correct version number
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD18
2 files changed, 9 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a9f73cfda7b..d304850ffa49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -50,8 +50,3 @@ pkgname = dotnet-runtime-bin
optdepends = lttng-ust: CoreCLR tracing
provides = dotnet-runtime=3.0.0
-pkgname = dotnet-sdk-bin
- pkgdesc = The .NET Core SDK (binary)
- depends = dotnet-runtime=3.0.0
- provides = dotnet-sdk=3.0.100
-
diff --git a/PKGBUILD b/PKGBUILD
index c82a58bd2941..78e03ed2a01e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Attila Greguss <floyd0122[at]gmail[dot]com>
pkgbase=dotnet-core-bin
-pkgname=('dotnet-host-bin' 'aspnet-runtime-bin' 'dotnet-runtime-bin' 'dotnet-sdk-bin')
+pkgname=('dotnet-host-bin' 'aspnet-runtime-bin' 'dotnet-runtime-bin')
pkgver=3.0.0
pkgrel=5
arch=('x86_64' 'armv7h' 'aarch64')
@@ -54,12 +54,12 @@ package_aspnet-runtime-bin() {
ln -s dotnet-host-bin "${pkgdir}"/usr/share/licenses/aspnet-runtime-bin
}
-package_dotnet-sdk-bin() {
- pkgdesc='The .NET Core SDK (binary)'
- depends=('dotnet-runtime=3.0.0')
- provides=("dotnet-sdk=3.0.100")
+#package_dotnet-sdk-bin() {
+# pkgdesc='The .NET Core SDK (binary)'
+# depends=('dotnet-runtime=3.0.0')
+# provides=("dotnet-sdk=3.0.100")
- install -dm 755 "${pkgdir}"/{opt/dotnet,usr/share/licenses}
- cp -dr --no-preserve='ownership' packs sdk templates "${pkgdir}"/opt/dotnet/
- ln -s dotnet-host-bin "${pkgdir}"/usr/share/licenses/dotnet-sdk-bin
-}
+# install -dm 755 "${pkgdir}"/{opt/dotnet,usr/share/licenses}
+# cp -dr --no-preserve='ownership' packs sdk templates "${pkgdir}"/opt/dotnet/
+# ln -s dotnet-host-bin "${pkgdir}"/usr/share/licenses/dotnet-sdk-bin
+#}