summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAttila Greguss2019-10-05 12:21:25 +0100
committerAttila Greguss2019-10-05 12:21:25 +0100
commitb34453d865b208f83143c106a6bf4cd178df5a32 (patch)
tree289e3c0a6052de40bc5a4b6644fe22b37535ce60
parent040e6aa70ab7dd649f24b40b7a3c2ab8f3dc9b54 (diff)
downloadaur-b34453d865b208f83143c106a6bf4cd178df5a32.tar.gz
Disable Aspnet-Runtime because it prevents installing the other packages on aarch64
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD20
2 files changed, 10 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5269444e46a..59d932782e83 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -45,13 +45,6 @@ pkgname = dotnet-runtime-bin
optdepends = lttng-ust: CoreCLR tracing
provides = dotnet-runtime=3.0.100
-pkgname = aspnet-runtime-bin
- pkgdesc = The ASP.NET Core runtime (binary)
- arch = x86_64
- arch = armv7h
- depends = dotnet-runtime=3.0.100
- provides = aspnet-runtime=3.0.100
-
pkgname = dotnet-sdk-bin
pkgdesc = The .NET Core SDK (binary)
depends = dotnet-runtime=3.0.100
diff --git a/PKGBUILD b/PKGBUILD
index 81724627778b..1c1a22e7b9d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Attila Greguss <floyd0122[at]gmail[dot]com>
pkgbase=dotnet-core-bin
-pkgname=('dotnet-host-bin' 'dotnet-runtime-bin' 'aspnet-runtime-bin' 'dotnet-sdk-bin')
+pkgname=('dotnet-host-bin' 'dotnet-runtime-bin' 'dotnet-sdk-bin')
pkgver=3.0.100
pkgrel=4
arch=('x86_64' 'armv7h' 'aarch64')
@@ -44,16 +44,16 @@ package_dotnet-runtime-bin() {
ln -s dotnet-host-bin "${pkgdir}"/usr/share/licenses/dotnet-runtime-bin
}
-package_aspnet-runtime-bin() {
- arch=('x86_64' 'armv7h')
- pkgdesc='The ASP.NET Core runtime (binary)'
- depends=('dotnet-runtime=3.0.100')
- provides=("aspnet-runtime=${pkgver%+*}")
+#package_aspnet-runtime-bin() {
+# arch=('x86_64' 'armv7h')
+# pkgdesc='The ASP.NET Core runtime (binary)'
+# depends=('dotnet-runtime=3.0.100')
+# provides=("aspnet-runtime=${pkgver%+*}")
- install -dm 755 "${pkgdir}"/{opt/dotnet/shared,usr/share/licenses}
- cp -dr --no-preserve='ownership' shared/Microsoft.AspNetCore.App "${pkgdir}"/opt/dotnet/shared/
- ln -s dotnet-host-bin "${pkgdir}"/usr/share/licenses/aspnet-runtime-bin
-}
+# install -dm 755 "${pkgdir}"/{opt/dotnet/shared,usr/share/licenses}
+# cp -dr --no-preserve='ownership' shared/Microsoft.AspNetCore.App "${pkgdir}"/opt/dotnet/shared/
+# ln -s dotnet-host-bin "${pkgdir}"/usr/share/licenses/aspnet-runtime-bin
+#}
package_dotnet-sdk-bin() {
pkgdesc='The .NET Core SDK (binary)'