summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Maunier2022-08-12 10:52:56 +0200
committerFlorian Maunier2022-08-12 10:52:56 +0200
commit69db0979f701a989d3e7b8d774c981016cf34e82 (patch)
tree00bfc7204e53347ffbb8d7ead550b770914582d3
parent647e1ce20d20a489abf8a3780d51c9c47734d696 (diff)
downloadaur-69db0979f701a989d3e7b8d774c981016cf34e82.tar.gz
Fix wrong replaces
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24900a01abfb..221f81fee258 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dotnet-core-preview-bin
pkgver = 7.0.0.sdk100+preview.7
- pkgrel = 1
+ pkgrel = 2
url = https://www.microsoft.com/net/core
arch = armv7h
arch = aarch64
@@ -28,7 +28,7 @@ pkgname = dotnet-host-preview-bin
provides = dotnet-host
provides = dotnet-host=7.0.0
conflicts = dotnet-host
- replaces = dotnet-host-preview-bin
+ replaces = dotnet-host-preview
pkgname = aspnet-runtime-preview-bin
pkgdesc = The ASP.NET Core runtime (preview, binary)
@@ -36,7 +36,7 @@ pkgname = aspnet-runtime-preview-bin
provides = aspnet-runtime=7.0.0
provides = aspnet-runtime-7.0
conflicts = aspnet-runtime=7.0.0
- replaces = aspnet-runtime-preview-bin
+ replaces = aspnet-runtime-preview
pkgname = dotnet-runtime-preview-bin
pkgdesc = The .NET Core runtime (preview, binary)
@@ -53,7 +53,7 @@ pkgname = dotnet-runtime-preview-bin
provides = dotnet-runtime=7.0.0
provides = dotnet-runtime-7.0
conflicts = dotnet-runtime=7.0.0
- replaces = dotnet-runtime-preview-bin
+ replaces = dotnet-runtime-preview
pkgname = dotnet-sdk-preview-bin
pkgdesc = The .NET Core SDK (preview, binary)
@@ -65,7 +65,7 @@ pkgname = dotnet-sdk-preview-bin
provides = dotnet-sdk=7.0.100
provides = dotnet-sdk-7.0
conflicts = dotnet-sdk=7.0.100
- replaces = dotnet-sdk-preview-bin
+ replaces = dotnet-sdk-preview
pkgname = dotnet-targeting-pack-preview-bin
pkgdesc = The .NET Core targeting pack (preview, binary)
@@ -73,7 +73,7 @@ pkgname = dotnet-targeting-pack-preview-bin
provides = dotnet-targeting-pack=7.0.0
provides = dotnet-targeting-pack-7.0
conflicts = dotnet-targeting-pack=7.0.0
- replaces = dotnet-targeting-pack-preview-bin
+ replaces = dotnet-targeting-pack-preview
pkgname = aspnet-targeting-pack-preview-bin
pkgdesc = The ASP.NET Core targeting pack (preview, binary)
@@ -81,4 +81,4 @@ pkgname = aspnet-targeting-pack-preview-bin
provides = aspnet-targeting-pack=7.0.0
provides = aspnet-targeting-pack-7.0
conflicts = aspnet-targeting-pack=7.0.0
- replaces = aspnet-targeting-pack-preview-bin
+ replaces = aspnet-targeting-pack-preview
diff --git a/PKGBUILD b/PKGBUILD
index dfb8c4b05c8e..b5caef924194 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,7 +18,7 @@ _hostver=7.0.0-preview.7.22375.6
_dotnetruntimever=7.0.0-preview.7.22375.6
_aspnetruntimever=7.0.0-preview.7.22376.6
_sdkver=7.0.100-preview.7.22377.5
-pkgrel=1
+pkgrel=2
arch=(armv7h aarch64 x86_64)
url=https://www.microsoft.com/net/core
license=(MIT)
@@ -43,7 +43,7 @@ package_dotnet-host-preview-bin() {
depends=(glibc)
provides=(dotnet-host dotnet-host=${_hostver%-*})
conflicts=(dotnet-host)
- replaces=(dotnet-host-preview-bin)
+ replaces=(dotnet-host-preview)
install -dm 755 "${pkgdir}"/usr/{bin,lib,share/{dotnet,licenses/dotnet-host-preview-bin}}
cp -dr --no-preserve='ownership' dotnet host "${pkgdir}"/usr/share/dotnet/
@@ -73,7 +73,7 @@ package_dotnet-runtime-preview-bin() {
'msquic>=2.0.0: HTTP/3 support with System.Net.Quic')
provides=(dotnet-runtime=${_dotnetruntimever%-*} dotnet-runtime-7.0)
conflicts=(dotnet-runtime=${_dotnetruntimever%-*})
- replaces=(dotnet-runtime-preview-bin)
+ replaces=(dotnet-runtime-preview)
install -dm 755 "${pkgdir}"/usr/share/{dotnet/shared,licenses}
cp -dr --no-preserve='ownership' shared/Microsoft.NETCore.App "${pkgdir}"/usr/share/dotnet/shared/
@@ -85,7 +85,7 @@ package_aspnet-runtime-preview-bin() {
depends=(dotnet-runtime-preview-bin)
provides=(aspnet-runtime=${_aspnetruntimever%-*} aspnet-runtime-7.0)
conflicts=(aspnet-runtime=${_aspnetruntimever%-*})
- replaces=(aspnet-runtime-preview-bin)
+ replaces=(aspnet-runtime-preview)
install -dm 755 "${pkgdir}"/usr/share/{dotnet/shared,licenses}
cp -dr --no-preserve='ownership' shared/Microsoft.AspNetCore.App "${pkgdir}"/usr/share/dotnet/shared/
@@ -103,7 +103,7 @@ package_dotnet-sdk-preview-bin() {
optdepends=('aspnet-targeting-pack-preview-bin: Build ASP.NET Core applications')
provides=(dotnet-sdk=${_sdkver%-*} dotnet-sdk-7.0)
conflicts=(dotnet-sdk=${_sdkver%-*})
- replaces=(dotnet-sdk-preview-bin)
+ replaces=(dotnet-sdk-preview)
install -dm 755 "${pkgdir}"/usr/share/{dotnet,licenses}
cp -dr --no-preserve='ownership' sdk sdk-manifests templates "${pkgdir}"/usr/share/dotnet/
@@ -114,7 +114,7 @@ package_dotnet-sdk-preview-bin() {
# pkgdesc='The .NET Standard targeting pack (preview, binary)'
# provides=(netstandard-targeting-pack-2.1)
# conflicts=(netstandard-targeting-pack-2.1)
-# replaces=(netstandard-targeting-pack-preview-bin)
+# replaces=(netstandard-targeting-pack-preview)
# install -dm 755 "${pkgdir}"/usr/share/{dotnet,dotnet/packs,licenses}
# cp -dr --no-preserve='ownership' packs/NETStandard.Library.Ref "${pkgdir}"/usr/share/dotnet/packs/
@@ -126,7 +126,7 @@ package_dotnet-targeting-pack-preview-bin() {
depends=(netstandard-targeting-pack-2.1)
provides=(dotnet-targeting-pack=${_dotnetruntimever%-*} dotnet-targeting-pack-7.0)
conflicts=(dotnet-targeting-pack=${_dotnetruntimever%-*})
- replaces=(dotnet-targeting-pack-preview-bin)
+ replaces=(dotnet-targeting-pack-preview)
if [ $CARCH = 'x86_64' ]; then msarch=x64;
elif [ $CARCH = 'aarch64' ]; then msarch=arm64;
@@ -142,7 +142,7 @@ package_aspnet-targeting-pack-preview-bin() {
depends=(dotnet-targeting-pack-preview-bin)
provides=(aspnet-targeting-pack=${_aspnetruntimever%-*} aspnet-targeting-pack-7.0)
conflicts=(aspnet-targeting-pack=${_aspnetruntimever%-*})
- replaces=(aspnet-targeting-pack-preview-bin)
+ replaces=(aspnet-targeting-pack-preview)
install -dm 755 "${pkgdir}"/usr/share/{dotnet,dotnet/packs,licenses}
cp -dr --no-preserve='ownership' packs/Microsoft.AspNetCore.App.Ref "${pkgdir}"/usr/share/dotnet/packs/