summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Maunier2020-07-31 12:14:41 +0200
committerFlorian Maunier2020-07-31 12:14:41 +0200
commit868634da980441eac27264beefd4145306dbd639 (patch)
treef16a3c5847584a0367c980ba88b18873c012bf55
parentf08b3ffa3789d03041a4042f00fd4cdbc7b52a37 (diff)
downloadaur-868634da980441eac27264beefd4145306dbd639.tar.gz
Re-add versionned provides and conflicts
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD26
2 files changed, 26 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f68217f4c66..7fe44dd1bcf3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dotnet-core-preview
pkgver = 5.0.0+100+preview.7.20366.6
- pkgrel = 3
+ pkgrel = 4
url = https://www.microsoft.com/net/core
arch = x86_64
arch = armv7h
@@ -18,17 +18,19 @@ pkgname = dotnet-host-preview
pkgdesc = A generic driver for the .NET Core Command Line Interface (preview, binary)
depends = glibc
provides = dotnet-host
+ provides = dotnet-host=5.0.0
conflicts = dotnet-host
pkgname = aspnet-runtime-preview
pkgdesc = The ASP.NET Core runtime (preview, binary)
depends = dotnet-runtime-preview
+ provides = aspnet-runtime=5.0.0
provides = aspnet-runtime-5.0
- conflicts = aspnet-runtime-5.0
+ conflicts = aspnet-runtime=5.0.0
pkgname = dotnet-runtime-preview
pkgdesc = The .NET Core runtime (preview, binary)
- depends = dotnet-host-preview
+ depends = dotnet-host>=5.0.0
depends = glibc
depends = icu
depends = krb5
@@ -37,8 +39,9 @@ pkgname = dotnet-runtime-preview
depends = openssl
depends = zlib
optdepends = lttng-ust: CoreCLR tracing
+ provides = dotnet-runtime=5.0.0
provides = dotnet-runtime-5.0
- conflicts = dotnet-runtime-5.0
+ conflicts = dotnet-runtime=5.0.0
pkgname = dotnet-sdk-preview
pkgdesc = The .NET Core SDK (preview, binary)
@@ -47,18 +50,21 @@ pkgname = dotnet-sdk-preview
depends = glibc
depends = netstandard-targeting-pack
optdepends = aspnet-targeting-pack-preview: Build ASP.NET Core applications
+ provides = dotnet-sdk=5.0.100
provides = dotnet-sdk-5.0
- conflicts = dotnet-sdk-5.0
+ conflicts = dotnet-sdk=5.0.100
pkgname = dotnet-targeting-pack-preview
pkgdesc = The .NET Core targeting pack (preview, binary)
depends = netstandard-targeting-pack
+ provides = dotnet-targeting-pack=5.0.0
provides = dotnet-targeting-pack-5.0
- conflicts = dotnet-targeting-pack-5.0
+ conflicts = dotnet-targeting-pack=5.0.0
pkgname = aspnet-targeting-pack-preview
pkgdesc = The ASP.NET Core targeting pack (preview, binary)
depends = dotnet-targeting-pack-preview
+ provides = aspnet-targeting-pack=5.0.0
provides = aspnet-targeting-pack-5.0
- conflicts = aspnet-targeting-pack-5.0
+ conflicts = aspnet-targeting-pack=5.0.0
diff --git a/PKGBUILD b/PKGBUILD
index 1774844ad868..db366a4b6727 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@ pkgver=5.0.0+100+preview.7.20366.6
_hostver=5.0.0-preview.7.20364.11
_runtimever=5.0.0-preview.7.20365.19
_sdkver=5.0.100-preview.7.20366.6
-pkgrel=3
+pkgrel=4
arch=(x86_64 armv7h aarch64)
url=https://www.microsoft.com/net/core
license=(MIT)
@@ -32,7 +32,7 @@ sha512sums_aarch64=(34cc65a879c8dedf854e0bb5b8b3f415c7db1ea9281a868516b6c0fdbb6d
package_dotnet-host-preview() {
pkgdesc='A generic driver for the .NET Core Command Line Interface (preview, binary)'
depends=(glibc)
- provides=(dotnet-host)
+ provides=(dotnet-host dotnet-host=${_hostver%-*})
conflicts=(dotnet-host)
install -dm 755 "${pkgdir}"/usr/{bin,lib,share/{dotnet,licenses/dotnet-host-preview}}
@@ -45,7 +45,7 @@ package_dotnet-host-preview() {
package_dotnet-runtime-preview() {
pkgdesc='The .NET Core runtime (preview, binary)'
depends=(
- dotnet-host-preview
+ "dotnet-host>=${_hostver%-*}"
glibc
icu
krb5
@@ -56,8 +56,8 @@ package_dotnet-runtime-preview() {
)
optdepends=('lttng-ust: CoreCLR tracing')
- provides=(dotnet-runtime-5.0)
- conflicts=(dotnet-runtime-5.0)
+ provides=(dotnet-runtime=${_runtimever%-*} dotnet-runtime-5.0)
+ conflicts=(dotnet-runtime=${_runtimever%-*})
install -dm 755 "${pkgdir}"/usr/share/{dotnet/shared,licenses}
cp -dr --no-preserve='ownership' shared/Microsoft.NETCore.App "${pkgdir}"/usr/share/dotnet/shared/
@@ -67,8 +67,8 @@ package_dotnet-runtime-preview() {
package_aspnet-runtime-preview() {
pkgdesc='The ASP.NET Core runtime (preview, binary)'
depends=(dotnet-runtime-preview)
- provides=(aspnet-runtime-5.0)
- conflicts=(aspnet-runtime-5.0)
+ provides=(aspnet-runtime=${_runtimever%-*} aspnet-runtime-5.0)
+ conflicts=(aspnet-runtime=${_runtimever%-*})
install -dm 755 "${pkgdir}"/usr/share/{dotnet/shared,licenses}
cp -dr --no-preserve='ownership' shared/Microsoft.AspNetCore.App "${pkgdir}"/usr/share/dotnet/shared/
@@ -84,8 +84,8 @@ package_dotnet-sdk-preview() {
netstandard-targeting-pack
)
optdepends=('aspnet-targeting-pack-preview: Build ASP.NET Core applications')
- provides=(dotnet-sdk-5.0)
- conflicts=(dotnet-sdk-5.0)
+ provides=(dotnet-sdk=${_sdkver%-*} dotnet-sdk-5.0)
+ conflicts=(dotnet-sdk=${_sdkver%-*})
install -dm 755 "${pkgdir}"/usr/share/{dotnet,licenses}
cp -dr --no-preserve='ownership' sdk templates "${pkgdir}"/usr/share/dotnet/
@@ -105,8 +105,8 @@ package_dotnet-sdk-preview() {
package_dotnet-targeting-pack-preview() {
pkgdesc='The .NET Core targeting pack (preview, binary)'
depends=(netstandard-targeting-pack)
- provides=(dotnet-targeting-pack-5.0)
- conflicts=(dotnet-targeting-pack-5.0)
+ provides=(dotnet-targeting-pack=${_runtimever%-*} dotnet-targeting-pack-5.0)
+ conflicts=(dotnet-targeting-pack=${_runtimever%-*})
install -dm 755 "${pkgdir}"/usr/share/{dotnet,dotnet/packs,licenses}
cp -dr --no-preserve='ownership' packs/Microsoft.NETCore.App.{Host.linux-x64,Ref} "${pkgdir}"/usr/share/dotnet/packs/
@@ -116,8 +116,8 @@ package_dotnet-targeting-pack-preview() {
package_aspnet-targeting-pack-preview() {
pkgdesc='The ASP.NET Core targeting pack (preview, binary)'
depends=(dotnet-targeting-pack-preview)
- provides=(aspnet-targeting-pack-5.0)
- conflicts=(aspnet-targeting-pack-5.0)
+ provides=(aspnet-targeting-pack=${_runtimever%-*} aspnet-targeting-pack-5.0)
+ conflicts=(aspnet-targeting-pack=${_runtimever%-*})
install -dm 755 "${pkgdir}"/usr/share/{dotnet,dotnet/packs,licenses}
cp -dr --no-preserve='ownership' packs/Microsoft.AspNetCore.App.Ref "${pkgdir}"/usr/share/dotnet/packs/