summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Maunier2019-10-03 09:00:52 +0200
committerFlorian Maunier2019-10-03 09:00:52 +0200
commit080385387d63a23249bde8ab6bebea7134f6c010 (patch)
treed8499e68c608fa3e30304c3f79bc248cebe59483
parent1c5db78093b361d997d8393f3241451e1fb0f767 (diff)
downloadaur-dotnet-core-rc.tar.gz
Mirror dotnet-core-preview
-rw-r--r--.SRCINFO57
-rw-r--r--PKGBUILD78
-rwxr-xr-xdotnet.sh6
3 files changed, 104 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c6e2861f0f1..7076dd2bd82e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,36 +1,57 @@
pkgbase = dotnet-core-rc
- pkgver = 2.1.0
+ pkgver = 3.0.0+100+rc1.014190
pkgrel = 1
url = https://www.microsoft.com/net/core
arch = x86_64
+ arch = armv7h
+ arch = aarch64
license = MIT
- depends = gcc-libs
- depends = glibc
+ makedepends = clang
+ makedepends = cmake
+ makedepends = curl
+ makedepends = git
+ makedepends = icu
+ makedepends = krb5
+ makedepends = libunwind
+ makedepends = lldb
+ makedepends = llvm
+ makedepends = lttng-ust
+ makedepends = openssl
+ makedepends = zlib
options = staticlibs
- source = https://download.microsoft.com/download/D/0/B/D0B7F62D-9C5D-4CF3-AB6C-88F56B4FC1A9/dotnet-runtime-2.1.0-rc1-linux-x64.tar.gz
- sha256sums = f720cf96ec174369e1fa217be8935ad787fe7964eeb8b3f062dfc89c08d1736e
+ source = dotnet.sh
+ sha256sums = 4978b3a31a94032b425d2a2a9b5a17f506f36fb784fbfefdf2cfea9485a30f47
+ source_x86_64 = https://download.visualstudio.microsoft.com/download/pr/b81a2bd3-a8a4-4c7e-bd69-030f412ff7b4/3fc5f2c0481313daf2e18c348362ff3f/dotnet-sdk-3.0.100-rc1-014190-linux-x64.tar.gz
+ sha256sums_x86_64 = 4429853c24e054cd8ec0e471a41682da591888b9652d24021c761c0ba6be8d7f
+ source_armv7h = https://download.visualstudio.microsoft.com/download/pr/29f1b10f-758f-44fb-b14c-49833e5379aa/c259e43ccc84a77fdf4ab5feea6774b3/dotnet-sdk-3.0.100-rc1-014190-linux-arm.tar.gz
+ sha256sums_armv7h = 8b0f0f27e2e4fba85fb48117f771de306fec89943b13d61ce220db95eb732c90
+ source_aarch64 = https://download.visualstudio.microsoft.com/download/pr/19cc5d2e-6794-401a-8b57-29a96cbf21b5/f1de24385a2b5a8fcbebab3af9ec07c4/dotnet-sdk-3.0.100-rc1-014190-linux-arm64.tar.gz
+ sha256sums_aarch64 = 34dc98d4abbde383b4b2ce6836e321de074a8aaeb21163e9eb8d68fe2b88a918
pkgname = dotnet-host-rc
- pkgdesc = A generic driver for the .NET Core Command Line Interface
- provides = dotnet-host
+ pkgdesc = A generic driver for the .NET Core Command Line Interface (RC)
+ provides = dotnet-host=3.0.0+100
conflicts = dotnet-host
pkgname = dotnet-runtime-rc
- pkgdesc = The .NET Core runtime
- depends = gcc-libs
- depends = glibc
+ pkgdesc = The .NET Core runtime (RC)
depends = dotnet-host-rc
depends = icu
depends = krb5
depends = libunwind
- depends = lldb
- depends = lttng-ust
- depends = openssl-1.0
+ depends = openssl
depends = zlib
depends = libcurl.so
- depends = libuuid.so
- provides = dotnet-runtime-2.0
- provides = dotnet-runtime
- conflicts = dotnet-runtime-2.0
- conflicts = dotnet-runtime
+ optdepends = lttng-ust: CoreCLR tracing
+ provides = dotnet-runtime=3.0.0+100
+
+pkgname = aspnet-runtime-rc
+ pkgdesc = The ASP.NET Core runtime (RC)
+ depends = dotnet-runtime-rc
+ provides = aspnet-runtime=3.0.0+100
+
+pkgname = dotnet-sdk-rc
+ pkgdesc = The .NET Core SDK (RC)
+ depends = dotnet-runtime-rc
+ provides = dotnet-sdk=3.0.0+100
diff --git a/PKGBUILD b/PKGBUILD
index fe196e1a9dc9..7e8aea9c29c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,77 @@
-# Maintainer: Thomas Guillemard <me[at]thog[dot]eu>
+# Maintainer: Florian Maunier <fmauneko@dissidence.ovh>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Max Liebkies <mail@maxliebkies.de>
pkgbase=dotnet-core-rc
-pkgname=('dotnet-host-rc' 'dotnet-runtime-rc')
-pkgver=2.1.0
+pkgname=('dotnet-host-rc' 'dotnet-runtime-rc' 'aspnet-runtime-rc' 'dotnet-sdk-rc')
+pkgver=3.0.0+100+rc1.014190
pkgrel=1
-arch=('x86_64')
+arch=('x86_64' 'armv7h' 'aarch64')
url='https://www.microsoft.com/net/core'
license=('MIT')
-depends=('gcc-libs' 'glibc')
+makedepends=(
+ 'clang' 'cmake' 'curl' 'git' 'icu' 'krb5' 'libunwind' 'lldb' 'llvm'
+ 'lttng-ust' 'openssl' 'zlib'
+)
options=('staticlibs')
-source=('https://download.microsoft.com/download/D/0/B/D0B7F62D-9C5D-4CF3-AB6C-88F56B4FC1A9/dotnet-runtime-2.1.0-rc1-linux-x64.tar.gz')
-sha256sums=('f720cf96ec174369e1fa217be8935ad787fe7964eeb8b3f062dfc89c08d1736e')
+source=(
+ 'dotnet.sh'
+)
+source_x86_64=(
+ 'https://download.visualstudio.microsoft.com/download/pr/b81a2bd3-a8a4-4c7e-bd69-030f412ff7b4/3fc5f2c0481313daf2e18c348362ff3f/dotnet-sdk-3.0.100-rc1-014190-linux-x64.tar.gz'
+)
+source_armv7h=(
+ 'https://download.visualstudio.microsoft.com/download/pr/29f1b10f-758f-44fb-b14c-49833e5379aa/c259e43ccc84a77fdf4ab5feea6774b3/dotnet-sdk-3.0.100-rc1-014190-linux-arm.tar.gz'
+)
+source_aarch64=(
+ 'https://download.visualstudio.microsoft.com/download/pr/19cc5d2e-6794-401a-8b57-29a96cbf21b5/f1de24385a2b5a8fcbebab3af9ec07c4/dotnet-sdk-3.0.100-rc1-014190-linux-arm64.tar.gz'
+)
+sha256sums=('4978b3a31a94032b425d2a2a9b5a17f506f36fb784fbfefdf2cfea9485a30f47')
+sha256sums_x86_64=('4429853c24e054cd8ec0e471a41682da591888b9652d24021c761c0ba6be8d7f')
+sha256sums_armv7h=('8b0f0f27e2e4fba85fb48117f771de306fec89943b13d61ce220db95eb732c90')
+sha256sums_aarch64=('34dc98d4abbde383b4b2ce6836e321de074a8aaeb21163e9eb8d68fe2b88a918')
package_dotnet-host-rc() {
- pkgdesc='A generic driver for the .NET Core Command Line Interface'
- provides=('dotnet-host')
+ pkgdesc='A generic driver for the .NET Core Command Line Interface (RC)'
+ provides=("dotnet-host=${pkgver%+*}")
conflicts=('dotnet-host')
- install -dm 755 "${pkgdir}"/{opt/dotnet,usr/bin,usr/share/licenses/dotnet-host}
+ install -dm 755 "${pkgdir}"/{opt/dotnet,usr/share/licenses/dotnet-host-rc}
cp -dr --no-preserve='ownership' dotnet host "${pkgdir}"/opt/dotnet/
- install -m 644 *.txt -t "${pkgdir}"/usr/share/licenses/dotnet-host/
- ln -s /opt/dotnet/dotnet "${pkgdir}"/usr/bin/
+ cp -dr --no-preserve='ownership' LICENSE.txt ThirdPartyNotices.txt "${pkgdir}"/usr/share/licenses/dotnet-host-rc
+ install -Dm 755 "${srcdir}"/dotnet.sh "${pkgdir}"/usr/bin/dotnet
}
package_dotnet-runtime-rc() {
- pkgdesc='The .NET Core runtime'
- depends+=('dotnet-host-rc' 'icu' 'krb5' 'libunwind' 'lldb' 'lttng-ust' 'openssl-1.0' 'zlib'
- 'libcurl.so' 'libuuid.so')
- provides=('dotnet-runtime-2.0' 'dotnet-runtime')
- conflicts=('dotnet-runtime-2.0' 'dotnet-runtime')
+ pkgdesc='The .NET Core runtime (RC)'
+ depends=('dotnet-host-rc' 'icu' 'krb5' 'libunwind' 'openssl' 'zlib'
+ 'libcurl.so')
+ optdepends=('lttng-ust: CoreCLR tracing')
+ provides=("dotnet-runtime=${pkgver%+*}")
+
+ install -dm 755 "${pkgdir}"/{opt/dotnet/shared,usr/share/licenses}
+ cp -dr --no-preserve='ownership' shared/Microsoft.NETCore.App "${pkgdir}"/opt/dotnet/shared/
+ ln -s dotnet-host-rc "${pkgdir}"/usr/share/licenses/dotnet-runtime-rc
+}
+
+package_aspnet-runtime-rc() {
+ pkgdesc='The ASP.NET Core runtime (RC)'
+ depends=('dotnet-runtime-rc')
+ provides=("aspnet-runtime=${pkgver%+*}")
+
+ install -dm 755 "${pkgdir}"/{opt/dotnet/shared,usr/share/licenses}
+ cp -dr --no-preserve='ownership' shared/Microsoft.AspNetCore.App "${pkgdir}"/opt/dotnet/shared/
+ ln -s dotnet-host-rc "${pkgdir}"/usr/share/licenses/aspnet-runtime-rc
+}
+
+package_dotnet-sdk-rc() {
+ pkgdesc='The .NET Core SDK (RC)'
+ depends=('dotnet-runtime-rc')
+ provides=("dotnet-sdk=${pkgver%+*}")
install -dm 755 "${pkgdir}"/{opt/dotnet,usr/share/licenses}
- cp -dr --no-preserve='ownership' shared "${pkgdir}"/opt/dotnet/
- ln -s dotnet-host "${pkgdir}"/usr/share/licenses/dotnet-runtime
+ cp -dr --no-preserve='ownership' packs sdk templates "${pkgdir}"/opt/dotnet/
+ ln -s dotnet-host-rc "${pkgdir}"/usr/share/licenses/dotnet-sdk-rc
}
+# vim: ts=2 sw=2 et:
diff --git a/dotnet.sh b/dotnet.sh
new file mode 100755
index 000000000000..3e90896cdfd8
--- /dev/null
+++ b/dotnet.sh
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+export DOTNET_ROOT=/opt/dotnet
+exec /opt/dotnet/dotnet "$@"
+
+# vim: ts=2 sw=2 et: