summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Liebkies2017-06-30 14:04:52 +0200
committerMax Liebkies2017-06-30 14:04:52 +0200
commitf7832315f8a61974afd6937c1a30d5c5d69289bf (patch)
tree5ec58b4acf12b6ec431866fc7314af63a1ce5241
downloadaur-f7832315f8a61974afd6937c1a30d5c5d69289bf.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..563104c3c20a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = dotnet-runtime-2.0
+ pkgdesc = A command line utility for building, testing, packaging and running .NET Core applications and libraries
+ pkgver = 2.0.0_preview2_25407_01
+ pkgrel = 1
+ url = https://www.microsoft.com/net/core
+ arch = x86_64
+ license = MIT
+ depends = lldb
+ depends = libunwind
+ depends = icu
+ depends = lttng-ust
+ depends = openssl
+ depends = curl
+ depends = dotnet-host
+ conflicts = dotnet-lts
+ options = staticlibs
+ source = https://download.microsoft.com/download/8/5/8/85896F6E-C7F5-4ECA-ADF7-CCE8EFAD9AA6/dotnet-runtime-2.0.0-preview2-25407-01-linux-x64.tar.gz
+ sha256sums = 1fe615f179fef606b97d43ce07a491da9067716ff594f929b82d8772d461c027
+
+pkgname = dotnet-runtime-2.0
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6795f7d61f81
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+**.tar.gz
+**.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf80f9a52ff0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Max Liebkies <mail at maxliebkies dot de>
+
+pkgname=dotnet-runtime-2.0
+pkgver=2.0.0_preview2_25407_01
+pkgrel=1
+pkgdesc="A command line utility for building, testing, packaging and running .NET Core applications and libraries"
+arch=(x86_64)
+url="https://www.microsoft.com/net/core"
+license=('MIT')
+depends=('lldb' 'libunwind' 'icu' 'lttng-ust' 'openssl' 'curl' 'dotnet-host')
+options=('staticlibs')
+
+conflicts=('dotnet-lts')
+
+source=("https://download.microsoft.com/download/8/5/8/85896F6E-C7F5-4ECA-ADF7-CCE8EFAD9AA6/dotnet-runtime-2.0.0-preview2-25407-01-linux-x64.tar.gz")
+
+sha256sums=('1fe615f179fef606b97d43ce07a491da9067716ff594f929b82d8772d461c027')
+
+package() {
+ mkdir -p "${pkgdir}/opt/dotnet/shared/Microsoft.NETCore.App/"
+
+ cp --force --preserve=mode --recursive "${srcdir}/shared/Microsoft.NETCore.App/${pkgver//_/-}" "${pkgdir}/opt/dotnet/shared/Microsoft.NETCore.App/${pkgver//_/-}"
+
+ chown -R root:root "${pkgdir}/opt/dotnet"
+ find "${pkgdir}/opt/dotnet" -name *.dll -exec chmod 644 {} \;
+ find "${pkgdir}/opt/dotnet" -name *.exe -exec chmod 755 {} \;
+ find "${pkgdir}/opt/dotnet" -name *.so -exec chmod 755 {} \;
+}
+
+# vim:set ts=2 sw=2 et: