summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2020-11-10 02:49:22 +0300
committerorhun2020-11-10 02:49:22 +0300
commitb1d024d2c358f380ed6b69069482234909c55a37 (patch)
tree97313ae5a617ab34a129d32af2799a3214b23bee
downloadaur-b1d024d2c358f380ed6b69069482234909c55a37.tar.gz
Initial upload: dotter-rs-git 0.9.0.r1.g60f4f15-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD37
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cefe2538be1b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = dotter-rs-git
+ pkgdesc = A dotfile manager and templater written in Rust (git)
+ pkgver = 0.9.0.r1.g60f4f15
+ pkgrel = 1
+ url = https://github.com/SuperCuber/dotter
+ arch = x86_64
+ license = Unlicense
+ makedepends = cargo
+ makedepends = git
+ provides = dotter-rs
+ conflicts = dotter-rs
+ conflicts = dotter-rs-bin
+ source = git+https://github.com/SuperCuber/dotter
+ sha512sums = SKIP
+
+pkgname = dotter-rs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0758ff535a37
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# https://github.com/orhun/pkgbuilds
+
+pkgname=dotter-rs-git
+_pkgname=dotter
+pkgver=0.9.0.r1.g60f4f15
+pkgrel=1
+pkgdesc="A dotfile manager and templater written in Rust (git)"
+arch=('x86_64')
+url="https://github.com/SuperCuber/dotter"
+license=('Unlicense')
+makedepends=('cargo' 'git')
+conflicts=("${pkgname%-git}" "${pkgname%-git}-bin")
+provides=("${pkgname%-git}")
+source=("git+${url}")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_pkgname"
+ cargo build --release
+}
+
+check() {
+ cd "$_pkgname"
+ cargo test --release
+}
+
+package() {
+ cd "$_pkgname"
+ install -Dm 755 "target/release/$_pkgname" -t "$pkgdir/usr/bin"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$_pkgname"
+}